•   
  • 1
  • 141
  • 142
  • 143(current)
  • 144
  • 145
  • 208
  •   
Artwork Downloader
If you've removed Textures13.db you should also delete the Thumbnails folder (or run "texturecache.py R" to remove the artwork files that no longer exist in your database).

Not really sure what you mean by "they do not get inserted" - have you confirmed the logo/disc artwork is being associated correctly with your movies?

For instance, run "texturecache.py jd movies <moviename>" and confirm all the "art" entries are correct for <moviename>.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
What I meant with not being inserted is just that. Artwork downloader finds them, i download, they get downloaded and that's all lol. They dont show up. They previously did!!


EDIT: I dont use local files!

EDIT2: When using the "R" function the following prompts:

Found 5,347 orphaned files for 34,801 database files.

This is far too many orphaned files for this number of
database files - more than 5% - and something may be wrong.

Check your configuration, database, and Thumbnails folder.

Add "orphan.limit.check = no" to the properties file
if you wish to disable this check.


Where do I place the properties file?
(2014-11-30, 22:41)djhifi Wrote: What I meant with not being inserted is just that. Artwork downloader finds them, i download, they get downloaded and that's all lol. They dont show up. They previously did!!

EDIT: I dont use local files!

If you're not got "use local files" enabled then Artwork Downloader isn't downloading anything - it will be associating your movies with remote artwork.

You've probably screwed up your cache by deleting Textures13.db but not Thumbnails. Try running:
Code:
texturecache.py R
texturecache.py Xd

which should get Textures13.db and the Thumbnails folder back in sync.

Then try re-caching the artwork for one of your troublesome movies:
Code:
texturecache.py C movies <moviename>

Any errors would suggest the remote artwork is not accessible.

Confirming the state of your media library by looking at the artwork associations (texturecache.py jd movies <moviename>) is usually the first step to understanding why artwork is not being displayed.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
When using the "R" function the following prompts:

Found 5,347 orphaned files for 34,801 database files.

This is far too many orphaned files for this number of
database files - more than 5% - and something may be wrong.

Check your configuration, database, and Thumbnails folder.

Add "orphan.limit.check = no" to the properties file
if you wish to disable this check.

Where do I place the properties file?




-----------

EDIT 2: When running that "Jd" command, the following prompts:

XBMCquarto:~ # ./texturecache.py jd movies "Cold Comes The Night"
[
{
"art": {
"banner": "image://http://assets.fanart.tv/fanart/movies/210047/moviebanner/cold-comes-the-night-5311d61844608.jpg/",
"clearlogo": "image://http://assets.fanart.tv/fanart/movies/210047/hdmovielogo/cold-comes-the-night-539d7cb0dceeb.png/",
"discart": "image://http://assets.fanart.tv/fanart/movies/210047/moviedisc/cold-comes-the-night-5412530feee34.png/",
"fanart": "image://smb://POPCORNHOUR/USB-6/Filmes (HD7)/Movies/Cold Comes The Night (2014)/fanart.jpg/",
"poster": "image://http://image.tmdb.org/t/p/original/ceMpKE2i65abAG0lVi8J9vdcCuR.jpg/"
},
"file": "smb://POPCORNHOUR/USB-6/Filmes (HD7)/Movies/Cold Comes The Night (2014)/Cold Comes The Night (2014).mkv",
"label": "Cold Comes the Night",
"movieid": 2322,
"title": "Cold Comes the Night"


Ok...where can I understand what is going on then lol ?
In the same directory as texturecache.py (call it texturecache.cfg), or your current directory if that folder isn't writeable. Or in /storage/.config if you're using OpenELEC. Or just add "@Orphan.limit.check=no" on the command line when calling texturecache.py while using the R option.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Yeah, im using openelec and .config isnt reachable.

To make it reachable can you check if this is correct please?
(other than that and Im gonna use that command line lol):

[Config]
path = /storage/.config
available = yes
browsable = yes
public = yes
writable = yes
root preexec = mkdir -p /storage/.config


NOPE, i can't make .config folder reachable in windows with this edition of the samba config file Sad
The OpenELEC .config folder should be automatically reachable using Samba, it should appear as the "Configfiles" folder and you shouldn't have to do anything to make it accessible from Windows.

Another option is to use ssh:
Code:
echo "orphan.limit.check = no" >>/storage/.config/texturecache.cfg

(2014-11-30, 22:59)djhifi Wrote: Ok...where can I understand what is going on then lol ?

Looks fine. as expected your artwork is all remote (apart from the fanart) so fix your cache then force update the artwork.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Massive noob question. I've tried reading through the thread and the forum, however I think my question is too simple that it hasn’t been covered off.

I use Media Center Master for my movie organisation/artwork downloading etc.

I recently scraped my movie files in to XBMC (haswel nuc running OE 4.0.6) and only the poster/+1 fanart comes across. None of the clearart, diskart etc that I had downloaded in the individual folders created by MCM were showing up.

I ran Artwork downloader in XBMC, hoping it would either:
a) download the artwork from my individual movie folders on my network to xbmc. This was the preferrable option as I had taken some time changing the primary fanart.jpg to the fanart that I wanted for each of my 1050 odd movies
b) artwork download re-downloads all of the artwork, clearart, discart etc, and save it to my movie folder, overwriting the existing data. This way I could manage from XBMC, and my folders / XBMC match up.

I ran artwork downloader, and it seems to have downloaded different artwork from the internet again (so not point a.) and not saved it to my folders (so not point b.).

Could someone explain where Artwork Downloader gets the stuff from, and where it saves it? and whether its possible to get my locally saved artwork on to my movies?
Did you enable "Use local files" when running AD? Although this option assumes you have single movies per folder as that's all AD supports with this option enabled (AD will make a mess of your movies if you use this option and have multiple movies per folder).

You could read the discussion with djhifi immediately prior to yours to discover a method for viewing your media library metadata, which would answer your last two questions.

As for getting your locally saved artwork added to your movies, you've got two options: 1) use AD (it does work if you've organised your library how AD likes it organised and named all your artwork correctly, plus enabled the use local files option), or 2) if you're capable of running a script see the thread in my sig and read about the mklocal.py script (just discussed in the last 2-3 pages) - mklocal.py is a lot more flexible than AD (but not click-click easy - it's a script) when you just want to associate existing local artwork with your movies.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
i have recently started using disk images for each movie stored in xbmc.
i use media companion to scrape my movies, and the program does a very good job downloading the disc image as well. however by default the disk image never shows up in any of the view, i have extended script info as well, well in order for the disk image to show up i have to hit "get more" and choose the "disk art" option which pulls the disk image of Artwork downloader. i have like 2000+ movies, is there a way that xbmc automatically loads all the disk images? i have tried both the options in artwork downloader, to download disk images and keep it offline, and tried the other as well. but none works automatically to show the disk image, i have to manually do this for every movie. any help or guidence will help.
Do you have "Use local art" selected?
ASUS Chromebox M004U (LibreELEC 8.2/Aeon Nox SiLVO)--->HDMI--->Onkyo TX-NR646--->HDMI--->Panasonic P65VT30
(2014-12-05, 00:13)MANswers Wrote: i have recently started using disk images for each movie stored in xbmc.
i use media companion to scrape my movies, and the program does a very good job downloading the disc image as well. however by default the disk image never shows up in any of the view, i have extended script info as well, well in order for the disk image to show up i have to hit "get more" and choose the "disk art" option which pulls the disk image of Artwork downloader. i have like 2000+ movies, is there a way that xbmc automatically loads all the disk images? i have tried both the options in artwork downloader, to download disk images and keep it offline, and tried the other as well. but none works automatically to show the disk image, i have to manually do this for every movie. any help or guidence will help.

Maybe try reading the post above yours - you're hardly the first person to ask this.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-12-05, 00:18)wgstarks Wrote: Do you have "Use local art" selected?

Yes i have local art selected. But dont see the disc's for "Panel View". It works for a few other views though. Any idea on how this can be enabled?
(2014-12-05, 15:45)MANswers Wrote:
(2014-12-05, 00:18)wgstarks Wrote: Do you have "Use local art" selected?

Yes i have local art selected. But dont see the disc's for "Panel View". It works for a few other views though. Any idea on how this can be enabled?

Sounds like you need to contact the skin author, use a different skin, or edit the skin yourself to show the disc art for Panel View. I had to do this with the MultiPlex view on Aeon MQ5 skin.
(2014-12-06, 06:41)Ic3y Wrote:
(2014-12-05, 15:45)MANswers Wrote:
(2014-12-05, 00:18)wgstarks Wrote: Do you have "Use local art" selected?

Yes i have local art selected. But dont see the disc's for "Panel View". It works for a few other views though. Any idea on how this can be enabled?

Sounds like you need to contact the skin author, use a different skin, or edit the skin yourself to show the disc art for Panel View. I had to do this with the MultiPlex view on Aeon MQ5 skin.

Great. can u let me know which file/location u edited, i know a bit of programming, and i can compare the code snippet for other view vs panel view to figure that out.
  •   
  • 1
  • 141
  • 142
  • 143(current)
  • 144
  • 145
  • 208
  •   



Logout Mark Read Team Forum Stats Members Help
Artwork Downloader18
This forum uses Lukasz Tkacz MyBB addons.