•   
  • 1
  • 183
  • 184
  • 185(current)
  • 186
  • 187
  • 208
  •   
  Thread Closed
Artwork Downloader
(2017-07-18, 23:35)shedrock Wrote:
(2017-07-18, 14:34)Code101 Wrote: Sorry to be a total noob but once I have the API for tmdb do I just add it to the tmdb.py file? I did this but just get an error in the addon. Or do I have to "create application" on the site too?

If you are getting an error, it probably means you're entering it incorrectly. Make sure to use the Notepad++ editor. Changing the API key is all that is required, and yes, just the tmdb.py file is necessary to change.

Example:

Code:
API_KEY = 'enter-your-api-key-here'
Thanks shedrock. This fix works great.

Sent from my SM-N920P
Something is not right here.

After modifying the API's, the AD addon it seems working and downloading the artworks but nothing is showing, the screen is black.

Artworks downloaded.

Image

Nothing appears.

Image

Even when I try to manually choosing the artwork.

Image

Nothing appears.

Image

After you modify your API's do you still have the same issue as mine? Someone chime in.
Nvidia Shield TV 2015, Sony BRAVIA XBR55HX929, Yamaha Aventage RX-A3050, Dolby Atmos/DTS:X (5.1.4) Front Mains: Jamo C109, Surrounds: Jamo C103, FH/RH: Jamo C93, Center: Jamo C10 CEN and Subwoofer: Jamo J112 SUB
@iMak - I do not have this issue that you're having. Everything works just fine for me.
Galatians 6:7 (KJV) - Be not deceived; God is not mocked: for whatsoever a man soweth, that shall he also reap.
@shedrock

I know it's weird, the addon downloads the artworks but why nothing appears?! I shutdown Kodi and restarted the device but still the same.
Nvidia Shield TV 2015, Sony BRAVIA XBR55HX929, Yamaha Aventage RX-A3050, Dolby Atmos/DTS:X (5.1.4) Front Mains: Jamo C109, Surrounds: Jamo C103, FH/RH: Jamo C93, Center: Jamo C10 CEN and Subwoofer: Jamo J112 SUB
Still bug with tvshows and Leia, missing or changed sql query..
(2017-07-19, 23:10)iMak Wrote: @shedrock

I know it's weird, the addon downloads the artworks but why nothing appears?! I shutdown Kodi and restarted the device but still the same.

I am not sure what your problem could be. I am using Helix and Jarvis and I haven't had any issues since.

Here is an image to show that it works for me on Helix:

Image

Shedrock
Galatians 6:7 (KJV) - Be not deceived; God is not mocked: for whatsoever a man soweth, that shall he also reap.
(2017-07-16, 23:55)shedrock Wrote: I have fixed it. You just need to register your own API keys on fanart.tv and themoviedb.org. Once you've done that you just need to edit the following files:

\addons\script.artwork.downloader\lib\provider\fanarttv.py and \addons\script.artwork.downloader\lib\provider\tmdb.py

Note 1: For the fanart.tv API key I had to apply for the Project API Keys, the Personal API Keys option did not download all the artwork.
Note 2: For the themoviedb.org API key I applied for the Developer Key.

I used Notepad++ to edit the files and it can be downloaded HERE - Once you have that installed you can browse over to edit the (2) files.

On Windows:

Users/username/AppData/Roaming/Kodi/addons/script.artwork.downloader/lib/provider/fanarttv.py
Users/username/AppData/Roaming/Kodi/addons/script.artwork.downloader/lib/provider/tmdb.py


On Linux:

\\your.ip.address\kodi\addons\script.artwork.downloader\lib\provider\fanarttv.py
\\your.ip.address\kodi\addons\script.artwork.downloader\lib\provider\tmdb.py


Save and reboot.

That's it!

Shedrock

Thanks man!
It's working Smile

TMDB is a little annoying with the process of getting the API key.

So from now on, there won't be a public key for all, everyone should now put a personal key?
If so, the developer must add it to the settings.
I did a fresh install of Kodi 17 and Kodi 18 nightly, installed the addons and scraped some movies using Universal Movie Scraper, the scrapping was very slow and if I configure the addon to use any source from TMDB, it won't scrape.

I run Artwork Downloader and downloaded the files, but I'm still getting nothing on the screen, no artwork is showing.

This driving me crazy
Nvidia Shield TV 2015, Sony BRAVIA XBR55HX929, Yamaha Aventage RX-A3050, Dolby Atmos/DTS:X (5.1.4) Front Mains: Jamo C109, Surrounds: Jamo C103, FH/RH: Jamo C93, Center: Jamo C10 CEN and Subwoofer: Jamo J112 SUB
(2017-07-21, 00:28)iMak Wrote: I did a fresh install of Kodi 17 and Kodi 18 nightly, installed the addons and scraped some movies using Universal Movie Scraper, the scrapping was very slow and if I configure the addon to use any source from TMDB, it won't scrape.

I run Artwork Downloader and downloaded the files, but I'm still getting nothing on the screen, no artwork is showing.

This driving me crazy

I too use Universal Movie Scraper but I don't configure anything in it, and in AD I only select "use local files". I will try it on Krypton at some point this weekend, as well as Kodi 18 nightly and see what happens.

Maybe you should do like me and just use Helix (best kodi imo) which NEVER gives problems, or Gotham for that matter. Just saying.Big Grin
Galatians 6:7 (KJV) - Be not deceived; God is not mocked: for whatsoever a man soweth, that shall he also reap.
I'm pretty sure It's nothing wrong with Kodi version, a week ago everything was working just fine, scrapping and artwork downloading, etc. but suddenly all acting weird now. I also tried on SPMC with exactly same issue.
Nvidia Shield TV 2015, Sony BRAVIA XBR55HX929, Yamaha Aventage RX-A3050, Dolby Atmos/DTS:X (5.1.4) Front Mains: Jamo C109, Surrounds: Jamo C103, FH/RH: Jamo C93, Center: Jamo C10 CEN and Subwoofer: Jamo J112 SUB
@shedrock

Do you believe that all these problems was because of my Internet provider. I have switched the Internet to another provider and all is good. I don't know what they have blocked. Any idea?

EDIT:
I installed a VPN app and everything is back to normal. I will need to talk to my internet provider.
Nvidia Shield TV 2015, Sony BRAVIA XBR55HX929, Yamaha Aventage RX-A3050, Dolby Atmos/DTS:X (5.1.4) Front Mains: Jamo C109, Surrounds: Jamo C103, FH/RH: Jamo C93, Center: Jamo C10 CEN and Subwoofer: Jamo J112 SUB
(2017-07-16, 23:55)shedrock Wrote: I have fixed it. You just need to register your own API keys on fanart.tv and themoviedb.org. Once you've done that you just need to edit the following files:

\addons\script.artwork.downloader\lib\provider\fanarttv.py and \addons\script.artwork.downloader\lib\provider\tmdb.py

Note 1: For the fanart.tv API key I had to apply for the Project API Keys, the Personal API Keys option did not download all the artwork.
Note 2: For the themoviedb.org API key I applied for the Developer Key.

I used Notepad++ to edit the files and it can be downloaded HERE - Once you have that installed you can browse over to edit the (2) files.

On Windows:

Users/username/AppData/Roaming/Kodi/addons/script.artwork.downloader/lib/provider/fanarttv.py
Users/username/AppData/Roaming/Kodi/addons/script.artwork.downloader/lib/provider/tmdb.py


On Linux:

\\your.ip.address\kodi\addons\script.artwork.downloader\lib\provider\fanarttv.py
\\your.ip.address\kodi\addons\script.artwork.downloader\lib\provider\tmdb.py


Save and reboot.

That's it!

Shedrock

This solution DOES WORK (Thanks Shedrock) just do what it says, and it WILL fix the problem.

Applying for the APIs was a pain in the ass...simple enough, just sucked having to do it. What a pain in the ass overall for everyone though! lol
Thanks Shedrock for the wonderful solution!
Unfortunately, animated posters and fanarts cannot be downloaded.
They can be selected and previewed but they cannot be downloaded either automatically or manually.

Has anyone found a solution?
Thanks!
Hello,

I have a problem when i finishing scrapping all episodes on my series
when i open addons Artwork Download Manager to scraping clearlogo on my series
but suddenly clearlogo not downloaded and when i check my series
the clearlogo not downloading too

is this normal? i'm using KODI 17.3
and all addons is up to date version

sorry for my bad english
INTEL: Core i3 - HD 4400
KODI: 18.3
LIBRARY: Movies & TV Shows
OS: Windows 8 - Android 9 & Android 7
(2017-07-21, 09:46)hackademic Wrote: Thanks Shedrock for the wonderful solution!
Unfortunately, animated posters and fanarts cannot be downloaded.
They can be selected and previewed but they cannot be downloaded either automatically or manually.

Has anyone found a solution?
Thanks!

I don't know about the animated posters but it downloads fanart for me without any issues.
Galatians 6:7 (KJV) - Be not deceived; God is not mocked: for whatsoever a man soweth, that shall he also reap.
  •   
  • 1
  • 183
  • 184
  • 185(current)
  • 186
  • 187
  • 208
  •   
  Thread Closed
 
Thread Rating:
  • 18 Vote(s) - 4.44 Average



Logout Mark Read Team Forum Stats Members Help
Artwork Downloader4.4418