•   
  • 1
  • 200
  • 201
  • 202(current)
  • 203
  • 204
  • 208
  •   
Artwork Downloader
I tried now in the office, with windows this time ... not with the mac.

Same configuration also on Windows 17.6 + Aeon Mq7 2.0.75 ..

NOOOWay .... same issue. 

Clearat, gorgeous rotating Discart, logos........   E 'was great while it lasted Rofl
Last test.

Changing AeonMQ to Artict Zephyr, same issue, "No provider ID Found for looking up artwork"
Hi,

I'm working on adding the option of insert API keys through the Settings, instead of touching the code. And it's working well Smile

Do you think that can be a global working API keys? So I could use them as default for the addon.
And if it will stop working you will be able to modify it by yourself.
(2017-12-05, 20:23)burekas Wrote: Hi,

I'm working on adding the option of insert API keys through the Settings, instead touching the code. And it's working well Smile

Do you think that can be a global working API keys? So I could use them as default for the addon.
And when it stop working you can modify it by yourself.
Sounds good
(2017-12-05, 20:18)Bitter Wrote: Last test.

Changing AeonMQ to Artict Zephyr, same issue, "No provider ID Found for looking up artwork"
 Have you tried maybe to change to the default skin? just to make sure if it's actually skin result.
(2017-12-05, 21:07)burekas Wrote:
(2017-12-05, 20:18)Bitter Wrote: Last test.

Changing AeonMQ to Artict Zephyr, same issue, "No provider ID Found for looking up artwork"
 Have you tried maybe to change to the default skin? just to make sure if it's actually skin result. 
I have. Still same problem......
(2017-12-05, 21:07)burekas Wrote:  Have you tried maybe to change to the default skin? just to make sure if it's actually skin result.

Just now... Same result using ESTOUCHY.......ID NOT FOUND
(2017-12-05, 14:13)burekas Wrote:
(2017-12-05, 13:41)bigwillch Wrote:  This is great work, thanks so much for sharing! I can confirm that this fix works on my setup (using the Arctic Zephyr skin if that's relevant)

One thing that might need clarification is that people need to make sure to delete your commented instructions from the fanart.py and tmdb.py files as well as add their api keys (I didn't do this at first which resulted in errors)

It would be great if this code could make it into Martijn's main addon, with the ability to set the API keys in the UI so that they can persist over updates

Thanks again! Really glad to have logos back! 
Thank you.
I'm glad that it's helpful.

As I said, their problem with the provider ID is probably a skin issue (Aeon) that should be solve there.

Regarding the 'Comment', the user only need to replace the number with his own key, the comment there should not makes a problem.
The text that is written in the right side of to the '#' is a comment and should not supposed to break the code or something.

I think it's a good idea to add an option for insert the keys in the addon setting, instead of touching the code.
I will try to learn how to do this and post you an update if it will be..


Reminder:Fix for the fanart.tv problem with Fanarts & Posters results + Updated addon zip file 14.2.0.0 
I'd assumed the comment would be fine left there too, but I got this in the log (and artworkdownloader failed) when it was left in, which is why I removed it

Code:
09:50:46.212 T:1543500704   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.SyntaxError'>
                                            Error Contents: ('invalid syntax', ('/storage/.kodi/addons/script.artwork.downloader/lib/provider/tmdb.py', 34, 25, '22222222222222222222 with your own \n'))
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/script.artwork.downloader/default.py", line 39, in <module>
                                                from lib import provider
                                              File "/storage/.kodi/addons/script.artwork.downloader/lib/provider/__init__.py", line 22, in <module>
                                                from tmdb import TMDBProvider
                                            SyntaxError: ('invalid syntax', ('/storage/.kodi/addons/script.artwork.downloader/lib/provider/tmdb.py', 34, 25, '22222222222222222222 with your own \n'))
                                            -->End of Python script error report<--
Good luck with the config stuff! I know nothing about coding kodi otherwise I'd offer assistance Smile
(2017-12-05, 21:12)Bitter Wrote:
(2017-12-05, 21:07)burekas Wrote:  Have you tried maybe to change to the default skin? just to make sure if it's actually skin result.

Just now... Same result using ESTOUCHY.......ID NOT FOUND 
I was having the same problem in the last hour. I found that by switching from tmdb to universal movie scrapper my problem was corrected. I now suspect something with the last update tmdb scrapper.
I'm also using universal as a scraper.
Maybe the problem is there, what scraper do you use for Movies and Tv shows?
@bigwillch

Regarding the code edit:
This is not relevant anymore because I have already made a new version with the option of enter the API Keys in the setting, without touching the code.

I will post here the update very soon (Will be version 14.3.0.0)
(2017-12-05, 22:55)burekas Wrote: iI'm also using universal as a scraper.
Maybe the problem is there, what scraper do you use for Movie and Tv shows? 


I was using the TMDB scrapper but when I scrapped the movie it Did not work. then I used the universal movie scrapper and it was fine.
Not sure why. 
(2017-12-05, 22:47)tymmy Wrote: I was having the same problem in the last hour. I found that by switching from tmdb to universal movie scrapper my problem was corrected. I now suspect something with the last update tmdb scrapper.
 Changed over to Universal Movie Scrapper now myself, and what do you know. Artwork Downloader started downloading again
So I think we might have found the problem, we will wait for the others to confirm.
Maybe there is a problem with TMDB that conflicts with Artwork Downloader.

My scrapers are:
For Movies = Universal
For TV Shows = The TVDB
  •   
  • 1
  • 200
  • 201
  • 202(current)
  • 203
  • 204
  • 208
  •   



Logout Mark Read Team Forum Stats Members Help
Artwork Downloader18
This forum uses Lukasz Tkacz MyBB addons.