•   
  • 1
  • 120
  • 121
  • 122(current)
  • 123
  • 124
  • 208
  •   
  Thread Closed
Artwork Downloader
(2014-01-08, 00:39)BiTeMeNoW Wrote: @kanepa, you forgot to set AD in debug mode too, so I don't see anything there, but glad to see that you could solve the issue deleting the cache db.
In the wiki you can see the locations of the dbs for all operating systems.

@AeronNL, why so complicated? If you use Aeon Nox skin, just go into movies in library mode and go to quick navigation and choose Artwork Downloader so it will just scan for all movies (not Music and tv shows) instead of getting it one by one, or just start the app in the app center ... Tongue
Oh, and don't use the option for local files if not needed, cause it is really slow.
As I understand how it all works (and believe me, I'm a noob so I can be very wrong on this) to start AD after a lib update I would change the scraper script to fire AD at the end, or if you use a service to schedule lib update set there to also start AD in custom mode ... but be aware that if xbmc doesn't see the folders on scan (maybe on network and the connection is not yet estabilished or just nas offline) all contents will be wiped off the the db !!

Thnx for the reply mate.
I know i can do it the way you describe, but i like to have everything automated, i quess i am spoiled in that way...Big Grin
You could be right about the script, maybe there is someone on this forum who already achieved this?
(2011-11-14, 21:34)Martijn Wrote: Current Features and other info:
See the Artwork Downloader wiki for more information

I read the Wiki but still have 1 question, maybe you can help me.

ArworkDownloader will download the content based on the IMDB/TMDB?

Because my library is already organized one movie per folder and NFO file per each folder with some frodo named images (fanart, etc). I'd like to donwload the missing ones using artwork but I do not want that to mess up the other info or to scrape from a different it.

Can I use it safely?

M
If you think I'm useful please use the +/- button to raise my reputation
@m.savazzi, are the files an export? is your library in the database or are you still in file modus?
XBMC will on a scan look for files and then use the scraper online and get where applicable poster and backdrops (or if in the settings maybe fanart).
AD if set to look for files, it will look for other naming as Frodo (like poster.jpg, fanart.jpg, logo.jpg disc.jpg) so look in the wiki which one will be downloaded. If already in DB it should not overwrite them, but I prefer to disable poster and fanart, cause if in file mode it will not find them (frodo naming) and download maybe other as you already have and will overwrite them in the db !!
And Yes AD will look for IMDB index number as setted in DB from scraper. If no IMDB available it will search at TMDB (if I understud it right).
im having issues with the add-on not recognizing local artwork. i have checked off to allow local artwork and used the naming protocols on the WiKi page, ran the update, but its still not picking up my local files in my TV shows folder. any suggestions? thanks
Are the images in the root folder of the shows? Are there eventually already images (other as you wish) in the database and you are trying to replace them? If yes you have to delete them from the db (if you know how) or simply remove them from the library and add again, now it will read from the local files (if you did set it so).
(2014-01-14, 09:10)BiTeMeNoW Wrote: Are the images in the root folder of the shows? Are there eventually already images (other as you wish) in the database and you are trying to replace them? If yes you have to delete them from the db (if you know how) or simply remove them from the library and add again, now it will read from the local files (if you did set it so).

there wasnt any in the folder initially, it was all from the net. it wasnt pulling the pictures correctly so i checked the use local files and unchecked limit downloads. i removed the source and it cleaned the database, re-added the source and it looked like it rescraped everything (took a few min) but it still didnt use the files i added. i used the correct naming scheme off the WiKi page....

how would i delete them from database?

thanks for the response
there are several places ...
in the videodb under tvshow and art table, then in the texture db under texture table AND before deleting look at the url and delete the file linked. The file is in the cache folder.
At least delete the cache db and try again.

Sure the artworks are in the root of the show? In root (Lost) only seasons dirs plus artworks and under seasons (S01, S02) only the video files. On scraping/updating from menu i do not use local files when asked. Then use AD with local files and check that all the needed artworks are also selected in the settings ... Ahh, and disabling limitation will only get more extrafanart or extrathumbs (both from tvdb or local) but not more other artworks

Lost
└ S01
└ S02

Artworks Naming:
banner.jpg
clearart.png
fanart.jpg
landscape.jpg
logo.png
poster.jpg
seasonx-banner.jpg
seasonx-landscape.jpg
seasonx-poster.jpg
character.png

Note that clearart, logo and character are PNGs ... an the others JPGs Smile

If all does not work, then set xbmc AND artwork downloader in debug mode, and upload the log as describrd in post #1
thanks BiTe, ill check this afternoon, im pretty sure i have the files that way. ill have to check the db's. where are they located? under C inside the program files XBMC folder? or the app roaming location under XBMC?
second, userdata\database
can anyone explain me how "use local files" works?

I see that it saves the downloaded artwork into movie folder..

But I don't understand a thing..
When I select a movie it's show me the disc-art..
This disc-art is taken from the movie folder or from another in userdata folder??
Hi does anyone know of any other addon i can use to add/download artwork like discart caues this addon does not work well it does not download all artwork for my movies like the hobbit an unexpected journey 2012 does not get for me the discart and its on fanart.tv can anyone help me out
There are no other ones. But if it's not getting your fanart it can be for many reasons including: rating setting, language, fanart.tv hasn't updated the cache yet, etc.

So, best bet would be to recheck artwork downloader settings because I have An Unexpected Journey and my discart shows just fine Smile

(2014-01-17, 16:08)Bazzu85 Wrote: can anyone explain me how "use local files" works?

I see that it saves the downloaded artwork into movie folder..

But I don't understand a thing..
When I select a movie it's show me the disc-art..
This disc-art is taken from the movie folder or from another in userdata folder??
If I'm not mistaken files are saved locally(movie folder) and then again in xbmc userdata thumbnails folder. It's this 2nd folder that the xbmc database references when it loads the artwork. Pretty sure at least...
(2014-01-18, 01:22)Vaikin Wrote: There are no other ones. But if it's not getting your fanart it can be for many reasons including: rating setting, language, fanart.tv hasn't updated the cache yet, etc.

So, best bet would be to recheck artwork downloader settings because I have An Unexpected Journey and my discart shows just fine Smile

(2014-01-17, 16:08)Bazzu85 Wrote: can anyone explain me how "use local files" works?

I see that it saves the downloaded artwork into movie folder..

But I don't understand a thing..
When I select a movie it's show me the disc-art..
This disc-art is taken from the movie folder or from another in userdata folder??
If I'm not mistaken files are saved locally(movie folder) and then again in xbmc userdata thumbnails folder. It's this 2nd folder that the xbmc database references when it loads the artwork. Pretty sure at least...

Thx!
I've got a problem with art for one video, file name- Who's Afraid of Virginia Woolf? (1966).HDTV.mkv

Every time I run AD it downloads art for this video even though the art has already been downloaded last time. Not that this is really a big deal, but something must be wrong and I'd like to fix it if I can. Anyone have any ideas?
ASUS Chromebox M004U (LibreELEC 8.2/Aeon Nox SiLVO)--->HDMI--->Onkyo TX-NR646--->HDMI--->Panasonic P65VT30
Hi Vaikin rating setting ? what do you mean what would be best setting for this i dont know what i did now but i enable the option use local files and i try downloading artwork again now it shows same 4 movie cover for every movie
  •   
  • 1
  • 120
  • 121
  • 122(current)
  • 123
  • 124
  • 208
  •   
  Thread Closed
 
Thread Rating:
  • 18 Vote(s) - 4.44 Average



Logout Mark Read Team Forum Stats Members Help
Artwork Downloader4.4418
This forum uses Lukasz Tkacz MyBB addons.