•   
  • 1
  • 168
  • 169
  • 170(current)
  • 171
  • 172
  • 208
  •   
  Thread Closed
Artwork Downloader
(2015-12-06, 01:34)Rhys15 Wrote: So run it on my HTPC and my RPi will automatically load the fanart?

Run AD on the HTPC, then afterwards pre-load the cache on the RPi using texturecache.py so that the RPi is fully up to date with any new artwork.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Hey Martijn, will you have some time for Artwork Downloader soon? I want to get the multifanart PR merged in, and a handful of other changes, but the code doesn't look ready to rebase on. If not, I can take these down another path, but I'd like to know what your plans are.
Hello

Recently i noticed a new behavior of artwork downloader in my system. First i add a new movie to my library and start the artwork downloader tool. After run i look into the separated movie folder of my new movie and i only see two folders (extrafanarts,extrathumbs) but i miss the poster.jpg,fanart.jpg,cdart.png and so on. In the skin (Aeon Nox) i have all the arts like cdart, clearart and so on.
So i looked into the database and the table art and the entries of the movie and i noticed extrafanart and extrathumbs points to my local share. But the other arts point to the themoviedb.com webserver.
In Kodi skins i see all the artwork but not in my local folders. My other movies i have scraped before have all artwork downloaded by artwork downloader locally.

So why does the artwork downloader downloads the extrafanart and extrathumbs only and not the other arts like cdart,poster and so on?

I use Kodi 16 latest nighlty, Aeon Madnox and artwork downloader 13.1.10
As said before weeks ago artwork downloader downloads all artwork locally.
@_Andy_ If you want Artwork Downloader to download all artwork to local files, open AD settings, go to Advanced, and check 'Use local files'.

Kodi has supported all types of artwork in the database for quite a while now, so local files are optional for most artwork. Extrafanart and extrathumbs currently aren't placed in the database, so they still need to be on the filesystem to be usable.
Hi all.
After rebuilding Kodi on a new PC about 3/4 of my movie library has no poster/thumbnail available. I've tried AD and set it to get artwork for just my movie files (TV shows, music, etc, all turned off). It scanned my movie library, grabbed 364 pieces of fanart, 356 posters and 1191 extra thumbs, Yet when I go into my library none of them show up, except for the handful I manually downloaded using the Refresh command.

Let's say one of the affected ones was Nightcrawler. When I look in the Nightcrawler folder I see folders for extrafanart and extrathumbs as well as "poster.jpg", which is what I want to show up in the library. But for whatever reason, I just get a blank placeholder under "Movies" within Kodi for it, and several hundred like it. A random sampling shows they all have poster.jpg files, too. Any way to use AD (or some other feature in Kodi) to re-add these?
@rmrector thank you. In my recent installation i have never used local files but all files have been downloaded. So i never watched the option. Thank you for your hint.
Need help. I am using Kodi Jarvis Beta 4. with the XConfluence skin.

After scanning my Movies into the database AD starts to do a search for artwork. How do I stop it from overwriting my local Artwork. I DO NOT have a dot in the Advanced tab in the settings tab so I don't know why it is doing this.

Also Major problem with the Movie Fantastic Four the 2005 version. I do have a .nfo file in there with the correct info but AD overwrites my artwork and downloads the artwork from that horrible remake.
(2015-12-18, 14:46)Poetic-Soul Wrote: Need help. I am using Kodi Jarvis Beta 4. with the XConfluence skin.

After scanning my Movies into the database AD starts to do a search for artwork. How do I stop it from overwriting my local Artwork. I DO NOT have a dot in the Advanced tab in the settings tab so I don't know why it is doing this.

Also Major problem with the Movie Fantastic Four the 2005 version. I do have a .nfo file in there with the correct info but AD overwrites my artwork and downloads the artwork from that horrible remake.

Dont hint "subs artwork existent" and unmark search for extrafanart/extratumbs/poster/fanart, because normally we already have it.

Leave AD search only extra images, like clearlogo/clearimage/landscape/cdart.

Ok?

Cheers!
I'm using Ember Media Manager to scrape all media and metadata for my movies. (All movies are in their own folder where all corresponding artwork is stored as logo.png, poster.jpg etc)

Once I add the movies to Kodi, I use artwork downloader to update the artwork with the following settings:
Enable downloading yes - for extrafanart and extra thumbs only (all the rest is already done via Ember as described above)
Advanced - only 'use local files' set to yes.

This updates the majority of logos for my movies. However, the problem I'm having is that it doesn't seem to pick up all the logos. As an example, There was no logo for 'Biggles an Adventure in time' that ember could scrape, so one was created and placed as logo.png in the Biggles folder. When running artwork downloader, it doesn't update this logo.

I'm experiencing the same problem, for other movies where I've had to create a logo.

I'm using the madnox skin, and I've looked in the context menu, and I don't seem to have the option for adding artwork manually. So if anyone has any ideas if I need to change settings on artwork downloader to pick up these logos, or how to add the artwork manually, I would be really greatful.
I haven't had this problem when adding logos via bulk mode. Always works for me, but it you want to try and add them manually you need to navigate to the info screen for the individual video. Select "Extras". Select "Manually Add Art" or something similar (sorry, I'm at work and can't check the menu). This will open the menu for manually selecting artwork.
ASUS Chromebox M004U (LibreELEC 8.2/Aeon Nox SiLVO)--->HDMI--->Onkyo TX-NR646--->HDMI--->Panasonic P65VT30
(2015-12-29, 16:07)wgstarks Wrote: I haven't had this problem when adding logos via bulk mode. Always works for me, but it you want to try and add them manually you need to navigate to the info screen for the individual video. Select "Extras". Select "Manually Add Art" or something similar (sorry, I'm at work and can't check the menu). This will open the menu for manually selecting artwork.

I had to update the madnox skin to the latest version, these options then became available. All sorted now, so I can add individual logos.
Well I fixed one problem, and I seem to have another.

I've added a couple of TV shows (Arrow and American Horror Story) to Kodi. However, I can't seem to get AD to download to download the logo's and extra fanart for the new shows I've added - but it worked fine when initially adding my tv shows and initially scraping for the information.

Similarly - it appears to have downloaded the artwork for Agents of Shield, as I can see the fanart background, poster and logo when browsing kodi, but there's no sign of poster.jpg, logo.png ect in the Agents of Shield folder. (same as Arrow and American Horror Story)

Does anyone have a clue what is going on, as I'm completely baffled by this behaviour. Could it be a skin rather than AD problem? My full debug log can be found here.

(All the TV series and movies are on my NAS - If that helps).

Would appreciate anyhelp anyone can give.

[SOLVED]
I thought I'd have another look at this today, so I tried looking through the debug log to see if I could figure anything out, which did take me a while. However I found the corresponding entries from when I initiated artwork downloader, and it appeared to be unable to create the extrafanart folders on my NFS:// share.

I reset the NFS permissions on my qnap, making sure the IP of my desktop had read/write permissions and hey presto - AD is now able to create the folders and save the extra fanart.

Am relatively new to Kodi, even though I've been a member for sometime - so to solve this on my own (and yes I probably should've done it sooner, but I did feel a bit out of my depth) is quite a good feeling.

HAPPY NEW YEAR to all Smile
Hello Guys!Ive use Mq6 theme and when i Fanart Collection/Create Or Update data Base Add-on Required i send me to program addon and then ive chose artwork downloader but i get o download.Ive installed all dependency manually as theme also and i dont have any error but why i get o download.Anyone knows how to fix that?
@Martijn

Does the bug, if it is a bug, where the addon download the seasonXX-landscape.jpg art but kodi expect seasonX-landscape.jpg its fix ?
clearArt Concept
cdArt Concept

*If like, thank user
Hi, next to the previous report from reaven, just would like to know if $INFO[ListItem.Art(landscape)] isn't intended to show 16:9 landscape also at season level ? (as written in the wiki). Right now we're trying to display this using $INFO[ListItem.Path,,season]$INFO[ListItem.Season,,-landscape.jpg] but hard to define a false condition with this. Also, it requires to have "Use local files" activated for things to work correctly.
I'm under Jarvis RC1 with latest repo build.

Thanks
[Skin] KOver - V1.1.0 Stable (Repo version)
[WIP] ReKOver - Skinning tool project

If I've been helpful or you like my work, hit "THANK USER" button ;) ...
  •   
  • 1
  • 168
  • 169
  • 170(current)
  • 171
  • 172
  • 208
  •   
  Thread Closed
 
Thread Rating:
  • 18 Vote(s) - 4.44 Average



Logout Mark Read Team Forum Stats Members Help
Artwork Downloader4.4418
This forum uses Lukasz Tkacz MyBB addons.