music fullscreen automatically on selecting play
#16
This is nice. Should be a setting.
Reply
#17
I'm corious too,, Anyone have solved these case?
Reply
#18
If you read the first page on this thread you should be able to get it working.

Im subbed to this thread just int the hope that someone announces it as a feature.

I asked about this originally nearly 2 years ago.
And put in a feat. request about 8months ago.

I honestly think its a worthwhile feature.
My band - www.myspace.com/seabasskid
My systems - MEDIASERVER: ASRock 330, 1.6GHz DualCore Atom, GeForce9400 ION, 2GB ram
STAND-ALONE: Raspberry Pi2 MODEL B, OSMC Kodi15.2 compiled: Sept 27th 2015
XboxLive Gamertag - SkillipEvolver
Reply
#19
I have been using this code for a while in a custom window. Works like a charm.

Code:
<?xml version="1.0" encoding="UTF-8"?>
<window type="dialog" id="1100">
    <allowoverlay>no</allowoverlay>
    <onload condition="!Window.IsActive(visualisation)">FullScreen</onload>
    <visible>Player.HasAudio + !Integer.IsEqual(MusicPlayer.Time,0) + String.IsEmpty(Window(Videos).Property(PlayingBackgroundMedia))</visible>
    <visible>Skin.HasSetting(MusicFullscreenEnabled)</visible>
    <controls></controls>
</window>

Remember the skin setting (or delete the line).


EDIT: Code is for Kodi Krypton.
Reply
#20
(2016-08-24, 12:40)PantsOnFire Wrote: If you read the first page on this thread you should be able to get it working.

Im subbed to this thread just int the hope that someone announces it as a feature.

I asked about this originally nearly 2 years ago.
And put in a feat. request about 8months ago.

I honestly think its a worthwhile feature.

(2016-08-24, 14:05)Gade Wrote: I have been using this code for a while in a custom window. Works like a charm.

Code:
<?xml version="1.0" encoding="UTF-8"?>
<window type="dialog" id="1100">
    <allowoverlay>no</allowoverlay>
    <onload condition="!Window.IsActive(visualisation)">FullScreen</onload>
    <visible>Player.HasAudio + !Integer.IsEqual(MusicPlayer.Time,0) + String.IsEmpty(Window(Videos).Property(PlayingBackgroundMedia))</visible>
    <visible>Skin.HasSetting(MusicFullscreenEnabled)</visible>
    <controls></controls>
</window>

Remember the skin setting (or delete the line).


EDIT: Code is for Kodi Krypton.

Sorry,but it doesn't work, I tried to skin confluence for jarvis version. I've doing step as you do.
Do I only need to make custom_MusicFullscreensEnabler.xml and put in a directory 720p ?
Where I had to call the custom_MusicFullscreensEnabler.xml ? in viewfilemode.xml ?
Reply
#21
(2016-08-25, 03:49)encacil Wrote:
Sorry,but it doesn't work, I tried to skin confluence for jarvis version. I've doing step as you do.
Do I only need to make custom_MusicFullscreensEnabler.xml and put in a directory 720p ?
Where I had to call the custom_MusicFullscreensEnabler.xml ? in viewfilemode.xml ?

Like I wrote, the code is for Kodi Krypton, and will not work in Jarvis.

If you don't want a skin setting, you can use this code in Jarvis:

Code:
<?xml version="1.0" encoding="UTF-8"?>
<window type="dialog" id="1100">
    <allowoverlay>no</allowoverlay>
    <onload condition="!Window.IsActive(visualisation)">FullScreen</onload>
    <visible>Player.HasAudio + !StringCompare(MusicPlayer.Time,0) + IsEmpty(Window(Videos).Property(PlayingBackgroundMedia))</visible>
    <controls></controls>
</window>

Create a custom window and name it something like custom_MusicFullscreenEnabler.xml or whatever and place it inside it skin.confluence/720p folder

Make sure to check if window ID 1100 is already used.
Reply
#22
(2016-08-25, 05:50)Gade Wrote:
(2016-08-25, 03:49)encacil Wrote:
Sorry,but it doesn't work, I tried to skin confluence for jarvis version. I've doing step as you do.
Do I only need to make custom_MusicFullscreensEnabler.xml and put in a directory 720p ?
Where I had to call the custom_MusicFullscreensEnabler.xml ? in viewfilemode.xml ?

Like I wrote, the code is for Kodi Krypton, and will not work in Jarvis.

If you don't want a skin setting, you can use this code in Jarvis:

Code:
<?xml version="1.0" encoding="UTF-8"?>
<window type="dialog" id="1100">
    <allowoverlay>no</allowoverlay>
    <onload condition="!Window.IsActive(visualisation)">FullScreen</onload>
    <visible>Player.HasAudio + !StringCompare(MusicPlayer.Time,0) + IsEmpty(Window(Videos).Property(PlayingBackgroundMedia))</visible>
    <controls></controls>
</window>

Create a custom window and name it something like custom_MusicFullscreenEnabler.xml or whatever and place it inside it skin.confluence/720p folder

Make sure to check if window ID 1100 is already used.

Amazing,, it work..thanks you so much Gade..
Now, i will edit MusicOSD.Xml, change them with my design Smile
Reply
#23
Code:
<window type="dialog" id="1100">
    <allowoverlay>no</allowoverlay>
    <onload>ActivateWindow(MusicOSD)</onload>
    <visible>Player.HasAudio + !StringCompare(MusicPlayer.Time,0) + IsEmpty(Window(Videos) + !SubString(Window(videolibrary).Property(PlayingBackgroundMedia))</visible>
    <controls></controls>
</window>

I have modified your code, because I am planning to change the musicplayer..Big Grin[/php]
Reply
#24
(2016-08-25, 05:50)Gade Wrote:
(2016-08-25, 03:49)encacil Wrote:
Sorry,but it doesn't work, I tried to skin confluence for jarvis version. I've doing step as you do.
Do I only need to make custom_MusicFullscreensEnabler.xml and put in a directory 720p ?
Where I had to call the custom_MusicFullscreensEnabler.xml ? in viewfilemode.xml ?

Like I wrote, the code is for Kodi Krypton, and will not work in Jarvis.

If you don't want a skin setting, you can use this code in Jarvis:

Code:
<?xml version="1.0" encoding="UTF-8"?>
<window type="dialog" id="1100">
    <allowoverlay>no</allowoverlay>
    <onload condition="!Window.IsActive(visualisation)">FullScreen</onload>
    <visible>Player.HasAudio + !StringCompare(MusicPlayer.Time,0) + IsEmpty(Window(Videos).Property(PlayingBackgroundMedia))</visible>
    <controls></controls>
</window>

Create a custom window and name it something like custom_MusicFullscreenEnabler.xml or whatever and place it inside it skin.confluence/720p folder

Make sure to check if window ID 1100 is already used.


I just wanted to say, "THANKS!"

I'm not a skinner, though I have messed around with a few customizations to try and XBMC / KODI look and work the way I want.

I've been using different versions of Aeon MQ for a long time, and have only recently decided to add music as an option, but was disappointed to find that, upon selecting the song, the OSD didn't launch automatically.

It turns out that by following your simple instructions, and placing the custom_MusicFullscreenEnabler.xml file into the skin.aeonmq5.jarvismod\720p folder, the OSD now launches PERFECTLY, as, in my opinion, it should have. I fully expected that I would have to dig around and locate another option to call that XML... but NOPE. So simple!

Thanks for sharing your knowledge and for putting it into terms that even the inexperienced can follow.
Reply
#25
For some reason I cannot get this to work. I added the the XML posted here and im in krypton and just.. nothing.

What does "remember the music setting" mean?
Reply
#26
Just off top of my head - sure you got the XML in the right folder?

Damn man, this needs to be a feature already. This been going on for over 2 years!!
My band - www.myspace.com/seabasskid
My systems - MEDIASERVER: ASRock 330, 1.6GHz DualCore Atom, GeForce9400 ION, 2GB ram
STAND-ALONE: Raspberry Pi2 MODEL B, OSMC Kodi15.2 compiled: Sept 27th 2015
XboxLive Gamertag - SkillipEvolver
Reply
#27
Put it in 1080i folder of my skins addon folder. That's the place, no?
Reply
#28
Which Kodi version do you use?

For Kodi Krypton, you should use this code:

Code:
<?xml version="1.0" encoding="UTF-8"?>
<window type="dialog" id="1100">
    <allowoverlay>no</allowoverlay>
    <onload condition="!Window.IsActive(visualisation)">FullScreen</onload>
    <visible>Player.HasAudio + !Integer.IsEqual(MusicPlayer.Time,0)</visible>
    <controls />
</window>

If you use the TV Tunes add-on (you probably don't) use this instead:

Code:
<?xml version="1.0" encoding="UTF-8"?>
<window type="dialog" id="1100">
    <allowoverlay>no</allowoverlay>
    <onload condition="!Window.IsActive(visualisation)">FullScreen</onload>
    <visible>Player.HasAudio + !Integer.IsEqual(MusicPlayer.Time,0) + String.IsEmpty(Window(Videos).Property(PlayingBackgroundMedia))</visible>
    <controls />
</window>

Make sure there are not other custom windows in your skin using window id="1100".
Reply
#29
Just wondering I think I missed it but what actually triggers you custom window ... What tell the dialog to open
Reply
#30
(2017-05-10, 04:32)smitchell6879 Wrote: Just wondering I think I missed it but what actually triggers you custom window ... What tell the dialog to open

The Player.HasAudio visible condition in the window tags triggers the dialog to open and then the onload launches the "Fullscreen" command
Reply
 
Thread Rating:
  • 3 Vote(s) - 4.67 Average



Logout Mark Read Team Forum Stats Members Help
music fullscreen automatically on selecting play4.673