[atv2] screenshots with a blue hue
#1
I have had an atv2 since early november, upgrading to the latest nightly every other day. One continous issue I see is that screenshots get a blue hue added to them. Whether from the GUI or from watching a movie.

If anyone else can confirm this, I will trac it.

Image

EDIT: sorry, wrong section. should have been posted to ios. feel free to move.
Reply
#2
need debug log.
Reply
#3
odt_x Wrote:I have had an atv2 since early november, upgrading to the latest nightly every other day. One continous issue I see is that screenshots get a blue hue added to them. Whether from the GUI or from watching a movie.

If anyone else can confirm this, I will trac it.

Image

EDIT: sorry, wrong section. should have been posted to ios. feel free to move.

move your thumbnails folder away... looks like you have thumbs generated with a buggy version of xbmc and it now has the wrong color space ...

Let the current nightly version of xbmc refetch the thumbs ...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#4
I am only talking about screenshots getting the blue hue, the thumbnails and the whole UI display perfectly fine and in fact were scraped just last week. The background of the picture I posted is in fact blue, so its definitely not a thumb problem.

The one thing I think that could be having an impact is that I'm using a calibrated resolution (as evident in the black border around the UI).

another picture (should also have a blue backgroud):

Image

Debug Log, previous screenshot happening at line 6630 Debug Log

also, the imagelib seems recent:

Code:
-rwxr-xr-x 1 mobile mobile 796360 Nov 24 13:23 /private/var/stash/Applications/XBMC.frappliance/XBMCData/XBMCHome/system/ImageLib-arm-osx.so*
Reply
#5
now i got you ... could you test a nightly from before 17th of november please and report back if screenshots are working there?
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#6
Yes, I have tested older nightlies. Its been occuring with all nightlies from Nov 9th (the first I installed). If theres any specific nightly you want me to test I can do that.
Reply
#7
no its fine then...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#8
Screenshots have always had this problem.
Reply
#9
We need RGBA->BGRA conversion in CUtil::TakeScreenshot(const CStdString &filename, bool sync) in Util.cpp.
Reply
#10
bobo1on1 Wrote:We need RGBA->BGRA conversion in CUtil::TakeScreenshot(const CStdString &filename, bool sync) in Util.cpp.

thx ... i'll beam the yoda sign into the sky and hope it is visible in someones special mancave in usa ... Big Grin
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#11
Or we could drop the wacky conversion in CxImage/DllInterface.cpp and just always send it rgb...
Reply
#12
Quick (untested) fix: http://pastebin.com/raw.php?i=iJZRmkh6

Though I'm sure that loop in cximage could be skipped.

Note that Dx may still need a conversion. If so, imo that's easier to handle than splitting up the GL implementations.
Reply
#13
yoda says, http://pastebin.com/uEfTPuxm

theuni's fix is better but also touches much more behavior than mine. What else might be affected ?
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
#14
That's safer for sure, probably better for Eden.

Mine really wouldn't gain us anything as long as cximage is still dragging us down. Probably better to nuke cximage and standardize the bgra/rgba stuff all at once at some point.
Reply
#15
Reading GL_RGBA in LinuxRendererGL.cpp is no good, it decreases performance of CRenderCapture.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[atv2] screenshots with a blue hue00