xbmc wont install- unmet dependencies
#1
atv version 4.3 (2557)

I just got an atv2 and JB it with seasonpass. I then installed nitotv and it installed fine. I tried to install xbmc thru nitotv and it gave me a unmet dependencies.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
org.xbmc.xbmc-atv2: Depends: org.xbmc.xbmc-seatbeltunlock but it is not going to be installed
E: Broken packages


I then went to wiki and followed the instructions there and same thing.

See below

Code:
Apple-TV:~ root# apt-get install wget
Reading package lists... Done
Building dependency tree
Reading state information... Done
wget is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Apple-TV:~ root# wget -O- http://apt.awkwardtv.org/awkwardtv.pub | apt-key add -
/usr/bin/apt-key: line 161: run-parts: command not found
--2011-11-26 19:50:00--  http://apt.awkwardtv.org/awkwardtv.pub
Resolving apt.awkwardtv.org... 74.208.75.216
Connecting to apt.awkwardtv.org|74.208.75.216|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1698 (1.7K) [text/plain]
Saving to: `STDOUT'

100%[=======================================>] 1,698       --.-K/s   in 0s

2011-11-26 19:50:00 (22.5 MB/s) - `-' saved [1698/1698]

OK
Apple-TV:~ root# echo "deb http://apt.awkwardtv.org/ stable main" > /etc/apt/sources.list.d/awkwardtv.list
Apple-TV:~ root# echo "deb http://mirrors.xbmc.org/apt/atv2 ./" > /etc/apt/sources.list.d/xbmc.list
Apple-TV:~ root# apt-get update
Hit http://cydia.zodttd.com stable Release.gpg
Hit http://apt.modmyi.com stable Release.gpg
Hit http://apt.awkwardtv.org stable Release.gpg
Hit http://apt.thebigboss.org stable Release.gpg
Hit http://cydia.zodttd.com stable Release
Hit http://apt.awkwardtv.org ./ Release.gpg
Ign http://mirrors.xbmc.org ./ Release.gpg
Hit http://apt.thebigboss.org stable Release
Get:1 http://apt.modmyi.com stable Release [1328B]
Hit http://cydia.zodttd.com stable/main Packages/DiffIndex
Hit http://apt.awkwardtv.org stable Release
Hit http://apt.thebigboss.org stable/main Packages/DiffIndex
Hit http://apt.modmyi.com stable/main Packages/DiffIndex
Ign http://mirrors.xbmc.org ./ Release
Hit http://nitosoft.com  Release.gpg
Hit http://apt.awkwardtv.org ./ Release
Hit http://apt.awkwardtv.org stable/main Packages/DiffIndex
Hit http://nitosoft.com  Release
Ign http://mirrors.xbmc.org ./ Packages/DiffIndex
Hit http://apt.awkwardtv.org ./ Packages/DiffIndex
Ign http://nitosoft.com  Packages/DiffIndex
Hit http://nitosoft.com  Packages
Hit http://mirrors.xbmc.org ./ Packages
Fetched 1328B in 2s (494B/s)
Reading package lists... Done
Apple-TV:~ root# apt-get install org.xbmc.xbmc-atv2
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  org.xbmc.xbmc-atv2: Depends: org.xbmc.xbmc-seatbeltunlock but it is not going to be installed
E: Broken packages
Apple-TV:~ root#

any help on how to get this installed?
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#2
Some weird server/mirror problem, maybe? All the files from the XBMC repo get distributed by a network of mirrors, so maybe one of those servers was having issues. I'm able to access those files from http://mirrors.xbmc.org/apt/atv2/ so I would just wait a while and try again.
Reply
#3
See what aptitude can do for you. It usually tries to resolve all that. Read what it spits out and give it a thumbs up (Y) or thumbs down (n) on what it suggests.
Image
Code:
GRANT ALL PRIVILEGES ON `xbmc_%`.* TO 'xbmc'@'%';
IF you have a mysql problem, find one of the 4 dozen threads already open.
Reply
#4
darkscout Wrote:See what aptitude can do for you. It usually tries to resolve all that. Read what it spits out and give it a thumbs up (Y) or thumbs down (n) on what it suggests.

how do I do that?
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#5
Still getting same error message.any help
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#6
apt-get install org.xbmc.xbmc-seatbeltunlock
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
#7
aptitude install org.xbmc.xbmc-atv2
Image
Code:
GRANT ALL PRIVILEGES ON `xbmc_%`.* TO 'xbmc'@'%';
IF you have a mysql problem, find one of the 4 dozen threads already open.
Reply
#8
Apple-TV:~ root# aptitude
-sh: aptitude: command not found

Smile

While aptitude is present in apt-get, it's not there by default under atv2.
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
#9
davilla Wrote:apt-get install org.xbmc.xbmc-seatbeltunlock

when do I do this step in the belowHuh before installing xbmc?

Code:
apt-get install wget

wget -O- http://apt.awkwardtv.org/awkwardtv.pub | apt-key add -

echo "deb http://apt.awkwardtv.org/ stable main" > /etc/apt/sources.list.d/awkwardtv.list

echo "deb http://mirrors.xbmc.org/apt/atv2 ./" > /etc/apt/sources.list.d/xbmc.list

apt-get update

apt-get install org.xbmc.xbmc-atv2
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#10
apt-get update
apt-get install org.xbmc.xbmc-atv2

Those are the only steps needed as Seas0nPass will (should) have done everything else during the jb.

try:

apt-get update
apt-get install org.xbmc.xbmc-seatbeltunlock
apt-get install org.xbmc.xbmc-atv2
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
#11
davilla Wrote:apt-get update
apt-get install org.xbmc.xbmc-atv2

Those are the only steps needed as Seas0nPass will (should) have done everything else during the jb.

try:

apt-get update
apt-get install org.xbmc.xbmc-seatbeltunlock
apt-get install org.xbmc.xbmc-atv2

ok I am getting the below now when I try to install seatbeltunlock

The following packages have unmet dependencies:
org.xbmc.xbmc-seatbeltunlock: Depends: bsdiff but it is not installable
Depends: gawk but it is not installable
E: Broken packages

Code:
login as: root
[email protected]'s password:
Apple-TV:~ root# apt-get update
Hit http://apt.thebigboss.org stable Release.gpg
Hit http://apt.modmyi.com stable Release.gpg
Hit http://cydia.zodttd.com stable Release.gpg
Hit http://apt.thebigboss.org stable Release
Hit http://cydia.zodttd.com stable Release
Ign http://mirrors.xbmc.org ./ Release.gpg
Get:1 http://apt.modmyi.com stable Release [1331B]
Ign http://www.ambertation.de ./downloads/PLEX/ Release.gpg
Hit http://nitosoft.com  Release.gpg
Hit http://apt.thebigboss.org stable/main Packages/DiffIndex
Hit http://apt.awkwardtv.org stable Release.gpg
Hit http://apt.awkwardtv.org ./ Release.gpg
Hit http://nitosoft.com  Release
Ign http://www.ambertation.de ./downloads/PLEX/ Release
Ign http://mirrors.xbmc.org ./ Release
Hit http://cydia.zodttd.com stable/main Packages/DiffIndex
Hit http://apt.modmyi.com stable/main Packages/DiffIndex
Hit http://apt.awkwardtv.org stable Release
Ign http://nitosoft.com  Packages/DiffIndex
Ign http://www.ambertation.de ./downloads/PLEX/ Packages/DiffIndex
Ign http://mirrors.xbmc.org ./ Packages/DiffIndex
Hit http://apt.awkwardtv.org ./ Release
Hit http://nitosoft.com  Packages
Hit http://apt.awkwardtv.org stable/main Packages/DiffIndex
Hit http://www.ambertation.de ./downloads/PLEX/ Packages
Hit http://mirrors.xbmc.org ./ Packages
Hit http://apt.awkwardtv.org ./ Packages/DiffIndex
Fetched 1331B in 4s (322B/s)
Reading package lists... Done
Apple-TV:~ root# apt-get install org.xbmc.xbmc-seatbeltunlock
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

[b]The following packages have unmet dependencies:
  org.xbmc.xbmc-seatbeltunlock: Depends: bsdiff but it is not installable
                                Depends: gawk but it is not installable
E: Broken packages[/b]
Apple-TV:~ root#
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#12
Try:

apt-get update && apt-get upgrade
apt-get -f install
Reply
#13
Install aptitude. It's magic with unresolved crap.
Image
Code:
GRANT ALL PRIVILEGES ON `xbmc_%`.* TO 'xbmc'@'%';
IF you have a mysql problem, find one of the 4 dozen threads already open.
Reply
#14
darkscout Wrote:Install aptitude. It's magic with unresolved crap.

tried and get the below

Code:
login as: root
[email protected]'s password:
Apple-TV:~ root# aptitude
-sh: aptitude: command not found
Apple-TV:~ root# apt-get install aptitude
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package aptitude
Apple-TV:~ root#
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#15
your install is totally borked. re-jailbreak with the current Seas0nPass and just do:

apt-get update
apt-get install org.xbmc.xbmc-atv2

None of these other magic incantations are required. They are indications of something very wrong with apt.
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
xbmc wont install- unmet dependencies00