xbmc remote doesn't work on Ice Cream Sandwich (Galaxy Nexus)?
#1
Hi everyone, i received my galaxy nexus today and so far i'm unable to control my pre-eden xbmc (compiled 11/28 for linux) When i attempt to connect all that pops up is "NullPointerException" (xbmc commander on my iphone works beautifully so i know it isn't xbmc itself)

Is this a known limitation? Searching the forums has brought up nothing otherwise i wouldn't have posted. Thanks!
Reply
#2
A log would be great. I've just installed ICS on a Nexus S and I can't reproduce the issue.
Running XBMC on my HTPC, tablet, phone and pinball machine.
Always read the XBMC online-manual, FAQ and search the forums before posting. Do NOT e-mail Team-XBMC members asking for support. For troubleshooting and bug reporting, make sure you read this first.
Reply
#3
I actually also own the galaxy nexus and have exactly the same problem.
xbmc commander on my iphone works also great and the xbmc app on my samsung galaxy i9000 (s1) also works fine.

running the app from my galaxy nexus ice cream sandwich, though, produces the same error (nullpointerexception). i already saw this on the issue page (issue 581: http://code.google.com/p/android-xbmcrem...ail?id=581 )

any hope for a fix for christmas? Big Grin
Reply
#4
Image

Try this one. It seems weird that getMessage() of an IOException thrown by the system would be null though.
Running XBMC on my HTPC, tablet, phone and pinball machine.
Always read the XBMC online-manual, FAQ and search the forums before posting. Do NOT e-mail Team-XBMC members asking for support. For troubleshooting and bug reporting, make sure you read this first.
Reply
#5
freezy Wrote:Image

Try this one. It seems weird that getMessage() of an IOException thrown by the system would be null though.

installed r2-beta1 and am still experiencing the issue. xbmc app seems to be working though as pressing "power on" does wake up my HTPC it just throws the nullpointerexception message once the app recognized that my xbmc is online. any idea what this is?
Reply
#6
I'm also getting the NullPointerExpression error. Whenever I try to connect I get the error (On my Galaxy Nexus) But the remote works for navigating, play pause etc... What doesn't work however is the other functions, such as search through tv and movies on my phone, and the app constantly says its not connected.

I have a galaxy tab 10.1 running android 3.2 honeycomb and it works perfectly well. :S
Reply
#7
+1


Same errors here with samsung galaxy nexus
Reply
#8
I am also having this exact issue. I thought I was the only one. This happens with a droid incredible. XBMC remote used to work flawlessly until verizon updated my phone with Android version 2.3.4 (Build 4.08.605.2) - There are a few things I can't do very well anymore. I used to be able to search for a video on the phone and send to xbmc. It still does it, but it can take up to 5 minutes before the video will actually start playing. I get a black page, then about 2 minutes later it asks me if I want to stream it through XBMC and then it will start playing it roughly about a minute later after I say yes. The remote works all the time, but I also get that exception error every once in a while and I don't get the rest of the functions (All I get is the remote control). Somtimes once in a while, the rest of the functions will actually come up. I really do hope I made this clear enough for someone to know what is going on.
Reply
#9
Spent a few hours debugging today, still no idea what is happening. For reference, here are the links to the mailing list and StackOverflow where I asked the question.

See also bugreport on Google code.
Running XBMC on my HTPC, tablet, phone and pinball machine.
Always read the XBMC online-manual, FAQ and search the forums before posting. Do NOT e-mail Team-XBMC members asking for support. For troubleshooting and bug reporting, make sure you read this first.
Reply
#10
<aol>Me too!</aol>. I get the issue on the Galaxy Nexus.

BTW, it's pretty annoying that the remote throws up an exception when it can't connect (I got the error box on HTC Desire w/gingerbread too). Especially when you have more than one XBMC. Because if the selected one is unavailable when you start the app, it keeps complaining after you've chosen the one that is available.
Reply
#11
it´s couriose.

after reinstall and set up the connection to xbmc it works fine.
after closing and reopen the app got the error.

take other programs for xbmc from the market and they work well.
but no app got the functions like this one here.

i´m very sad about that Sad


one question:

what´s about the memorycard?
maybe it´s relatet to the not exisitng memoryslot in the phone?

because when i press often on the movie section and ignore the error message it goes to my movie librarie an with the first cover the programm got a force closed
Reply
#12
I also get the NullPointerException error
Code:
I/Connection( 6649): http://192.168.1.101:8888/xbmcCmds/xbmcHttp?command=GetSystemInfo(120)
W/System.err( 6649): java.io.EOFException
W/System.err( 6649):    at libcore.io.Streams.readAsciiLine(Streams.java:203)
W/System.err( 6649):    at libcore.net.http.HttpEngine.readResponseHeaders(HttpEngine.java:547)
W/System.err( 6649):    at libcore.net.http.HttpEngine.readResponse(HttpEngine.java:787)
W/System.err( 6649):    at libcore.net.http.HttpURLConnectionImpl.getResponse(HttpURLConnectionImpl.java:274)
W/System.err( 6649):    at libcore.net.http.HttpURLConnectionImpl.getInputStream(HttpURLConnectionImpl.java:168)
W/System.err( 6649):    at org.xbmc.httpapi.Connection.query(Connection.java:278)
W/System.err( 6649):    at org.xbmc.httpapi.Connection.getString(Connection.java:313)
W/System.err( 6649):    at org.xbmc.httpapi.client.InfoClient.getSystemInfo(InfoClient.java:126)
W/System.err( 6649):    at org.xbmc.android.util.ClientFactory.probeQueryApiType(ClientFactory.java:216)
W/System.err( 6649):    at org.xbmc.android.util.ClientFactory.getInfoClient(ClientFactory.java:68)
W/System.err( 6649):    at org.xbmc.android.remote.business.AbstractManager.info(AbstractManager.java:107)
W/System.err( 6649):    at org.xbmc.android.remote.business.InfoManager$1.doRun(InfoManager.java:51)
W/System.err( 6649):    at org.xbmc.android.remote.business.Command.run(Command.java:40)
W/System.err( 6649):    at android.os.Handler.handleCallback(Handler.java:605)
W/System.err( 6649):    at android.os.Handler.dispatchMessage(Handler.java:92)
W/System.err( 6649):    at android.os.Looper.loop(Looper.java:137)
W/System.err( 6649):    at org.xbmc.android.remote.business.ManagerThread.run(ManagerThread.java:78)
W/System.err( 6649): java.lang.NullPointerException
W/System.err( 6649):    at org.xbmc.android.remote.presentation.controller.AbstractController.onError(AbstractController.java:237)
W/System.err( 6649):    at org.xbmc.android.remote.business.AbstractManager.onError(AbstractManager.java:293)
W/System.err( 6649):    at org.xbmc.httpapi.Connection.query(Connection.java:298)
W/System.err( 6649):    at org.xbmc.httpapi.Connection.getString(Connection.java:313)
W/System.err( 6649):    at org.xbmc.httpapi.client.InfoClient.getSystemInfo(InfoClient.java:126)
W/System.err( 6649):    at org.xbmc.android.util.ClientFactory.probeQueryApiType(ClientFactory.java:216)
W/System.err( 6649):    at org.xbmc.android.util.ClientFactory.getInfoClient(ClientFactory.java:68)
W/System.err( 6649):    at org.xbmc.android.remote.business.AbstractManager.info(AbstractManager.java:107)
W/System.err( 6649):    at org.xbmc.android.remote.business.InfoManager$1.doRun(InfoManager.java:51)
W/System.err( 6649):    at org.xbmc.android.remote.business.Command.run(Command.java:40)
W/System.err( 6649):    at android.os.Handler.handleCallback(Handler.java:605)
W/System.err( 6649):    at android.os.Handler.dispatchMessage(Handler.java:92)
W/System.err( 6649):    at android.os.Looper.loop(Looper.java:137)
W/System.err( 6649):    at org.xbmc.android.remote.business.ManagerThread.run(ManagerThread.java:78)

ICS GN LTE
Reply
#13
I am receiving the same "NullPointerException" error on my LTE Galaxy Nexus when I try to connect to any XBMC instance.

I am on 4.0.2
Reply
#14
Getting the same error here.

Running a Nexus S and just updated to ICS 4.0.3 this afternoon via the update. Ever since then the app gives the null pointer exception described above.

Was working flawlessly before on gingerbread 2.3.6.
Reply
#15
I am having the same issue.

I have Galaxy Nexus from Verizon, running android 4.0.2.

Though I am not being prevented from actually using the app. If I'm persistent, it still works. For example, I might get the Nullpoint error, but it connects anyway, I hit back, and I can still use the app.

Or, it might not connect, and at most I have to hit connect once or twice more. Canceling out the error via the back button. But it's never been more than twice.

The error also might appear when going from menu to menu.

I don't know if this information helps at all.

P.s. I appreciate the app.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
xbmc remote doesn't work on Ice Cream Sandwich (Galaxy Nexus)?00