•   
  • 1
  • 40
  • 41
  • 42(current)
  • 43
  • 44
  • 107
  •   
[RELEASE] Official XBMC boblight Addon
So is there any way to contact the guy who hosted the boblight config calculator?

Doesnt look like he is still visiting this forum.

Or is there another way to create the config without writing everything from hand?
Reply
(2013-01-01, 03:16)teeedubb Wrote: Running both the boblight addon + boblight-x11 is working well for me too. To enable/disable boblight Im going to use irexec to stop/start boblightd. EDIT: It appears that you need to start boblight-x11 before the boblight addon for this to work.

Yeah it´s been working fine for me, apart from the error talked about earlier in this thread: "After stopping playback, the lights still stay on (in the last used colors)."

It fixes it self when i play a mp3 song, start a new video or the screensaver kicks in.

Hopefully it will be fixed after the Frodo release Smile
Reply
Im using adalight with 100LEDs and boblight for windows.
When I start it the LEDs light up and the XBMC addon connects.

But after that it does nothing not even the static backlight thing works.
Any idea?
Reply
(2012-12-30, 22:49)BurningSky Wrote: Hello,
I've tried to compile boblight by following the HowTo in the first post, but it stuck at the configure process. That's the error message I got:
Code:
configure: error: Missing a required header, please install it
I installed all dependencies as described here: http://code.google.com/p/boblight/wiki/Compiling

My OS is Ubuntu 12.10 x86 minimal with XBMC Frodo Nightly.

Check the line before it, the configure script tells you which header file it's checking.
Reply
can anyone please provide me a link to the latest boblighthd deamon for win7. on this page I cant find any compiled deamon. http://code.google.com/p/boblight/downloads/list and unfortunatelly I am not able to compile a deamon on my own.
Reply
(2013-01-02, 17:01)bobo1on1 Wrote: Check the line before it, the configure script tells you which header file it's checking.

Thank you, I thought I installed all necesary dependencies as described at the first step in the wiki, but libusb wasn't installed.
Reply
Could one of you with a 100 LED adalight setup upload the boblight.conf?

Is there an easy way to test boblight without the addon so I can see if its the deamon or the addon that causes problems?
Reply
@Memphiz
Would it be possible to have an option to hide the notifications on failed and successful connections?
Reply
(2013-01-04, 03:02)schumi2004 Wrote: @Memphiz
Would it be possible to have an option to hide the notifications on failed and successful connections?

Yes please Big Grin

So annoying when starting my pc that each time I get connection failed and the connected message because there's no delay in it.
Same on shutdown.

Will get a PR ready for this Wink
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
In case anyone is interested here is the script Im using to have both the boblight addon + boblight-x11 running at the same time from a remote with irexec (I still have some work to do with colours/speed etc..):

Code:
#!/bin/bash
#Script to start stop boblight-x11 with irexec

if [ ! "$(pgrep boblightd)" ]
then
        killall boblightd
        killall boblight-X11
        echo Starting boblightd + boblight-x11
        curl -v -H "Accept: application/json" -H "Content-type: application/json" -X POST -d '{"id":1,"jsonrpc":"2.0","method":"GUI.ShowNotification","params":{"title":"Boblight","message":"Enabled"}}' http://localhost:9191/jsonrpc
        /usr/local/bin/boblightd -f -c /etc/boblight.conf ;
        sleep 5 ;
        boblight-X11 -f -x -o speed=70 -o value=10 -o saturation=1.0 -o threshold=10 ;

else

        echo Boblight running, stopping boblightd + boblight-x11
        curl -v -H "Accept: application/json" -H "Content-type: application/json" -X POST -d '{"id":1,"jsonrpc":"2.0","method":"GUI.ShowNotification","params":{"title":"Boblight","message":"Disabled"}}' http://localhost:9191/jsonrpc
        killall boblightd
        killall boblight-X11
fi

I always keep the boblight addon enabled. This seems to work well when starting/stopping from a menu, but if its started while a movie is playing only boblight-x11 starts and after that the boblight addon doesnt connect to boblightd anymore. I couldnt find anything in my debug log but its no big deal really, restarting xbmc solves the problem. Im going to see if its possible to stop media playback via jsonrpc so xbmc is always on a menu when boblight is enabled/disabled.
Reply
Sorry perhaps my request is too easy, but where can I find the latest already compiled boblighthd windows deamon? I am looking for it for some days now.
Reply
(2013-01-04, 20:02)F0x123 Wrote: Sorry perhaps my request is too easy, but where can I find the latest already compiled boblighthd windows deamon? I am looking for it for some days now.

I was looking too but the one you have seems to be the latest Win version.

I would be happy if I could get it to work with any version Wink
Reply
(2013-01-04, 03:04)Martijn Wrote:
(2013-01-04, 03:02)schumi2004 Wrote: @Memphiz
Would it be possible to have an option to hide the notifications on failed and successful connections?

Yes please Big Grin

So annoying when starting my pc that each time I get connection failed and the connected message because there's no delay in it.
Same on shutdown.

Will get a PR ready for this Wink
I hope it will work because my attempt on making it still failes but then again i'm not a skilled Python coder Wink
Atleast got it working for Traktr Wink

Edit:
I think i solved it, no more script errors and not seen any notifications yet.
https://github.com/schumi2004/script.xbm...tification
Reply
Could anyone take a look at my debug log?

boblight is running and in the log I just startup xbmc, play a movie and then stop it.

http://pastebin.com/4VXm19sV

The lights only did the start thingy after I started boblight and after that nothing.

All the lights work with [email protected]

I dont know what I can try to figure out what the problem is here.
Reply
Got it to work somehow... Sad

Still looking for compiled win version of I think 461 is the latest.

Is the "rate" in the boblight.conf device specific? Or can I change it to something else?
Reply
  •   
  • 1
  • 40
  • 41
  • 42(current)
  • 43
  • 44
  • 107
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Official XBMC boblight Addon3
This forum uses Lukasz Tkacz MyBB addons.