Acer Revo USB to SD install experience (XBMC Live 10.1)
Edit: Changed the title from "Acer Revo USB to SD install experience (XBMC Live 10.1)" since I gave up on the SD idea due to slow boot times.

I have an Acer Revo (AR3610-U2002, 1.6GHz Atom, 2GB RAM, nVidia ION chipset, HDMI connection to 5.1 A/V receiver then to 1080p HDTV, Windows MCE remote with USB IR sensor, Acer wireless keyboard+mouse combo) that has Windows 7 Home pre-installed on the internal HDD. I've been happily running XBMC 10.1 on it, but I want to try running XBMC Live from an 8GB SD for faster boot, tighter system integration and access to better remote maintenance facilities than are available in Windows 7 (ssh/sftp/x2go/etc.).

I downloaded the XBMC Live 10.1 ISO and installed it to an 8GB USB stick using unetbootin v563 (the latest at this time). I then powered down the Revo and plugged in the USB stick along with a blank 8GB SD card (the Revo has an SD slot in the front). I powered it back up and entered the BIOS, setting the boot order to USB stick > SD card > HDD, then saved and exited.

The XBMC live boot menu appeared, and I chose the install option. This eventually led to a text-based partitioning wizard. Initially it scarily showed the internal HDD as its installation device of choice, but I think that I was able to choose the SD card instead after selecting the full-disk installation option. This caused the standard Linux ext4+swap partition setup to be created on the SD card, and the installation proceeded.

After following a couple of localization-related prompts and watching some status messages zip by, the installer appeared to get stuck for a good 10 minutes or so at a blank blue screen with a blank white line at the bottom. The USB stick's status light flashed on and off every couple seconds. I actually started writing this post as a call for help, as I believed that the installation was having problems, but a text window eventually showed up saying that the installation was complete. I guess the installer just doesn't bother giving status during the install? It should at least put up some kind of "Please wait while installation occurs" message, as that would be much more reassuring than a blank blue screen.

It then told me that the installation was complete and that I should remove any installation media before continuing. Figuring that it wouldn't expect me to install from USB, I left the stick in to avoid potential unmounting hiccups, then told it to continue. Surprisingly, it then said it was only 78% complete, and took a couple more minutes to finish configuring the installation (looks like it was setting up GRUB, which shouldn't have been needed for a whole-disk install, but I guess it wanted to give me the option of booting to Windows on the HDD while the SD card is installed?) and then powered down (instead of the expected rebooting, but that's okay because it gave me a chance to remove the USB stick).

I then removed the USB stick and powered back on. Following POST, the GRUB menu appeared and I chose the Linux install. The screen then went blank for 90 seconds (ouch) before the XBMC boot logo appeared (presumably a replacement for the Ubuntu OS boot logo), and it took another 30 seconds to reach XBMC main menu (during which time a text-mode login prompt briefly appeared, followed by a second XBMC startup logo that was presumably for the XBMC application itself).

The 120-second boot time for XBMC Live installed to a Class 6 SDHC card is a bit disappointing, especially considering that it's not much faster than booting Windows 7 + XBMC from a mechanical HDD. I was actually worried during the 90-second blank screen period that it wasn't activating the HDMI video output or something.

The Windows MCE remote seems to work at least as well as in Windows 7 (which was a major pain in 10.0, but much better in 10.1), and video appears to work fine. However, I could not get audio to work no matter what I tried. The XBMC Audio configuration menu lists Analog, Optical/Coax and HDMI audio output options, and Default/iec958/hdmi/Custom audio output device options; I tried every combination of the two settings (except Custom of course) with no luck.

Eventually, I read somewhere that I may need to open a terminal and run 'sudo alsamixer' to check for muted / turned-down outputs, and indeed it turned out that some or all of the SPDIF outputs were muted and/or turned down. Once I fixed this, I got sound in Youtube videos, and the fix seems to persist across reboots. Unfortunately, however, I still don't hear navigation sounds in the menus for some reason (not a deal-breaker, but still frustrating since I prefer to hear them); I again tried every combination of settings to get menu sounds, but no luck.

  • Is there a way to reduce the boot+startup time from ~120 seconds (90 boot + 30 start)? Some people were saying that the old 9.x version of XBMC Live may have run slower on SD than from HDD; is this still a known issue with 10.1? I saw some people pointing at guides, but they're very old and not specific to XBMC Live.
  • Is there something I'm missing that's causing menu sounds to be inaudible over HDMI even though Youtube videos have sound?
  • Should I do a 'sudo apt-get upgrade' in an Ubuntu terminal, or should I just leave all packages at the XBMC Live 10.1 release versions? I see that a couple dozen packages can be upgraded.

Thanks to those who bothered to read this Smile
Looks like the mediocre SD card boot time issue is most likely something endemic to Linux after all. I wasted a bunch of time following various tweak guides, but most did nothing and the most promising one I found reported cutting the boot time by only half.

As a result, I'm inclined to give up on the SD card idea and just install XBMC Live dual boot on the Revo's internal HDD. Before I can do that, though, I want to use Clonezilla to make a disk image over the LAN to the 2TB HDD in one of my desktops in case something goes wrong.
So Clonezilla was a HUGE pain to get booting from SD (I don't have a CD/DVD drive to connect to the HTPC to install from). I ended up having to use 'dd' on my Linux workstation to load the Clonezilla-SysRescCD ISO onto the SD card, and then it booted fine. Backup took a couple hours for 250GB (to a 30GB compressed archive), probably due to a combination of slow-ish HDDs and powerline networking adapters.

Installed XBMC Live to the HDD and boot time is 30-45 seconds, which is a significant improvement over Windows 7 and XBMC Live on the SD card.

Added the following to ~/.asoundsrc and it seems to have fixed the missing menu sounds (this seems like a real bug/omission in XBMC Live):
pcm.!default {
        type hw
        card 0
        device 3
        channels 2

ctl.!default {
        type hw
        card 0
        device 3
        channels 2
This messed up my sound output settings in the XBMC settings menus, but after putting everything back to HDMI it all seems to be working fine.

I also installed ssh for remote access via PuTTY and/or Linux. I also did a 'sudo apt-get update && sudo apt-get dist-upgrade', which upgraded from Ubuntu 10.04.2 LTS to 10.04.3 LTS and upgraded over 80 packages (including the Linux kernel, nvidia drivers, etc.). I haven't noticed any good or bad effects of this.

Had lots of trouble importing the database I had exported from Windows:
  • First of all, the XBMC Live importer can't browse to network locations, and I can't seem to add any sources. This left two options: either use Linux to mount the samba share with the database export and then browse to the mount point, or push the database export files to XBMC Live's local filesystem. Having recently gone through the headaches of getting SMB/CIFS mounting to work perfectly in Linux, I decided to instead do the push method via FileZilla SFTP from my desktop to the HTPC.
  • Once I got the files onto the HTPC and imported the library (which went fine), I wasn't able to play any of the videos. This turned out to be my fault for editing the database export to point to a smb:// path instead of a mounted drive letter; this isn't inherently bad, but I pointed at a slightly wrong path that didn't have Everyone permissions set on the Windows host.
  • After I fixed the permissions issue, I was able to view movies but not pull up the Info screen for them. TV Shows worked fine. I think this turned out to be due to XBMC somehow breaking the mapping between the source list and the individual movie entries in the database. I tried deleting and recreating the source list, as I remembered having set it up a little differently on the old Windows install that I exported from, but this didn't help. I'm still not able to pull up movie info for existing entries, and an update scan is causing duplicate entries to be added (for which the info screen does work, thankfully). I guess I'll have to just treat this as a movie database rebuild and clean out the old entries at the end (provided that the latter can be done in one fell swoop via the Clean Database function). This means I'll lose the data on which movies I've watched, but that's not nearly as important as the watched data for TV shows that was thankfully preserved.
I'm wondering if maybe the sources have to be set up perfectly before doing the import, and if there's no way to fix things after the fact other than clearing out the database, fixing the sources, and re-importing. I'm not sure if I want to bother trying this (I probably will once I see that my customized Star Wars ISO entries have all been replaced with generic scraper entries).

The Weather functionality seems to be broken; the weather screen is not showing any data even when I force a refresh. It could be because I installed the advanced weather plugin, whose features I can't seem to access from anywhere.

I also noticed that the YouTube plugin is staying at v2.1.3, even though a new version was supposed to have been added to the official addon repo recently. Fortunately I don't think I've had the login issue that the new version is supposed to fix. Edit: Apparently the new version is pre-Eden only, and some say it doesn't fix the login issue anyways.

I still think I'll be happier with this XBMC Live install than I was with the Windows one, once I get the kinks worked out.
I havent read the full post as I'm in airport killing time, but a quick one, can the Acer Revo support SDHC? I see all SDHC for sale on amazon say not backwards compatible with SD, and my Revo doesnt say SDHC on the slot...?
t2ffn Wrote:I havent read the full post as I'm in airport killing time, but a quick one, can the Acer Revo support SDHC? I see all SDHC for sale on amazon say not backwards compatible with SD, and my Revo doesnt say SDHC on the slot...?
Mine doesn't say SDHC either, but it appears to support it nonetheless. My card is a Transcend Class 6 8GB Micro SDHC in a micro-to-full SDHC adapter that was included with the card. I've been able to boot XBMC Live 10.1 and Clonezilla-SysRescCD from it in the Revo without problems, except of course for slow boot time. Then again, I was also able to use it with an old multi-card reader in an old Athlon 64 X2 system (my headless Linux workstation, running Xubuntu 11.10 x64). I think computers may have an easier time with reading SDHC, as the SD interface controllers are probably able to be driven mainly by software that knows how to deal with SDHC.

Anyways, XBMC Live seems to be working fine from the HDD now. I'm not sure whether my database import was failing to match up with the sources list due to a capitalization difference in the server name, or due to my having embedded name:password info in the source smb:// URLs. In any case, things seemed to work fine once I got it all matched up better (no duplicate entries on subsequent database update, and the Info screen was available for all movies that I tested).

I also did some tests to ensure that SPDIF-passthru was working with the HDMI output after I had tinkered with things to get the menu sounds back, and it was indeed working. As with Windows, I have XBMC configured for 2.0 speakers even though I have 5.1, as I prefer to have my A/V receiver perform Dolby Pro Logic II decoding on stereo streams. This works great, as 5.1 audio is passed through as pure AC3/DTS and piped directly to the speakers, while 2.0 audio is passed through as PCM and decoded to 5.1 by the A/V receiver.

This morning I got MySQL syncing working with the XBMC Live install, with the MySQL server living on my headless Xubuntu 11.10 x64 Linux workstation (and installed via apt-get instead of from the MySQL web site). After following the setup instructions in the XBMC wiki, I experienced problems with XBMC accessing the MySQL server that I eventually realized were due to the wiki not instructing me to set the password for the 'xbmc' database user. Fortunately a Google search popped up a helpful result on the MythTV wiki that helped me fix that issue.

I noticed that library access is slightly slower when the library is stored on a MySQL database on a remote server on the LAN, but this is to be expected and is not bad enough to noticeably detract from my end-user experience. I do seem to have lost some (but not all) thumbnails/fanart along the way, despite having also enabled thumbnail syncing per the XBMC Wiki article. This is a minor issue, however, and I've been working on restoring these manually via the XBMC GUI.

Quick summary of XBMC Live versus Windows XBMC impressions:
  • XBMC Live doesn't work with HDMI OOTB (out of the box), as it seems to mute some of the digital outputs by default in the ALSA mixer.
  • XBMC Live does not support menu sounds over HDMI by default, and needs some tweaking (that is not documented in the wiki as far as I can tell, but is murkily documented on the forum). Windows XBMC supports this OOTB.
  • XBMC Live boot time is much faster than Win7+XBMC (even with XBMC set as the Windows shell instead of Explorer.exe), unless booting from an SD card.
  • XBMC Live works better with MCE Remote OOTB, although my Windows experience was possibly tainted by poorer OOTB support in Windows XBMC versions prior to 10.1. If nothing else, it's nice the big green MCE button returns to the home screen by default in XBMC Live, and I don't need "remote sends keypresses" enabled (which causes problems when entering passwords with '0' in them on Windows).
  • The ability to connect to XBMC Live via SSH/SFTP for remote administration purposes is very handy. Windows 7 Home doesn't even allow Remote Desktop, UltraVNC was very slow due to the Atom CPU, and I had to move the XBMC GUI out of the way to do anything remotely.
  • Contrary to what I've read, XBMC Live doesn't seem to have any additional hardware control options compared to those offered in the Windows version. Both versions offer the ability to power off / suspend / hibernate / reboot etc. and not much else that I can see.

I'm a little more worried about trying to upgrade XBMC Live once Eden is released. Hopefully there will be a robust in-place upgrade process, but I suppose it won't be a huge deal to reinstall now that my database is stored on other machines on the LAN.
Almost a week out it's still working well. I've mostly been using Navi-X to watch random stuff, but I noticed today that the ISO rips of my daughter's baby show DVDs take 2 minutes to load the first time due to some CSS key retrieval mechanism. I'm not sure why I never noticed a similar delay under Windows using the same setup.

I also read somewhere that XBMC Live includes fluxbox as a lightweight X window manager that you can use to host other graphical Linux apps that you might want to run.

Lastly, I also heard about OpenELEC, which is a Linux distro built from scratch around XBMC for various specific HTPC hardware platforms. Supposedly it has Revo/ION support, but I think I'll stick with official XBMC Live for a few reasons:
  • It's official, which means it's likely better supported and gets the earliest updates.
  • I'm familiar with Ubuntu, so I know how to manage/administer it for home use. This makes it easier for me to either add neat things to it, or to fix it when something breaks down.
  • It runs just fine, and better than my Win7 setup did.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Acer Revo USB to SD install experience (XBMC Live 10.1)00
This forum uses Lukasz Tkacz MyBB addons.