•  Previous
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 49
  • Next 
 
Thread Rating:
  • 1 Vote(s) - 5 Average
Release - Weather Underground
#91
yeah, the script has been failing for me too. hope it gets fixed soon.
Image
[Image: watched-fanart.jpg]
[Image: widget]
Reply
#92
I hope someone can help me. I installed Eden few days ago, happy that the weather feature would work again...it does not for me. No location appears (based on IP recognition), and if I set "location" as the largest town close to me (Rotterdam, or even New ork), nothing happens. It does the same with Weather Plus.
Thank you!
Reply
#93
(2012-04-06, 17:46)pierocol Wrote: I hope someone can help me. I installed Eden few days ago, happy that the weather feature would work again...it does not for me. No location appears (based on IP recognition), and if I set "location" as the largest town close to me (Rotterdam, or even New ork), nothing happens. It does the same with Weather Plus.
Thank you!

maybe xbmc can't connect to the internet?
check if you didn't enable a proxy: System > Network > Internet connection > Use http proxy...

post a Debug Log if you can't figure it out.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#94
(2012-04-06, 22:42)ronie Wrote:
(2012-04-06, 17:46)pierocol Wrote: I hope someone can help me. I installed Eden few days ago, happy that the weather feature would work again...it does not for me. No location appears (based on IP recognition), and if I set "location" as the largest town close to me (Rotterdam, or even New ork), nothing happens. It does the same with Weather Plus.
Thank you!

maybe xbmc can't connect to the internet?
check if you didn't enable a proxy: System > Network > Internet connection > Use http proxy...

post a debug log if you can't figure it out.

Indeed! I am sure it was not the case before I upgraded. The option "use Proxy server" was turned on with no server. Now everything works. I am really grateful.
Reply
#95
glad this is working again, missed this addon for the weather!
Thanks
[Image: widget]
Reply
#96
still broken here, and no update showing.
Reply
#97
(2012-04-11, 01:45)ialand Wrote: still broken here, and no update showing.

Try a force refresh on the XBMC repo
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#98
(2012-04-11, 01:49)Martijn Wrote:
(2012-04-11, 01:45)ialand Wrote: still broken here, and no update showing.

Try a force refresh on the XBMC repo

Tried that, didn't help. Showing v 0.1.1, failing on every refresh.
Reply
#99
(2012-04-11, 22:49)ialand Wrote: Tried that, didn't help. Showing v 0.1.1, failing on every refresh.



(2012-04-06, 22:42)ronie Wrote: maybe xbmc can't connect to the internet?
check if you didn't enable a proxy: System > Network > Internet connection > Use http proxy...

post a debug log if you can't figure it out.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
if connects just fine for everything else - streaming, scraping, time Smile etc... doing it on all skins I'll clean things up and get a log.

addendum: well it's not a full log, but this barfs into it every time it fails...

Code:
14:40:43 T:2755369840  NOTICE: -->Python Interpreter Initialized<--
14:40:50 T:2755369840   ERROR: Error Type: <type 'exceptions.TypeError'>
14:40:50 T:2755369840   ERROR: Error Contents: unsupported operand type(s) for +: 'int' and 'unicode'
14:40:50 T:2755369840   ERROR: Traceback (most recent call last):
                                              File "/home/xbmc/.xbmc/addons/weather.wunderground/default.py", line 564, in <module>
                                                forecast(location)
                                              File "/home/xbmc/.xbmc/addons/weather.wunderground/default.py", line 180, in forecast
                                                properties(data)
                                              File "/home/xbmc/.xbmc/addons/weather.wunderground/default.py", line 249, in properties
                                                set_property('Current.HeatIndex'     , data['current_observation']['heat_index_f'] + TEMPUNIT)
                                            TypeError: unsupported operand type(s) for +: 'int' and 'unicode'
14:40:50 T:3017127696   ERROR: Control 402 in window 10107 has been asked to focus, but it can't

I'll do a clean one later if this doesn't point to the problem.
Reply
(2012-04-12, 00:03)ialand Wrote: if connects just fine for everything else - streaming, scraping, time Smile etc... doing it on all skins I'll clean things up and get a log.

addendum: well it's not a full log, but this barfs into it every time it fails...

Code:
14:40:43 T:2755369840  NOTICE: -->Python Interpreter Initialized<--
14:40:50 T:2755369840   ERROR: Error Type: <type 'exceptions.TypeError'>
14:40:50 T:2755369840   ERROR: Error Contents: unsupported operand type(s) for +: 'int' and 'unicode'
14:40:50 T:2755369840   ERROR: Traceback (most recent call last):
                                              File "/home/xbmc/.xbmc/addons/weather.wunderground/default.py", line 564, in <module>
                                                forecast(location)
                                              File "/home/xbmc/.xbmc/addons/weather.wunderground/default.py", line 180, in forecast
                                                properties(data)
                                              File "/home/xbmc/.xbmc/addons/weather.wunderground/default.py", line 249, in properties
                                                set_property('Current.HeatIndex'     , data['current_observation']['heat_index_f'] + TEMPUNIT)
                                            TypeError: unsupported operand type(s) for +: 'int' and 'unicode'
14:40:50 T:3017127696   ERROR: Control 402 in window 10107 has been asked to focus, but it can't

I'll do a clean one later if this doesn't point to the problem.
hehe, noticed that one myself a few days ago :-)
will be fixed in v0.1.2
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
this one should fix all issues reported so far:
weather.wunderground-0.1.2

please test and let me know if you spot any bugs :-)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
I've updated the Confluence test files to account for the fact that all the percent signs are now included with the info label. You can get the updated files here.
Providing a debug log: http://kodi.wiki/view/Log_file/Easy

Add-ons I maintain:
Artist Slideshow: Add-on:Artist_Slideshow (wiki)
SpeedFan Information Display: Add-on:SpeedFan_Information_Display (wiki)
Reply
Image

Yes. All the labels are working fine.

The only part that remains now to make this addon perfect replacement for weather+ is the full support for maps and video.

Cheers
Nessus
Reply
(2012-04-16, 19:39)nessus Wrote: The only part that remains now to make this addon perfect replacement for weather+ is the full support for maps and video.

Weather+ was, I believe, just screenscrapping weather.com to get maps and video. That meant a great deal of maintenance, as you have to update the screen scrapper every time the web site changes. You can get a map (yes, map singular) for the US based on your region. Right now I suspect that's all we're going to get.

Speaking of the map, I've having an odd issue that I was hoping someone could try and duplicate. The original map from wunderground is an animated gif, and ronie splits that up into individual png files so that the skin can display them as a slideshow. That all seems to work, but very frequently my map displays the images out of order (I'm using the hacked confluence files I created for testing). I checked the debug log, and there is nothing in there indicating an issue, and the individual png files are definitely in the right order. Here's the chuck of the skin file that creates the map:
Code:
<control type="multiimage">
    <description>maps multiimage</description>
    <posx>15</posx>
    <posy>80</posy>
    <width>620</width>
    <height>349</height>
    <imagepath>$INFO[Window.Property(MapPath)]</imagepath>
    <timeperimage>500</timeperimage>
    <pauseatend>1000</pauseatend>
    <fadetime>0</fadetime>
    <randomize>false</randomize>
    <loop>yes</loop>
    <aspectratio>keep</aspectratio>
</control>

Seems like to me it should be showing them in the correct order...
Providing a debug log: http://kodi.wiki/view/Log_file/Easy

Add-ons I maintain:
Artist Slideshow: Add-on:Artist_Slideshow (wiki)
SpeedFan Information Display: Add-on:SpeedFan_Information_Display (wiki)
Reply
  •  Previous
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 49
  • Next 
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Weather Underground51