•   
  • 1
  • 148
  • 149
  • 150(current)
  • 151
  • 152
  • 154
  •   
Another External Player Code, but Very Simple to Setup
(2014-10-15, 19:52)Roger79 Wrote: Not yet... My guess is that PDVD15 is coming soon so I'll wait until it's released before I upgrade.

Is your playercorefactory.xml any different from the one on page 1?

Thanks!
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A10 | NVIDIA SHIELD | SAMSUNG QLED QN75Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR | NAKAMICHI PRO 7.1.4 DTS:X/ATMOS 
Reply
(2014-10-15, 20:00)movie78 Wrote:
(2014-10-15, 19:52)Roger79 Wrote: Not yet... My guess is that PDVD15 is coming soon so I'll wait until it's released before I upgrade.

Is your playercorefactory.xml any different from the one on page 1?

Thanks!

No. It's the same. Although I removed the universal player as I don't need it.
Reply
(2014-10-15, 19:52)Roger79 Wrote: Not yet... My guess is that PDVD15 is coming soon so I'll wait until it's released before I upgrade.

Will try your configuration tonight.

Thanks!
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A10 | NVIDIA SHIELD | SAMSUNG QLED QN75Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR | NAKAMICHI PRO 7.1.4 DTS:X/ATMOS 
Reply
I have been using the instructions in the first post here to get 3D blu-ray iso playback with powerdvd working under windows 7/8. I had everything working fine, but.....

...I have decided to share my XBMC library via a mysql database across multiple xbmc installs. This means all files are now accessed via nfs from within XBMC. This has broken the use of the external player, because when the batch file gets to the bit where Virtual Clone Drive is asked to mount the ISO, Virtual Clone Drive does not like file paths which begin with nfs://192.168.1.100 (for example). Hence I get an error message, virtual clone drive does not mount the ISO file, and everything stops.

Can anyone who is a whizz at the windows batch file part of this explain how I get the batch file to change the file path into something Virtual Clone Drive will understand?

I think in the bit of the batch file which sets the "file" equal to %1 I need a line which will swap the nfs part of the file path to something windows and Virtual Clone Drive will understand. The NAS the files are sitting on is mapped via Windows, so I just need to get rid off the nfs part.

Any help much appreciated (and apologies if I have missed a solution to this in the prior umpteen pages).
Reply
ok, I am using the settings from page 1 with no big problems except for a couple of minor issues I can live with. Now I want to use the external player only with 3d movies files, I am ok with kodi playing the rest.
All my 3d files are sbs and they are properly named as ...3d.hsbs.mkv.
Any help will be highly appreciated.
Reply
So tonight I upgraded to Kodi from Gotham. I had my setup using TMT6 for my Blu Ray .iso and 3d Blu Ray .iso files. Well not when try to play them running Kodi they don't seem to do anything at all. Any fixes etc? Do I need to change the .bat files and or get different program to play them?
Reply
I was using Gotham and this all worked but since upgrading to Kodi today when I try to play files it seems to do nothing.

I was using external Player TMT6 to play all my BD .iso and BD 3d .iso files. I have a true 3d projector for home theater so wanted to use external play to ask like a true Blu Ray player.

playercorefactoy.xml:
Code:
<playercorefactory>
    <players>
           <player name="ISO_BDMV_Player" type="ExternalPlayer" audio="false" video="true">
            <filename>C:\Users\rmily_000\AppData\Roaming\XBMC\userdata\PlayISO.bat</filename>
            <args>"{1}"</args>
            <hidexbmc>false</hidexbmc>
                        <hideconsole>True</hideconsole>
                        <warpcursor>none</warpcursor>                
        </player>
        </players>
        <rules action="prepend">
        <!-- Bluray ISO -->
                <!-- Bluray ISO/BDMV -->
        <rule filetypes="iso|bdmv|mpls" player="ISO_BDMV_Player"/>
                 
</rules>
</playercorefactory>

PlayISO.bat
Code:
Set file=%1
Set dummy=%file:iso=%
IF NOT %dummy% == %file% (GOTO playiso) ELSE (goto next)

:next
Set file=%1
Set dummy=%file:mpls=%
IF NOT %dummy% == %file% (GOTO plaympls) ELSE (goto playbdmv)

:playiso
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 %1
"C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 6\uMCEPlayer6.exe" D:
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u
GOTO end

:plaympls
set pth=%1
set pth=%pth:~1,-25%

"C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 6\uMCEPlayer6.exe" "%pth%" exit
GOTO end

:playbdmv
set pth=%1
set pth=%pth:BDMV\MovieObject.bdmv=%
set pth=%pth:BDMV\index.bdmv=%

"C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 6\uMCEPlayer6.exe" %pth% exit
GOTO end

:end
exit

Can anyone help me out what might be wrong now? Do I need to change something? Use different external program?
Reply
This path needs to be updated.

<filename>C:\Users\rmily_000\AppData\Roaming\XBMC\userdata\PlayISO.bat</filename>
HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
W10/20H2 MPC-BE\HC PDVD19 DVDFab3,5&6 KODI 19 PotPlayer 960-4GB/RGB 4:4:4/Desktop=60Hz/Video=Matched Refresh rates 8/12bit/Samsung 82" Q90R
Reply
(2014-12-29, 18:40)brazen1 Wrote: This path needs to be updated.

<filename>C:\Users\rmily_000\AppData\Roaming\XBMC\userdata\PlayISO.bat</filename>

Good catch. I missed that one!
Reply
Hello all,

I am hoping for some help getting the external player working for 3D files with Stereoscopic Player.

I have the following for my playercorefactory.xml

Code:
<playercorefactory>
    <players>
        <player name="StereoPlayer" type="ExternalPlayer" audio="false" video="true">
            <filename>C:\Users\Kodi\AppData\Roaming\Kodi\userdata\launch3d.bat</filename>
            <args>"{1}"</args>
            <forceontop>false</forceontop>
            <hidexbmc>false</hidexbmc>
            <hidecursor>false</hidecursor>
        </player>
    </players>
    <rules action="prepend">      
        <rule filename="*3D*.mkv" player="StereoPlayer"/>    
    </rules>
</playercorefactory>

and this for my launch3d.bat

Quote:set file="%1"
C:\Progra~2\Stereo~1\Stereo~1.exe -file:%file% -nl -termend

I always get an error with file does not exist \\user:[email protected]Server\directory\file

it seems to be passing the filename to the player incorrectly. Which was when I thought it was because of spaces in the UNC path. So I pointed it to the launch3d.bat and had it add quotes to the passed filename.

Also it launches for every file not just ones with 3D in the filename.

Any help would be appreciated and if I need to provide more info please let me know.

Kodi 14 on Win 7.
Reply
I seem to be having the same troubles as rmilyard, above. When Kodi goes to play an ISO, even though it shows that it should play via the external player (total theater, via ISO_BDMV_Player),
Image


it simply shows the default internal bluray options.

Image

I noticed that kodi is not sending the parameter to have the ISO mounted.

My playISO looks like:
Code:
Set file=%1
Set dummy=%file:iso=%
IF NOT %dummy% == %file% (GOTO playiso) ELSE (goto next)

:next
Set file=%1
Set dummy=%file:mpls=%
IF NOT %dummy% == %file% (GOTO plaympls) ELSE (goto playbdmv)

:playiso
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 %1
"C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 6\uMCEPlayer6.exe" D:
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u
GOTO end

:plaympls
set pth=%1
set pth=%pth:~1,-25%

"C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 6\uMCEPlayer6.exe" "%pth%" exit
GOTO end

:playbdmv
set pth=%1
set pth=%pth:BDMV\MovieObject.bdmv=%
set pth=%pth:BDMV\index.bdmv=%

"C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 6\uMCEPlayer6.exe" %pth% exit
GOTO end

:end
exit

and the playercorefactory looks like:
Code:
<playercorefactory>
    <players>
           <player name="ISO_BDMV_Player" type="ExternalPlayer" audio="false" video="true">
            <filename>C:\Users\David\AppData\Roaming\Kodi\userdata\PlayISO.bat</filename>
            <args>"{1}"</args>
            <hidexbmc>false</hidexbmc>
                        <hideconsole>True</hideconsole>
                        <warpcursor>none</warpcursor>                
        </player>
        </players>
        <rules action="prepend">
        <!-- Bluray ISO -->
                <!-- Bluray ISO/BDMV -->
        <rule filetypes="iso|bdmv|mpls" player="ISO_BDMV_Player"/>
                
</rules>
</playercorefactory>

Help is appreciated!
Reply
(2014-12-29, 23:07)mguebert Wrote: <rules action="prepend">
<rule filename="*3D*.mkv" player="StereoPlayer"/>
</rules>

.....Also it launches for every file not just ones with 3D in the filename.

I've been trying to do exactly the same thing and I think I'm there. Firstly, I think your regex is wrong which is why all files are triggering Stereoscopic Player. Here's my PlayerCoreFactory.xml which is working:

Code:
<playercorefactory>

    <players>

        <player name="StereoPlayer" type="ExternalPlayer" audio="false" video="true">
            <filename>C:\Program Files (x86)\Stereoscopic Player\StereoPlayer.exe</filename>
            <args>-file:"{1}" -nl -fss</args>
            <hidexbmc>false</hidexbmc>
            <hideconsole>false</hideconsole>
            <warpcursor>none</warpcursor>
        </player>
        
    </players>
    
    <rules action="append">
        <rule filename=".*\.3D\..*" player="StereoPlayer"/>
    </rules>
    
</playercorefactory>

Note in my case, I'm remuxing all my 3D BluRay ISOs to MKV using MakeMKV and using the naming convention <MovieName>.3D.BluRay.mkv so the above regex matches anything with ".3D." in the name. The "\" acts as an escape character because "." means something in regex so you can't just put dots in your regex and have it find them without escaping them. There may be a more elegant regex to achieve this but it does work. This might solve your filename problem too because as you can see, you can call Stereoscopic straight from PCF.xml.

(2014-12-30, 14:44)orion_syndicate Wrote: When Kodi goes to play an ISO, even though it shows that it should play via the external player.....it simply shows the default internal bluray options.

Try using 'append' instead of 'prepend' in your PlayerCoreFactory.xml as that is meant to override the default player.
Reply
Quote:
(2014-12-30, 14:44)orion_syndicate Wrote: When Kodi goes to play an ISO, even though it shows that it should play via the external player.....it simply shows the default internal bluray options.

Try using 'append' instead of 'prepend' in your PlayerCoreFactory.xml as that is meant to override the default player.

Just tried that, and same issue remains. This all worked just fine in Gotham. Strange how now it doesn't.[/quote]
Reply
Well seeing as I still have lots of ISOs I've done a little testing for you to try and rule a few things out. Firstly, if I substitute my filenames rule with your filetypes rule, it still works fine so it's not that. You have actually tried pressing the "Play Main Title" option, right? Because I still get that initial menu too but as soon as I choose Main Title, Stereoscopic Player launches and tries to play the file.

Assuming it's not that simple, I also tried changing the name of my player in pcf.xml to the same as yours - "ISO_BDMV_Player" - again, still works fine. I can only summise that it's an issue with the batch file because the act of triggering an external player in v14.0 is definitely working correctly.
Reply
I'm having the same problems as above, although I only use the external player to play discs rather than ISOs. Previously, when I selected Play Disc it would boot up TMT 6, but since upgrading to Kodi it brings up the Kodi bluray menu (which would be awesome if it actually worked, but it doesnt). Is there a way to revert back to the old method? Seems a bit more elegant while we await full bluray support.
Reply
  •   
  • 1
  • 148
  • 149
  • 150(current)
  • 151
  • 152
  • 154
  •   



Logout Mark Read Team Forum Stats Members Help
Another External Player Code, but Very Simple to Setup13
This forum uses Lukasz Tkacz MyBB addons.