•   
  • 1
  • 6
  • 7
  • 8(current)
  • 9
  • 10
  • 154
  •   
Another External Player Code, but Very Simple to Setup
tried using the external player tonight. didn't work out so well, with play disk, it opens mpc-hc not in fullscreen, the args are the set for full screen and when i launch my sbs files, it does open up mpc-hc fullscreen, the only difference is the sbs player has the path in playercore and the play disk one uses the bat file.

I also get no sound when i do it through my audio engine build which i believe has to do with it locking the sound or something in xbmc.

i tried in eden beta and it had sound but eden is so messed up with sync to display that its unusable for actually watching movies in xbmc. maybe i have to go back to dharma.

anyway, the biggest problem however is when i launch through xbmc, i get dropped frames and presentation glitches with madvr in mpc-hc. if i launch mpc-hc by itself, that doesnt happen. any ideas on what could be going on?
Reply
bluray Wrote:And, this is where "C:\Users\big mal\AppData\Roaming\XBMC\userdata\PlayISO.bat" you saved PlayISO.bat file, right? And, this is where <"C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 5\uMCEPlayer5.exe" N:> you installed your TMT5, right? Is "N:" your VCD drive too?

I tried several BD ISO's. The only movie that playback with TMT5 using playercorefactory I created for you are BD ISO's with "_3d" files. All other files playback with XBMC!

Are your BD ISO's encrypted? If it is, you can download AnyDVD HD to decrypt it.

My drive is not n it is E: Here is my bat
@echo off
rem you can place your PlayISO file in \Roaming\XBMC\userdata\
rem you need to put the correct VCDMount drive letter in the command below

"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 %1
"C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 5\uMCEPlayer5.exe" E:
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u
Arcsoft is in default x86 program files and the bat file is in roaming folder as you said. As far as I know the encryption was stripped when I ripped it. It plays fine in xbmc in 2d mode and plays fine in tmt5 via media center.

here is a screenshot of the appdata and program files folders http://i975.photobucket.com/albums/ae237.../stuff.jpg I just edited the bat file and removed your comment made no difference Sad
Reply
bluc Wrote:My drive is not n it is E: Here is my bat
@echo off
rem you can place your PlayISO file in \Roaming\XBMC\userdata\
rem you need to put the correct VCDMount drive letter in the command below

"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 %1
"C:\Program Files (x86)\ArcSoft\TotalMedia Theatre 5\uMCEPlayer5.exe" E:
"C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDMount.exe" /d=0 /u
Arcsoft is in default x86 program files and the bat file is in roaming folder as you said. As far as I know the encryption was stripped when I ripped it. It plays fine in xbmc in 2d mode and plays fine in tmt5 via media center.

here is a screenshot of the appdata and program files folders http://i975.photobucket.com/albums/ae237.../stuff.jpg I just edited the bat file and removed your comment made no difference Sad
Your PlayISO.bat look fine. This is what I think- somehow XBMC is not seeing your Playercorefactory.xml in "AppData\Roaming\XBMC\userdata" folder. Did you save it in this folder? Can you double click on playercorefactory.xml? It'll make sure that there is no error in the playercorefactory.xml when it start up.
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
Reply
robl45 Wrote:tried using the external player tonight. didn't work out so well, with play disk, it opens mpc-hc not in fullscreen, the args are the set for full screen and when i launch my sbs files, it does open up mpc-hc fullscreen, the only difference is the sbs player has the path in playercore and the play disk one uses the bat file.

I also get no sound when i do it through my audio engine build which i believe has to do with it locking the sound or something in xbmc.

i tried in eden beta and it had sound but eden is so messed up with sync to display that its unusable for actually watching movies in xbmc. maybe i have to go back to dharma.

anyway, the biggest problem however is when i launch through xbmc, i get dropped frames and presentation glitches with madvr in mpc-hc. if i launch mpc-hc by itself, that doesnt happen. any ideas on what could be going on?
Did you set your playercorefactory for PlayDisc as shown below?

Inside playercorefactory:
<playercorefactory>
<players>
<player name="Disc_Player" type="ExternalPlayer" audio="false" video="false">
<filename>C:\Users\Dell\AppData\Roaming\XBMC\userdata\PlayDisc.bat</filename>
<args>"{1}" /fullscreen</args>
<forceontop>false</forceontop>
<hidexbmc>false</hidexbmc>
<hidecursor>false</hidecursor>


</players>
<rules action="prepend">

<!-- Bluray Disc -->
<rule protocols="bd|dvd" player="Disc_Player"/>

</rules>
</playercorefactory>

Inside PlayDisc:
@echo off
rem you can place your PlayDisc file in \Roaming\XBMC\userdata\

"C:\Program Files\Media Player Classic - Home Cinema\mpc-hc64.exe" E:


To make sure that MPC-HC is playback in full screen, you can set options>playback>fullscreen in MPC-HC to "Launch File In Fullscreen".
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
Reply
bluray Wrote:Your PlayISO.bat look fine. This is what I think- somehow XBMC is not seeing your Playercorefactory.xml in "AppData\Roaming\XBMC\userdata" folder. Did you save it in this folder? Can you double click on playercorefactory.xml? It'll make sure that there is no error in the playercorefactory.xml when it start up.

yes its in the correct location . When I doulble click it it opens with internet explorer how do I tell if there is an error? When I click the .bat file it opens tmt5 up to the list of dvd drive, So I think your right xbmc is not seeing theplayercorefactory.xml file for some reason
Reply
as i said in my previous post that playercorefactory dont work.
nothing happens.
also, i said that i dont mind playing real BD discs automatically with pdvd.
".*mkv.*" - as if to say that the file name has a different extension, where it does not.

my normal mkv and my 3d mkv has the same extension: .mkv

no need for different player. all i need is a playercorefactory that will let use pdvd for films i wat it to using " play using..."
with your playercorefactory, nothing happens when i try to play the film, and i dont even get the optio to " play using..."
please try to help
Reply
@bluray / @all

can somebody help me with Powerdvd11 and bdmc playback?
I adjusted the files to start powerdvd11 instead of TMT5 but all that happens is that a DOS screen comes ub (playbdmv.bat) but nothing happens?
I think the .bat has to be adjusted for powerdvd in order to let it play index.bdmv??

any ideas?

Thx

Atlas
Reply
Atlas100 Wrote:@bluray / @all

can somebody help me with Powerdvd11 and bdmc playback?
I adjusted the files to start powerdvd11 instead of TMT5 but all that happens is that a DOS screen comes ub (playbdmv.bat) but nothing happens?
I think the .bat has to be adjusted for powerdvd in order to let it play index.bdmv??

any ideas?

Thx

Atlas

Does the drive letter in the. Bat file match your vcd drive letter?
Reply
nope - I'm using bluray rips / folder structure - no ISO's!
Thats my problem I think.....
Reply
oh ok I have never used folder structure with blu ray rips sorry can't be more help.
Reply
yes, its exactly the same, i can work around the fullscreen thing, not the biggest deal, I can try to put the the full path right in the playercore and see if that makes a difference, but what about the glitches and dropped frames that are happening when opening mpc-hc through xbmc? should I start a separate thread for that if this isn't the right place to ask?

bluray Wrote:Did you set your playercorefactory for PlayDisc as shown below?

Inside playercorefactory:
<playercorefactory>
<players>
<player name="Disc_Player" type="ExternalPlayer" audio="false" video="false">
<filename>C:\Users\Dell\AppData\Roaming\XBMC\userdata\PlayDisc.bat</filename>
<args>"{1}" /fullscreen</args>
<forceontop>false</forceontop>
<hidexbmc>false</hidexbmc>
<hidecursor>false</hidecursor>


</players>
<rules action="prepend">

<!-- Bluray Disc -->
<rule protocols="bd|dvd" player="Disc_Player"/>

</rules>
</playercorefactory>

Inside PlayDisc:
@echo off
rem you can place your PlayDisc file in \Roaming\XBMC\userdata\

"C:\Program Files\Media Player Classic - Home Cinema\mpc-hc64.exe" E:


To make sure that MPC-HC is playback in full screen, you can set options>playback>fullscreen in MPC-HC to "Launch File In Fullscreen".
Reply
bluc Wrote:yes its in the correct location . When I doulble click it it opens with internet explorer how do I tell if there is an error? When I click the .bat file it opens tmt5 up to the list of dvd drive, So I think your right xbmc is not seeing theplayercorefactory.xml file for some reason
If there is an error, it should show error on the screen. If there is no error, it should show the entire codes on the screen!
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
Reply
tomera69 Wrote:as i said in my previous post that playercorefactory dont work.
nothing happens.
also, i said that i dont mind playing real BD discs automatically with pdvd.
".*mkv.*" - as if to say that the file name has a different extension, where it does not.

my normal mkv and my 3d mkv has the same extension: .mkv
I thought that you don't want PDVD10 to start automatcally when BD is inserted. Disable the autoplay in W7 will stop it from playback automatically, but when you use the playercorefactory with XBMC PlayDisc option it still playback autiomatically when you click PlayDisc option.


tomera69 Wrote:no need for different player. all i need is a playercorefactory that will let use pdvd for films i wat it to using " play using..."
with your playercorefactory, nothing happens when i try to play the film, and i dont even get the optio to " play using..."
please try to help
Can you post your PlayDisc.bat and Playercorefactory.xml codes in here? I want to see what is missing!
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
Reply
Atlas100 Wrote:@bluray / @all

can somebody help me with Powerdvd11 and bdmc playback?
I adjusted the files to start powerdvd11 instead of TMT5 but all that happens is that a DOS screen comes ub (playbdmv.bat) but nothing happens?
I think the .bat has to be adjusted for powerdvd in order to let it play index.bdmv??

any ideas?

Thx

Atlas
You need to download all the .bat and .xml files, and save all the files in roaming>xbmc>userdata folder. You need to replace all TMT5 path in .bat and .xml files with PDVD11 path from your HTPC. You need to make sure that all paths for PlayDisc/PlayBDMV/PayISO in .xml file are correct on your HTPC too. You should be able to use PDVD11 as your XBMC exteranal player afterward. You should be able to playback BD index.bdmv!
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
Reply
Hi bluray,

i did this - and i really only use the playbdmv.bat alongside the changes playercorefactory.
But I do have the stated problems - did you try these configs on your machine with powerdvd 11 ?
I know that pdvd needs other statements than TMT5.....
Reply
  •   
  • 1
  • 6
  • 7
  • 8(current)
  • 9
  • 10
  • 154
  •   



Logout Mark Read Team Forum Stats Members Help
Another External Player Code, but Very Simple to Setup13
This forum uses Lukasz Tkacz MyBB addons.