• 1
  • 170
  • 171
  • 172(current)
  • 173
  • 174
  • 189
How to Install XBMC PVR Xvba for AMD/Nvidia/Intel GPUs
For several weeks I am fighting with my E45M1 to have it working with Ubuntu 13.04...
3.8.0-29-generic #42-Ubuntu SMP Tue Aug 13 19:40:39 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I also installed xbmc, following the guide given in this forum.
XBMC was working, but the PC was crashing randomly within xmbc or just using other desktop application.
I found that compiz was not helping having a stable desktop situation, so I removed it.
The PC was more stable but still, XBMC and other application were having crash problems, each time it was like a video buffer corruption, some strange artefacts were displayed, upto the moment of a system crash (more exactly a system hang).
I figured out that my radeon driver must be the problem. So I decided to jump and try catalyst 13.8.
After installation, the system is stable.
I can use many applications, VLC for instance works fine now, as well as kazam and skype.
But XBMC is now crashing just after launching.
I activated the log, but the logfile is empty.
I think it must be again a problem with some driver, maybe a compatibility problem....
So I removed XBMC (apt-get remove xbmc xbmc-bin)
and redo an installation following this:
sudo add-apt-repository ppa:wsnipex/xbmc-xvba-frodo
sudo apt-get update
sudo apt-get install xbmc xbmc-bin

But still crash.
When it crashes, the PC reboots directly after launching XBMC.

What can I do to?
And more important, how did you do that:
(2013-08-08, 22:23)fritsch Wrote: I used the E45M1 for all my testing / developing of XVBA and from that I know, it should work quite well :-)

I can reinstall my whole system if necessary, I just want something working...

Thank you in advance for help and time.
Follow the howto from the first thread. Use 12.10 64 bit and install fglrx from the Repository (sudo apt-get install fglrx). That's basically it.

PS: Try to link the Debug Log
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
About a week ago I reinstalled XBMCBuntu on my computer and followed the instruction to be able to use Xvba on my machine for smooth playback and everything.
This all worked fine for me, but I noticed that I did not pick the alternative method at step 3, therefore running the new Alpha release now.
When I pause a movie, I noticed that the image as shown on the screen stretches beyond the visible part of the screen, though I "calibrated" the boundaries after installing. As a result, the playback buttons are partially "falling of the screen".
Has anyone else had this or knows a solution for this?
don't use screen calibration in xbmc, instead use amdconfig/aticonfig to disable underscan:

run this from ssh or a terminal (CTRL+ALT+F1]
sudo service lightdm stop
sudo aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
sudo service lightdm start
So I'll install 12.10.
Just to know, does that mean Ubuntu 13.04 + fglrx 13.8 does not work ?

About log:
I tried to activate the log in ~/.xbmc/userdata/advancedsettings.xml
but I receive an empty file:
# ls ~/.xbmc/temp
-rw-rw-r-- 1 xbmc xbmc 0 sept. 1 12:55 xbmc.log
-rw-rw-r-- 1 xbmc xbmc 0 sept. 1 12:28 xbmc.old.log

Thank you for this fast answer.
Quote:Just to know, does that mean Ubuntu 13.04 + fglrx 13.8 does not work ?

Every driver since Catalyst 12.10 was bad and worse. Only driver since than "partially" working with manual patching: 13.6.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Ubuntu 13.04 + fglrx 13.8 will not work. The latest working version is Ubuntu 12.10 with it's own driver.
After updating to latest xvba-testing (13.0~git20130905.0500-75d2a23-0quantal) to fix this problem I've noticed that I've got trouble with audio initialisation on LiveTV, at least I think that's what it is. If I press play there is no audio for a good 5 seconds and the picture is playing back at 10 fps for that amount of time, once audio plays picture recovers. I don't have these problems on LiveTV recordings or files in my library. I came from 13.0~git20130815.0500-36da37f-0quantal where everything works as expected.

Debug Log with those actions taken:

Starting xbmc - switching to LiveTV - playing back channel - stopping - switching to recordings - playing back recording - stopping

LiveTV -> no audio for 5+ seconds choppy video until audio recovers
Recording -> instant audio and video

http://www.xbmclogs.com/show.php?id=55279 (starting livetv at 19:50:42)

Not exactly sure where this should go, it may be a vnsi problem or something with ActiveAE. Any help would be appreciated.
Does this happen every time you start live tv? I can't reproduce.
Every time I start any LiveTV channel. It seems to be more pronounced with channels using AC3 sound, it is also there with mpeg2 but not as long it seems.
you have those in the log: ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer
indicating an issue with ActiveAE. interestingly it recovers without any additional log.
Could you post a log where you start tv 10 times. Maybe I can find a pattern. Your audio settings would be of interest too.
This problem sounds familiar, I think I have the same one. Gonna try reproducing it tomorrow!
http://www.xbmclogs.com/show.php?id=55320 there you go, starting and stopping TV 10 times. (Wasn't sure if you wanted different channels, I kept using the same 4)

Audio Settings: (I've tried to sync to Video with drop/dupe audio, same result)

I have an idea: pvr continuously calls pause on audio while buffering. we end up having quite many of those messages in the queue. I will push a fix this evening.
That fixed it indeed, just had a go on latest xvba-testing. Feels even faster now then before the problem turned up, thanks a lot. Smile
  • 1
  • 170
  • 171
  • 172(current)
  • 173
  • 174
  • 189

Logout Mark Read Team Forum Stats Members Help
How to Install XBMC PVR Xvba for AMD/Nvidia/Intel GPUs23
This forum uses Lukasz Tkacz MyBB addons.