•   
  • 1
  • 84
  • 85
  • 86(current)
  • 87
  • 88
  • 189
  •   
  Thread Closed
How to Install XBMC PVR Xvba for AMD/Nvidia/Intel GPUs
@gfisher:
Yes, what you describe could be caused by deinterlacing. Windows with fglrx cards does another deinterlacing algorithm, something like temporal / spatial. fglrx on linux only uses bob, this always causes artefacts on the last lines.

But - the screenshot linked in this bugreport indicates another issue. It seems that they did not cut the h264 frames correctly and left over some 8 pixels. If you look at the osx-quartz-1088.diff this is what they actuall do - cutting any frames (1088 -> 1080) by changing the output size.

This is iirc also done in Eden, since fernetmenta implemented cropping a long time ago.

Could you make a screenshot yourself of this issue running xbmc?
Just to be sure - could you post a mediainfo of such a file?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Fritsch thx. Do you know how to screen cap a running video? I pressed o and it did show 1920x1080 properly. In xbmc even deint off there is still some. But smplayer and vlc installed last night both show nothing, at all, abnormal with or without deint. same box. Except slight tearing like usual on those proggys. I will shoot pics with my phone if I can't get a cap On a black scene. It shows better.
update to pastebin
http://pastebin.com/fTHcJ7rY
(2012-10-11, 21:05)fritsch Wrote: @x0149128:
http://forum.xbmc.org/showthread.php?tid...pid1138272

12.6 is fine
12.8 has broken xvba
12.9 beta has broken suspend
12.9 quantal version is the best (one month newer than 12.9beta) - you can recompile it for Oneiric.

Hi Fritsch

Could you please describe how to compile quantal fglrx beta 12.9 outside of quantal for previous version, for precise as for an example ?
Don't have quantal installed for now and i'd like to test it under precise... Big Grin

I was looking for the run source file in quantal debs or some instructions but could find it for now... http://packages.ubuntu.com/quantal/fglrx

Thanks!
Please support my Blog, XBMC and Linux related :-)
http://youresuchageek.blogspot.com
@gfisher:
Press the Screenshot Button Smile must be print or something

You must have Ubuntu 12.04 installed (check with lsb_release -a) - it won't work on oneiric
@guilmxm:
it is much easier as you think,

wget the original.tar.gz file
wget the debian.tar.gz file

extract the original.tar.gz file
extract the debian.tar.gz file

and simply run out of this folder: dpkg-buildpackage -us -uc (conflicts must be solved via apt-get install missing_package_name)

Code:
mkdir tmp
cd tmp
mkdir fglrx
cd fglrx
wget http://archive.ubuntu.com/ubuntu/pool/restricted/f/fglrx-installer/fglrx-installer_9.000.orig.tar.gz
wget http://archive.ubuntu.com/ubuntu/pool/restricted/f/fglrx-installer/fglrx-installer_9.000-0ubuntu3.debian.tar.gz
tar xvfz fglrx-installer_9.000.orig.tar.gz
tar xvfz fglrx-installer_9.000-0ubuntu3.debian.tar.gz
mv *.tar.gz ../
dpkg-buildpackage -us -uc

Don't forget to enable Level51, Underscan and stuff again, also quit lightdm before.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2012-10-12, 16:30)fritsch Wrote: @gfisher:
Press the Screenshot Button Smile must be print or something

@guilmxm:
it is much easier as you think,

wget the original.tar.gz file
wget the debian.tar.gz file

extract the original.tar.gz file
extract the debian.tar.gz file

and simply run out of this folder: dpkg-buildpackage -us -uc (conflicts must be solved via apt-get install missing_package_name)

Code:
mkdir tmp
cd tmp
wget http://archive.ubuntu.com/ubuntu/pool/restricted/f/fglrx-installer/fglrx-installer_9.000.orig.tar.gz
wget http://archive.ubuntu.com/ubuntu/pool/restricted/f/fglrx-installer/fglrx-installer_9.000-0ubuntu3.debian.tar.gz
tar xvfz fglrx-installer_9.000.orig.tar.gz
tar xvfz fglrx-installer_9.000-0ubuntu3.debian.tar.gz
dpkg-buildpackage -us -uc

Don't forget to enable Level51, Underscan and stuff again, also quit lightdm before.

@fritsch

Great ! Big Grin Thank you very much !!!

So fast and efficient ^^

Please support my Blog, XBMC and Linux related :-)
http://youresuchageek.blogspot.com
fritsch thanks tried prt scrn like in windows it did not copy to clipboard for gimp paste Mapping must be borked.. i had hoped you had a diff trick. i can open a mediafire account and upload a small raw m2ts clip of a black or dark scene for you to see yourself if you like. i can cap and raw cut no reencode and keep files less than 10 megs.. do you prefer this/?
@gfisher:
When you press print, it does a screenshot - this even works in fullscreen session mode - and saves this file in your home folder on the htpc. I want to see it as you see it - as i did not have such problems on my system.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
@fritsch thx that worked but no corruption in the png. not worth posting pix you might need a small clip or external camera pic
@gfisher:

Take your mobile phone and photograph it :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
will do after work tonight it is better seen in dark since the pixels are at bottom
(2012-10-12, 16:30)fritsch Wrote: @gfisher:
Press the Screenshot Button Smile must be print or something

@guilmxm:
it is much easier as you think,

wget the original.tar.gz file
wget the debian.tar.gz file

extract the original.tar.gz file
extract the debian.tar.gz file

and simply run out of this folder: dpkg-buildpackage -us -uc (conflicts must be solved via apt-get install missing_package_name)

Code:
mkdir tmp
cd tmp
wget http://archive.ubuntu.com/ubuntu/pool/restricted/f/fglrx-installer/fglrx-installer_9.000.orig.tar.gz
wget http://archive.ubuntu.com/ubuntu/pool/restricted/f/fglrx-installer/fglrx-installer_9.000-0ubuntu3.debian.tar.gz
tar xvfz fglrx-installer_9.000.orig.tar.gz
tar xvfz fglrx-installer_9.000-0ubuntu3.debian.tar.gz
dpkg-buildpackage -us -uc

Don't forget to enable Level51, Underscan and stuff again, also quit lightdm before.

Fritsch:

When i try to compile, i get the following error:

Code:
mkdir tmp
cd tmp
wget http://archive.ubuntu.com/ubuntu/pool/restricted/f/fglrx-installer/fglrx-installer_9.000.orig.tar.gz
wget http://archive.ubuntu.com/ubuntu/pool/restricted/f/fglrx-installer/fglrx-installer_9.000-0ubuntu3.debian.tar.gz
tar xvfz fglrx-installer_9.000.orig.tar.gz
tar xvfz fglrx-installer_9.000-0ubuntu3.debian.tar.gz
dpkg-buildpackage -us -uc


dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor): -D_FORTIFY_SOURCE=2
dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2
dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor): -Wl,-Bsymbolic-functions -Wl,-z,relro
dpkg-buildpackage: paquet source fglrx-installer
dpkg-buildpackage: version source 2:9.000-0ubuntu3
dpkg-buildpackage: source changé par Alberto Milone <[email protected]>
dpkg-buildpackage: architecture hôte amd64
dpkg-source --before-build tmp
fakeroot debian/rules clean
# refresh copyright file
cat debian/copyright_stub_0 > debian/copyright
cat usr/share/doc/fglrx/LICENSE.TXT >> debian/copyright
cat debian/copyright_stub_1 >> debian/copyright
# remove any file generated from a template
for file in *.in; do \
        # strip only the last .in from the name \
        filename=`echo $file | sed -e "s|.in||"` \
        rm -f ; \
    done
rm -f debian/fglrx.substvars
dh clean
   dh_testdir
   dh_auto_clean
   dh_clean
dpkg-source -b tmp
dpkg-source: erreur: impossible de construire avec le format source « 3.0 (quilt) » : pas de « tarball » de sources amont à ../fglrx-installer_9.000.orig.tar.{bz2,gz,lzma,xz}
dpkg-buildpackage: erreur: dpkg-source -b tmp a produit une erreur de sortie de type 255

An other related source package seems to be missing, also tried with a third file mentioned in package page, but same result

http://packages.ubuntu.com/source/quanta...-installer

Code:
Download fglrx-installer
Fichier    Taille (en ko)    Somme MD5
fglrx-installer_9.000-0ubuntu3.dsc    1,5 ko    d1990f5edeb02c2c95e847a4ba2e5f6c
fglrx-installer_9.000.orig.tar.gz    109 222,1 ko    2bb6e8193fdddff9bbd2e3d9f9e8f39b
fglrx-installer_9.000-0ubuntu3.debian.tar.gz    42,2 ko    0bc6874028ca977b30a3950f2af39acd

What did you mean by "out of this folder" ?
Please support my Blog, XBMC and Linux related :-)
http://youresuchageek.blogspot.com
the problem is, that it searches for fglrx-installer_9.000.orig.tar.gz in ../

as the fglrx-installer_9.000.orig.tar.gz is in . you have to move something around - i updated the above howto
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2012-10-12, 19:45)fritsch Wrote: the problem is, that it searches for fglrx-installer_9.000.orig.tar.gz in ../

as the fglrx-installer_9.000.orig.tar.gz is in . you have to move something around - i updated the above howto

You're right and i've been a little bit stupid Rofl or tired ... Sleepy

Thanks
Please support my Blog, XBMC and Linux related :-)
http://youresuchageek.blogspot.com
Thanks fritsch for your "little" fglrx-tutorial - worked like a charm!
Asrock J5005 powered by Ubuntu 18.10 and KODI
Here is the requested xbmc.log file for sorting out issues with next on playlists with just one item:
http://paste.ubuntu.com/1275694/

Thx for watching Wink
  •   
  • 1
  • 84
  • 85
  • 86(current)
  • 87
  • 88
  • 189
  •   
  Thread Closed
 
Thread Rating:
  • 23 Vote(s) - 4.52 Average



Logout Mark Read Team Forum Stats Members Help
How to Install XBMC PVR Xvba for AMD/Nvidia/Intel GPUs4.5223