SPDIF Passthrough
#1
Hi,

I've just built up a new HTPC and I've installed Ubuntu 10.04 and XBMC, I'm having trouble with outputting SPDIF to my amp.

Audio: Realtek ALC892

I seem to be able to get 2 channel sound when in Ubuntu via SPDIF, but when in XBMC I get a "Failed to initialise audio device"

I have read lots on this topic and also tried several different things but nothing has work, can anyone shed some light, I'm really stuck on this.

Thanks in advance.
Reply
#2
I've managed to get DTS/AC3 passthrough to the amp via SPDIF following this post:

http://forum.xbmc.org/showthread.php?tid=71885

Problem is now I have no audio output for music via SPDIF, I think this is because I have in xbmc I selected
"Internal Audio Analog Stereo" in the tutorial it says use "IEC958" for audio output device and passthrough device, however I don't have the option for IEC958 in audio output device, only the passthrough device.

Any ideas?
Reply
#3
bump..

Anyone?
Reply
#4
jwarder Wrote:bump..

Anyone?

I have been searching for days on this same issue. I gave up and went back to running XBMC off of a windows build. SPDIF is a waste of time in ubuntu based XBMC.
Reply
#5
jwarder Wrote:Hi,

I've just built up a new HTPC and I've installed Ubuntu 10.04 and XBMC, I'm having trouble with outputting SPDIF to my amp.

Audio: Realtek ALC892

I seem to be able to get 2 channel sound when in Ubuntu via SPDIF, but when in XBMC I get a "Failed to initialise audio device"

I have read lots on this topic and also tried several different things but nothing has work, can anyone shed some light, I'm really stuck on this.

Thanks in advance.

XBMCbuntu? What about with OpenElec?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
SPDIF Passthrough00