•   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 11
  •   
[REQUEST] TuneIn Radio Plugin?
#46
Rofl TuneIn my Raspberry Pi... tkssssssssss
Reply
#47
Great plugin!

Although, I see some of my favorites as "Not supported", why is this the case? Here's a trace on a Raspberry Pi.

Code:
2:29:20 T:2932864064   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ValueError'>
                                            Error Contents: unknown url type:
                                            Traceback (most recent call last):
                                              File "/home/pi/.xbmc/addons/plugin.audio.tuneinradio-master/default.py", line 876, in <module>
                                                result = __tunein__.tune(__id__)
                                              File "/home/pi/.xbmc/addons/plugin.audio.tuneinradio-master/resources/lib/tunein.py", line 805, in tune
                                                f = opener.open(request)
                                              File "/usr/lib/python2.7/urllib2.py", line 393, in open
                                                protocol = req.get_type()
                                              File "/usr/lib/python2.7/urllib2.py", line 255, in get_type
                                                raise ValueError, "unknown url type: %s" % self.__original
                                            ValueError: unknown url type:
                                            -->End of Python script error report<--
22:29:20 T:3040785024   ERROR: Playlist Player: skipping unplayable item: 23, path [plugin://plugin.audio.tuneinradio/?logo=http%3A%2F%2Fd1i6vahw24eb07.cloudfront.net%2Fs31204q.png&path=tune&id=s31204&name=CJAD+-+Not+Supported]
Reply
#48
(2013-10-13, 04:30)joelones Wrote: Great plugin!

Although, I see some of my favorites as "Not supported", why is this the case? Here's a trace on a Raspberry Pi.
...

The station you are trying to play CJAD links to an external website not a stream.
Reply
#49
Hey

Thanks a lot for the great plugin , quick questions though , does it work with Gotham ?

I'm trying to install but it's giving me ( Dependcies not met )
Reply
#50
(2013-10-15, 15:31)rmohsen Wrote: Hey

Thanks a lot for the great plugin , quick questions though , does it work with Gotham ?

I'm trying to install but it's giving me ( Dependcies not met )

I'm not going to update the plugin to work with Gotham until there is a release candidate.
But looking at this post I would guess the dependency issue is probably to do with the xbmc.python version specified in the addon.xml file.
Try updating that to 2.1.0

Code:
diff --git a/addon.xml b/addon.xml
index b7c9b87..a83d9ff 100644
--- a/addon.xml
+++ b/addon.xml
@@ -4,7 +4,7 @@
   <requires>
-    <import addon="xbmc.python" version="1.0"/>
+    <import addon="xbmc.python" version="2.1.0"/>
     <import addon="script.module.simplejson" version="2.0.10"/>
   </requires>

That might get it to install, but I don't know if the plugin will work correctly without any other code changes.
Reply
#51
(2013-10-16, 00:01)brianhornsby Wrote:
(2013-10-15, 15:31)rmohsen Wrote: Hey

Thanks a lot for the great plugin , quick questions though , does it work with Gotham ?

I'm trying to install but it's giving me ( Dependcies not met )

I'm not going to update the plugin to work with Gotham until there is a release candidate.
But looking at this post I would guess the dependency issue is probably to do with the xbmc.python version specified in the addon.xml file.
Try updating that to 2.1.0

Code:
diff --git a/addon.xml b/addon.xml
index b7c9b87..a83d9ff 100644
--- a/addon.xml
+++ b/addon.xml
@@ -4,7 +4,7 @@
   <requires>
-    <import addon="xbmc.python" version="1.0"/>
+    <import addon="xbmc.python" version="2.1.0"/>
     <import addon="script.module.simplejson" version="2.0.10"/>
   </requires>

That might get it to install, but I don't know if the plugin will work correctly without any other code changes.

It should fix it. In fact every addon in Frodo repo is required to do the same.
There will be no difference between Frodo and gotham
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#52
Thanks guys. I'm not sure how to update it thought. Do I just edit the XML file ?

I installed it on frodo but it's giving me script failed.
Reply
#53
Hi Brian,

I love your add-on, but it doesn't play my favourite station which is ByteFM (http://www.byte.fm/stream/bytefm.m3u).

Is there any thing I can do to make it working?

Cheers

Mathias
Reply
#54
i just tested the tunein plugin 2.0.3 with xbmc 12.3.

i have two questions:
most, but not all of my favorit channels work, for example all my selected channels from http://www.181.fm (plugin gives a error but the same radiostations work with the mediaportal tunein plugin).
in the options i have activated "use fanart". but there is no fanart when playing a track from well known artists. is there somthing i have to do? i dont have fanart with default skin and also not with aeon nox.

furthermore i have two "feature sugestions":
is it possible to display the quality (bitrate and codec/format) of the stream as preview (same way the current songname of a station is displayd without i have to "start" the radio chanel).
is it possible to add an option to start the plugin in "favorites view"

thanks in advance!
Reply
#55
tested with Gotham nightly on Android.
I would not use Gotham, but with Frodo, the sound stutters on my Amlogic device (Pivos)
Works so far, except playing from XBMC favorites.
Plugin throws an "invalid handle"

EDIT: same issue with Frodo 12.2 on Android...
EDIT2: same issue with Frodo 12.2 on Windows...

Code:
DEBUG: static bool XFILE::CPluginDirectory::RunScriptWithParams(const CStdString&) - calling plugin TuneIn Radio('plugin://plugin.audio.tuneinradio/','-1','?logo=http://d1i6vahw24eb07.cloudfront.net/s47713q.png&path=tune&id=s98683&name=1.FM - ReggaeTrade (Reggae)')

and than:

Code:
15:04:43 T:12709760 WARNING: Attempt to use invalid handle -1

otherwise a great Plugin!
thanks
Reply
#56
its really sad that such a good service like tunein hasnt a good working xbmc plugin. at the moment 30% - 40% of my favorite radio stations dont work with current addon version 2.0.5. the same radio stations work with ipad app or mediaportals tunin addon, also the not working radio stations that are available in xbmc shoutcast2 or radio plugin work there. i reported that 4 month ago (2 posts above) but no response maybe the autor lost interest?

as i sayd i tested the radio and shoutcast2 plugin, both work very well, but both doesnt offer as much radio stations as tunein. also its not possible to save the favorite channels online. so both are not a real alternative....
Reply
#57
I am not quite sure this is tunein radio or artist fanart script issue, but it seems to using the song name as the artist name which is showing the wrong fanart. Anyone else experiencing this.
Reply
#58
would it be possible to add posibiltity to force a streamingfomat per channel/station? i have aac and mp3 radio stations. some station have 64 kb aac and 320kb mp3 quality but tunein plugin chooses the lower quality 64kb aac. if i could force "mp3" only for that station tunin would play @320kb mp3.
Reply
#59
How is the stream selection handled?
For instance this station http://tunein.com/radio/Hot-Dance-Radio-s124300/ also offers a 192 Kbs MP3 stream.
However the plugin always selects the 128 Kb MP3
Reply
#60
Getting Script error today any new updates
Reply
  •   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 11
  •   



Logout Mark Read Team Forum Stats Members Help
[REQUEST] TuneIn Radio Plugin?3
This forum uses Lukasz Tkacz MyBB addons.