• 1
  • 52
  • 53
  • 54
  • 55(current)
  • 56
[RELEASE] Radio Add-on (rad.io, radio.de, radio.fr, radio.pt, radio.es) Music Plugin
(2024-05-28, 13:46)fivebanger Wrote:
(2024-05-28, 12:18)bizounage Wrote: ...
Especially the addon is powered via an API (www.radio-browser.info) and not via scraping, so it's seems more reliable.
...

Errr.... No. Neither the original radio add-on (the "old" one from the OP), nor one of the successors discussed here recently are based on scraping. They are using/have used the API from radio.de or radio.net rep. which is returning a clear JSON data set in a similar manner than the radio-browser API. Just to not confuse others. Whether they are more or less reliable compared to others is another question.
Sorry. My mistake. When the response time of an addon is slow, I tend to conclude that it's scraping. Hence my erroneous assertion.
Reply
@andrkac
I have added a new function "play_station" to play a station by just providing the "station ID". This should also fix your issues with the stations you have reported. For further documentation, pls. refer to https://github.com/fivebanger/kodi_addon...io.radiode

@lineweight
I don't have any plans to commit my add-on to the official Kodi add-on repo yet. If you want to make advance of automated updates, you can install my add-on via my add-on repo: https://github.com/fivebanger/kodi_addon...banger.zip
Reply
@fivebanger
Thank you very much! It works like a charm. Got more work with volume etc, but this was the most important part.
Reply
(2024-05-28, 12:18)bizounage Wrote: Hi. I've tried the few forks mentioned in this thread (and a sincere thank you to the contributors for the effort). It's correct but not perfect for my needs. Then I came across the RadioChomik addon. Hallelujah. All my favorite stations are working again. Especially the addon is powered via an API (www.radio-browser.info) and not via scraping, so it's seems more reliable. Voilà. My 2 cents.

Where do you find this addon?
Reply
Here : https://github.com/JaroslawHryszko/RadioChomik
Reply
I'm currently using fivebanger's 1.1.2 version.
If I am playing a channel and I have "ProjectM" visualization running, how do I turn off the green "Radio.de" logo?
Its highly annoying and triggering.

Never mind. I believe I found it. I am using the Quartz skin. For Quartz its...

Settings->Skin->Player->Hide fanart in music player
Reply
(2024-05-29, 15:19)fivebanger Wrote: @andrkac
I have added a new function "play_station" to play a station by just providing the "station ID". This should also fix your issues with the stations you have reported. For further documentation, pls. refer to https://github.com/fivebanger/kodi_addon...io.radiode

@lineweight
I don't have any plans to commit my add-on to the official Kodi add-on repo yet. If you want to make advance of automated updates, you can install my add-on via my add-on repo: https://github.com/fivebanger/kodi_addon...repository.
I have installed Radio.de from your repo which plays channels okay.
But when I boot Kodi or play a radio station I keep getting a popup asking me to install the Radio addon.
Do I need to have the Radio addon installed even if I'm only using the Radio de addon?
ImageImage
Reply
@Jeffers24 No, there are no dependencies to the original "Radio" add-on. I have never seen a request to install the "old" Radio add-on when using the "Radio.de" add-on. Is there a possibility that you have other dependencies to the "Radio" add-on, e.g. from the skin you are using?
Reply
(2024-06-01, 14:22)fivebanger Wrote: @Jeffers24 No, there are no dependencies to the original "Radio" add-on. I have never seen a request to install the "old" Radio add-on when using the "Radio.de" add-on. Is there a possibility that you have other dependencies to the "Radio" add-on, e.g. from the skin you are using?
Thanks for confirming Radio.de has no dependencies on Radio. I thought that may be the case and asked just to check.

I thought I may have some skin shortcuts to the Radio addon that may be causing the issue.

Before posting I deleted all my skin radio shortcuts but still got the issue.

I somehow need to find out what is trying to make a call to the Radio addon  Huh
Reply
(2024-06-01, 14:22)fivebanger Wrote: @Jeffers24 No, there are no dependencies to the original "Radio" add-on. I have never seen a request to install the "old" Radio add-on when using the "Radio.de" add-on. Is there a possibility that you have other dependencies to the "Radio" add-on, e.g. from the skin you are using?
I found a couple of errors in my log
2024-06-01 14:11:43.941 T:14028   error <general>: Unable to find plugin plugin.audio.radio_de
2024-06-01 14:11:43.941 T:14028   error <general>: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.audio.radio_de/stations/my/?reload=

I need to do some more digging
Reply
(2024-06-01, 14:22)fivebanger Wrote: @Jeffers24 No, there are no dependencies to the original "Radio" add-on. I have never seen a request to install the "old" Radio add-on when using the "Radio.de" add-on. Is there a possibility that you have other dependencies to the "Radio" add-on, e.g. from the skin you are using?
I believe I have found my issue.
I had the Radio addon my stations listed as a widget in the skin.
Changing this to Radio.de addon my stations seems to have done the trick.
Image
Reply
Hi,
I need help ! 

2024-06-04 16:22:17.313 T:3470 info <general>: [plugin.audio.radio_de] __get_language has first run with xbmc_language=french
2024-06-04 16:22:17.315 T:3470 info <general>: [plugin.audio.radio_de] __get_language detected: french
2024-06-04 16:22:17.318 T:3470 info <general>: [xbmcswift2] Request for "/menu/languages" matches rule for function "show_languages"
2024-06-04 16:22:17.318 T:3470 info <general>: [plugin.audio.radio_de] get_topics started
2024-06-04 16:22:17.318 T:3470 info <general>: [plugin.audio.radio_de] __api_call started with path=v2/search/getlanguages, param=None
2024-06-04 16:22:17.319 T:3470 info <general>: [plugin.audio.radio_de] __urlopen opening url=http://api.radio.fr/info/v2/search/getlanguages
2024-06-04 16:22:19.659 T:3470 info <general>: [plugin.audio.radio_de] __urlopen HTTPError: HTTP Error 404: Not Found
2024-06-04 16:22:19.659 T:3470 info <general>: [plugin.audio.radio_de] String is missing: network_error
2024-06-04 16:22:19.760 T:3469 error <general>: GetDirectory - Error getting plugin://plugin.audio.radio_de/menu/languages
2024-06-04 16:22:19.776 T:1069 error <general>: CGUIMediaWindow::GetDirectory(plugin://plugin.audio.radio_de/menu/languages) failed[/syntax]
Reply
My in-laws are really missing their radio streams and have asked me to sort out their Raspberry Pi KODI.

The main two stations they listen to are Andys80s & Radio 10 80's Hits

Which if any of the replacement plug-ins will allow those stations?
Reply
I did a test run on our RPi and tried fivebanger plugin.audio.radiode-1.1.2.zip

I did a search for the stations in my previous post Andys80s & Radio 10 80's Hits but neither showed up.

Do I have to manually add them to stations.jsn as shown here: https://github.com/fivebanger/kodi_addons/issues/2
Reply
I found Radio 10 80's Hits but can't find Andys80s.

I've tried using the info for editing stations.jsn on github Custom streams #2 but that just made the existing stations disappear from the My Stations list in KODI.

Can anyone explain if or how I can manually add the station, it's homepage is: http://www.andys80s.com
Reply
  • 1
  • 52
  • 53
  • 54
  • 55(current)
  • 56

Logout Mark Read Team Forum Stats Members Help
[RELEASE] Radio Add-on (rad.io, radio.de, radio.fr, radio.pt, radio.es) Music Plugin5
This forum uses Lukasz Tkacz MyBB addons.