• 1
  • 47
  • 48
  • 49(current)
  • 50
  • 51
  • 56
[RELEASE] Radio Add-on (rad.io, radio.de, radio.fr, radio.pt, radio.es) Music Plugin
They will probably be using different streams or sources, one of which works and one that now doesn't.

But if you have a suitable source, one workaround option could be to set it up as a strm (wiki) file and play that directly rather than via the addon.
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

Kodi Blog Posts
Reply
I can make that solution but I have interested why same station is playing via web but under ADDON isn 't accessible

thank you for answer
Reply
(2024-04-02, 12:50)kowalski78 Wrote: I can make that solution but I have interested why same station is playing via web but under ADDON isn 't accessible

thank you for answer
Looks like the dev is no longer maintaining the radio channel links?
Reply
(2024-03-13, 01:13)Fuchs2468 Wrote:
(2024-03-13, 00:31)lineweight Wrote: I tried using the method above again, but unfortunately without any success (the suggested search term doesn't bring anything up).

Yes, it looks like changes have been made to the "Radio" website.

The new search term is now:
Code:
"hasValidStreams\":true,\"streams\":[{\"url\":
Then you should get the correct URL again.
Thanks.

In fact when I looked into this more, it wasn't that the stream link had changed, but for some reason the addon seemed to have forgotten all my custom stations and I had to set them up again.
Reply
Hi guys!
Recently I got with the radio addon the message "network_error", both on two diferent devices (windows) with LAN and WLAN. Both are really stable and working without any problems. I didn't change anything with kodi or any apps. I'm running Omega with MQ8 modded. The log shows after reinstalling the addon:
"2024-04-19 12:43:59.288 T:7120     info <general>: [plugin.audio.radio_de] get_cities_by_country started with country = None
2024-04-19 12:43:59.288 T:7120     info <general>: [plugin.audio.radio_de] __api_call started with path=v2/search/getcities, param=None
2024-04-19 12:43:59.288 T:7120     info <general>: [plugin.audio.radio_de] __urlopen opening url=http://api.radio.de/info/v2/search/getcities
2024-04-19 12:43:59.383 T:7120     info <general>: [plugin.audio.radio_de] __urlopen HTTPError: HTTP Error 404: Not Found
2024-04-19 12:43:59.384 T:7120     info <general>: [plugin.audio.radio_de] String is missing: network_error
2024-04-19 12:43:59.483 T:4400    error <general>: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.audio.radio_de/menu/cities/select/az
2024-04-19 12:43:59.484 T:14576   error <general>: CGUIMediaWindow::GetDirectory(plugin://plugin.audio.radio_de/menu/cities/select/az) failed
2024-04-19 12:43:59.679 T:5912     info <general>: [xbmcswift2] Request for "/menu/cities" matches rule for function "show_cities_submenu"

Anybody has any ideas?
Greetz
Klaus
Windows 11 Kodi Omega Aeon 8 mod
Reply
Addon seems to be completely broken since last week (here on Void Linux/Kodi 20.5 - flathub). No matter which action you perform, just getting "network error". Last week everything worked fine like the last 10 years ...
Reply
(2024-04-20, 09:11)Asato Wrote: Addon seems to be completely broken since last week (here on Void Linux/Kodi 20.5 - flathub). No matter which action you perform, just getting "network error". Last week everything worked fine like the last 10 years ...
Same to me. Kobi 20.3.0, LibreELEC (official): 11.0.6, plugin.audio.radio_de v3.0.9+matrix.1
Reply
(2024-04-20, 12:27)rws2024a Wrote:
(2024-04-20, 09:11)Asato Wrote: Addon seems to be completely broken since last week (here on Void Linux/Kodi 20.5 - flathub). No matter which action you perform, just getting "network error". Last week everything worked fine like the last 10 years ...
Same to me. Kobi 20.3.0, LibreELEC (official): 11.0.6, plugin.audio.radio_de v3.0.9+matrix.1
Forgot to write: selfdefinded radio station works fine.
Reply
It's not a fix, but a workaround.
The german API URL does not exist anymore.

You have to change:

plugin.audio.radio_de\resources\lib\api.py

Line 29 / 30:

Set the german url to the french url.
Reply
All the others are currently saying the system is under maintenance, which may also be playing a part here.
The German one is indeed AWOL with a 404 error.
|Banned add-ons (wiki)|Forum rules (wiki)|VPN policy (wiki)|First time user (wiki)|FAQs (wiki) Troubleshooting (wiki)|Add-ons (wiki)|Free content (wiki)|Debug Log (wiki)|

Kodi Blog Posts
Reply
If you open it in the browser you get the maintenance error.
But if you change it in the addon it works for me.

Edit:
Maybe the other URLs wiill be closed, too in short time.
If you inspect the website there is a complete different api. But it needs tokens.
Reply
(2024-04-20, 12:48)Publish3r Wrote: It's not a fix, but a workaround.
The german API URL does not exist anymore.

You have to change:

plugin.audio.radio_de\resources\lib\api.py

Line 29 / 30:

Set the german url to the french url.
Works for me. Thank you.
Reply
A way more simple workaround is to set "language" to something different from "German" in the add-on settings.
Reply
Can confirm this too.
Reply
(2024-04-20, 18:34)ksooo Wrote: A way more simple workaround is to set "language" to something different from "German" in the add-on settings.

Thx, nice workaround!
Reply
  • 1
  • 47
  • 48
  • 49(current)
  • 50
  • 51
  • 56

Logout Mark Read Team Forum Stats Members Help
[RELEASE] Radio Add-on (rad.io, radio.de, radio.fr, radio.pt, radio.es) Music Plugin5
This forum uses Lukasz Tkacz MyBB addons.