disable-x11 option
#1
Compiling with --disable-x11 --enable-sdl options gives following error:
Quote:DVDPlayerVideo.cpp: In member function ‘void CDVDPlayerVideo:TonguerocessOverlays(DVDVideoPicture*, double)’:
DVDPlayerVideo.cpp:845:8: error: ‘g_Windowing’ was not declared in this scope
DVDPlayerVideo.cpp:845:40: error: ‘RENDER_QUIRKS_MAJORMEMLEAK_OVERLAYRENDERER’ was not declared in this scope
/home/amaru/xbmc/xbmc/guilib/GraphicContext.h: At global scope:
/home/amaru/xbmc/xbmc/guilib/GraphicContext.h:245:1: warning: ‘g_graphicsContext’ defined but not used [-Wunused-variable]
make[1]: *** [DVDPlayerVideo.o] Error 1
make: *** [xbmc/cores/dvdplayer/DVDPlayer.a] Error 2
Platform: Ubuntu 11

config.log
http://speedy.sh/jm6kH/config.log

What's wrong? Are these options still in development state?
Reply
#2
No, they work fine but you have misused them in a way we did not predict. Perhaps you could explain why you want to configure xbmc on ubuntu 11 without x11 ?
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
#3
Same error message for me. I was trying to compile an headless xbmc. If don't want to use it in this way, maybe an additional check in the configurre could be worth?!
Reply
#4
@subbia - check out http://forum.kodi.tv/showthread.php?tid=212061 for headless
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
disable-x11 option00