Thread Rating:
  • 0 Vote(s) - 0 Average
VDPAU not working in Linux with XBMC Eden

I'm trying to get XBMC to use VDPAU to render videos. The option is selected in the configuration menu, but I still see CPU spikes when rendering high-bitrate scenes.

The video card is a Geforce 8600M.

Looking through the XBMC log file, I found this excerpt:
19:03:52 T:140430247188224  NOTICE: Opening video stream: 0 source: 256
19:03:52 T:140430247188224  NOTICE: Creating video codec with codec id: 28
19:03:52 T:140430247188224  NOTICE: CDVDVideoCodecFFmpeg::Open() Creating VDPAU(1920x1080, 28)
19:03:52 T:140430247188224  NOTICE: vdp_device = 0x00000001 vdp_st = 0x00000000
19:03:52 T:140430247188224  NOTICE: VDPAU Decoder capabilities:
19:03:52 T:140430247188224  NOTICE: name          level macbs width height
19:03:52 T:140430247188224  NOTICE: ------------------------------------
19:03:52 T:140430247188224  NOTICE: MPEG1             0  8192  2048  2048
19:03:52 T:140430247188224  NOTICE: MPEG2_SIMPLE      3  8192  2048  2048
19:03:52 T:140430247188224  NOTICE: MPEG2_MAIN        3  8192  2048  2048
19:03:52 T:140430247188224  NOTICE: H264_MAIN        41  8192  2048  2048
19:03:52 T:140430247188224  NOTICE: H264_HIGH        41  8192  2048  2048
19:03:52 T:140430247188224  NOTICE: VC1_SIMPLE        1  8190  2048  2048
19:03:52 T:140430247188224  NOTICE: VC1_MAIN          2  8190  2048  2048
19:03:52 T:140430247188224  NOTICE: VC1_ADVANCED      4  8190  2048  2048
19:03:52 T:140430247188224  NOTICE: ------------------------------------
19:03:52 T:140430247188224  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_NOISE_REDUCTION
19:03:52 T:140430247188224  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_SHARPNESS
19:03:52 T:140430247188224  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_DEINTERLACE_TEMPORAL
19:03:52 T:140430247188224  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_INVERSE_TELECINE
19:03:52 T:140430247188224   ERROR:  (VDPAU) Error: The system does not have enough resources to complete the requested operation at this time.(23) checking for decoder support
19:03:52 T:140430247188224  NOTICE: CDVDVideoCodecFFmpeg::Open() Failed to get VDPAU device
19:03:52 T:140430247188224  NOTICE:  (VDPAU) Close
19:03:52 T:140430247188224  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
19:03:52 T:140430247188224  NOTICE: Creating video thread
19:03:52 T:140430247188224  NOTICE: Opening audio stream: 1 source: 256
19:03:52 T:140430247188224  NOTICE: Finding audio codec for: 86019
19:03:52 T:140430199904000  NOTICE: running thread: video_thread
19:03:52 T:140430247188224  NOTICE: Creating audio thread
19:03:52 T:140430247188224  NOTICE: Opening Subtitle stream: 2 source: 256
19:03:52 T:140430191511296  NOTICE: running thread: CDVDPlayerAudio::Process()
19:03:52 T:140430191511296  NOTICE: Creating audio device with codec id: 86019, channels: 6, sample rate: 48000, no pass-through
19:03:52 T:140430199904000   ERROR: VAAPI - unable to initialize display -1 - unknown libva error
19:03:52 T:140430199904000  NOTICE:  fps: 23.976024, pwidth: 1920, pheight: 1080, dwidth: 1920, dheight: 1080
19:03:52 T:140430199904000  NOTICE: Display resolution DESKTOP : 1920x1080 @ 50.00 - Full Screen (12)
19:03:54 T:140430878037888  NOTICE: Using GL_TEXTURE_2D


# ~/.xbmc/temp$ dpkg -l | grep vdpau
ii  libvdpau1                              0.4.1-2ubuntu1                                   Video Decode and Presentation API for Unix (libraries)

Does anyone know what is going wrong?
One clue has led me to investigate the proprietary nvidia drivers... I'm trying various versions of them now...
Check if you can increase the amount of gpu ram in the bios.
Thanks for the suggestion! Unfortunately not possible in this BIOS. So yeah, it seems the driver tries to allocate too much graphics ram and fails miserably.

I have tried all versions from 290.10, 285, 280 and 27x, all with similar results. I couldn't build the 256 driver for this version of ubuntu (11.10) unfortunately, which is apparently right before VDPAU broke.

I believe my only next option is to downgrade to ubuntu 11.04 (after a fresh install, sigh) and try again. Not excited to say the least.
You might want to try 295,09 beta.
I believe it is not a matter of driver, since on the same box XBMC Dharma works and XBMC Eden doesn't. Other VPDAU-enabled apps work fine (e.g. mplayer). I will try investigating this further
295 is now in stable branch. Use it with the latest Eden version. I had a lot of problems in the past with eden. But no more!
I had the same problem after upgrading to Eden, updating the NVIDIA driver to 295.33 fixed it for me.
Using the Ubuntu xbmc (which uses the system libav stuff), solves the problem and I get proper VDPAU decoding
(2012-04-16, 10:29)NadirX Wrote: Using the Ubuntu xbmc (which uses the system libav stuff), solves the problem and I get proper VDPAU decoding

Hi NadirX,

What do you mean by "Using the Ubuntu xbmc", everything was working great for me on ubuntu 11.04, yesterday I've updated to 12.04 and now am having problems playing youtube and tvcatchup videos, I can hear their audio for a few seconds (no video at all) and then it all freezes.

Logs indicate issue with the video resolution and vdpau, but everything was working fine on 11.04, so can't see why this is the problem now
00:05:34 T:10930176  NOTICE: DVDPlayer: Opening: rtmp:// app=tvcatchup-103/_definst_/userID=122647/accessKey=521F7637R122647Q12O19858L-e80bcebb396f074460af9f12264182c9-4fa9a6bd/device=web/sdp=bbc_three.sdp swfurl= tcurl=rtmp:// pageurl= live=1
00:05:34 T:10930176 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
00:05:34 T:3038767936  NOTICE: Creating InputStream
00:05:35 T:3038767936  NOTICE: Creating Demuxer
00:05:35 T:3038767936  NOTICE: Metadata:
00:05:35 T:3038767936  NOTICE: trackinfo:
00:05:35 T:3038767936  NOTICE:   type                  video
00:05:35 T:3038767936  NOTICE:   profile-level-id      4d401f
00:05:35 T:3038767936  NOTICE:   sprop-parameter-sets  Z01AH5ZSAIAJNgKhAAADAAEAAAMAMp2hYuSA,aOvNSA==
00:05:35 T:3038767936  NOTICE:   description           {H264CodecConfigInfo: codec:H264, profile:Main, level:3.1, frameSize:1024x576, displaySize:1024x576, frameRate:25.0, PAR:1:1}
00:05:35 T:3038767936  NOTICE: rtpsessioninfo:
00:05:35 T:3038767936  NOTICE:   connectiondata        IN IP4
00:05:35 T:3038767936  NOTICE:   name                  WowzaMediaServer
00:05:35 T:3038767936  NOTICE:   origin                - -342846248 -342846248 IN IP4
00:05:35 T:3038767936  NOTICE:   timing                0 0
00:05:35 T:3038767936  NOTICE:   protocolversion       0
00:05:35 T:3038767936  NOTICE: attributes:
00:05:35 T:3038767936  NOTICE:   range                 npt=now-
00:05:35 T:3038767936  NOTICE:   videocodecid          avc1
00:05:35 T:3038767936  NOTICE:   width                 1024.00
00:05:35 T:3038767936  NOTICE:   height                576.00
00:05:35 T:3038767936  NOTICE:   frameWidth            1024.00
00:05:35 T:3038767936  NOTICE:   frameHeight           576.00
00:05:35 T:3038767936  NOTICE:   displayWidth          1024.00
00:05:35 T:3038767936  NOTICE:   displayHeight         576.00
00:05:35 T:3038767936  NOTICE:   framerate             25.00
00:05:35 T:3038767936  NOTICE:   audiochannels         2.00
00:05:35 T:3038767936  NOTICE:   audiosamplerate       48000.00
00:05:35 T:3038767936  NOTICE:   audiocodecid          mp4a
00:05:35 T:3038767936  NOTICE: Opening video stream: 0 source: 256
00:05:35 T:3038767936  NOTICE: Creating video codec with codec id: 28
00:05:35 T:3038767936  NOTICE: CDVDVideoCodecFFmpeg::Open() Creating VDPAU(1024x576, 28)
00:05:36 T:3038767936  NOTICE: vdp_device = 0x00000001 vdp_st = 0x00000000
00:05:36 T:3038767936  NOTICE: VDPAU Decoder capabilities:
00:05:36 T:3038767936  NOTICE: name          level macbs width height
00:05:36 T:3038767936  NOTICE: ------------------------------------
00:05:36 T:3038767936  NOTICE: MPEG1             0  8192  2048  2048
00:05:36 T:3038767936  NOTICE: MPEG2_SIMPLE      3  8192  2048  2048
00:05:36 T:3038767936  NOTICE: MPEG2_MAIN        3  8192  2048  2048
00:05:36 T:3038767936  NOTICE: H264_MAIN        41  8190  2032  2048
00:05:36 T:3038767936  NOTICE: H264_HIGH        41  8190  2032  2048
00:05:36 T:3038767936  NOTICE: VC1_SIMPLE        1  8190  2048  2048
00:05:36 T:3038767936  NOTICE: VC1_MAIN          2  8190  2048  2048
00:05:36 T:3038767936  NOTICE: VC1_ADVANCED      4  8190  2048  2048
00:05:36 T:3038767936  NOTICE: ------------------------------------
00:05:36 T:3038767936  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_NOISE_REDUCTION
00:05:36 T:3038767936  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_SHARPNESS
00:05:36 T:3038767936  NOTICE: Mixer feature: VDP_VIDEO_MIXER_FEATURE_INVERSE_TELECINE
00:05:36 T:3038767936 WARNING: (VDPAU) width 1024 might not be supported because of hardware bug
00:05:36 T:3038767936   ERROR:  (VDPAU) Error: A catch-all error, used when no other error code applies.(25) checking for decoder support
00:05:36 T:3038767936  NOTICE: CDVDVideoCodecFFmpeg::Open() Failed to get VDPAU device
00:05:36 T:3038767936  NOTICE:  (VDPAU) Close
00:05:36 T:3038767936  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
00:05:36 T:3038767936  NOTICE: Creating video thread
00:05:36 T:3038767936  NOTICE: Opening audio stream: 1 source: 256
00:05:36 T:2950679360  NOTICE: running thread: video_thread
00:05:36 T:3038767936  NOTICE: Finding audio codec for: 86018
00:05:36 T:3038767936  NOTICE: Creating audio thread
00:05:36 T:2942286656  NOTICE: running thread: CDVDPlayerAudio::Process()
00:05:36 T:2942286656  NOTICE: Creating audio device with codec id: 86018, channels: 2, sample rate: 48000, no pass-through
00:05:45 T:2942286656 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available

I'm hopping maybe your solution can help me. I might try to compile xbmc from source to see if that helps to.

Kadu: That seems to be the issue talked about in this thread:

Acer Aspire Revo AR1600
(2012-05-09, 23:10)OwlBoy Wrote: Kadu: That seems to be the issue talked about in this thread:

Thanks OwlBoy, that does seems to be the same issue I'm having.

Unfortunately there's no solution to the problem other than upgrading to unstable ubuntu, which for some reason my system doesn't seem to do with "do-release-upgrade -d". At least there's some light at the end of the tunnel.t

I'll do some more troubleshooting and paste my findings on that thread, hopefully we'll get to the bottom of the problem.

If you want to avoid trouble, never do "do-release-upgrade". Recently I tried for curiosity and it ruined my system. It's much faster and stable to do a clean installation. I have separate partitions for boot, root, and home. A new installation does format boot and root partitions, some configurations steps and finished.
(2012-05-10, 11:34)FernetMenta Wrote: If you want to avoid trouble, never do "do-release-upgrade". Recently I tried for curiosity and it ruined my system. It's much faster and stable to do a clean installation. I have separate partitions for boot, root, and home. A new installation does format boot and root partitions, some configurations steps and finished.

I haven't had any problem with the "do-release-upgrade" command on multiple linux machines.

As you might have not noticed from my post the problem is with "do-release-upgrade -d"

-d, --devel-release   Check if upgrading to the latest devel release is

For some reason it does not think I have a devel release available.

I've fixed that by editing the sources.list manually and doing a "apt-get dist-upgrade", unfortunately my problem is not fixed. but this is all irrelevant to this thread.

Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
VDPAU not working in Linux with XBMC Eden00