Enabling DTS/AC3 disables sound
#1
So, I've just brought an Onkyo HTX-22HDX system. Sounds way way better than what was in my TV, as you'd expect.

I've got my HTPC running into the back of it via HDMI and it then passes the video to the TV via its output HDMI. The output on the HTPC is the i3 2100T iGPU HDMI socket. So far, so good. However, if I select either of the digital sound options in the system/audio playback menu, I get a device failed to init error when attempting to playback a file in one of those formats.

In the settings menu I have HDMI selected as the output @ 2.1. Selecting different Audio Devices/Passthrough devices makes no difference at all aside from a few of them removing sound all together.

The receiver shows the input as PCM 44.1hz whatever is input. Put when bringing up the stream information within XBMC on a DTS file, it's showing as outputting as DTS at 1.5Mb/s. Sounds pretty good too.

Here's the debug log of an example file:

http://pastebin.com/6f4Yu1Mz

Any ideas? Thanks.
Reply
#2
Code:
DEBUG: Initialize - using alsa device :AES0=0x6,AES1=0x82,AES2=0x0,AES3=0x2
That's not right, what did you have set as passthrough device?
Reply
#3
The passthrough device is set as 'custom', although it's blank. Other options are HDMI (ALSA) and IEC958 (ALSA). Would either of them be more suitable?
Reply
#4
Yes, leaving it blank guarantees that it won't work.
Reply
#5
Okay, we'll picking the other 2 options makes no difference. On the other hand, when streaming DTS etc, it's shown as such @ 1.5mb/s, so maybe it's just a display issue on the receivers end?
Reply
#6
Could you post a debug log when using the other two options as well?
Reply
#7
IEC958 = Optical
HDMI = HDMI
Custom = plughw:X,X (0,3 for HDMI or 1,0 for analogue on mine per aplay cmd below)

X,X value is taken from the cmd aplay below.
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: default [USB PnP Sound Device ], device 0: USB Audio [USB Audio]
Subdevices: 0/1
Subdevice #0: subdevice #0

Also another thingie that can affect changes to options/selections in XBMC system/audio screen, is (drum roll), how you have defined your asoundrc file or asound.conf system file. Also, make sure it is enabled, run cmd alsamixer and enable selections using m key (I think) if disabled. Search forums for asoundrc or asound.conf and alsamixer settings for your chipset.
Reply
#8
First drop to a terminal and perform the following:
Code:
aplay -l
This will list your audio output devices.

I'm using a Biostar mini-ITX motherboard (H61 chipset) with an i3 2100 in my HTPC and I have the following in my /etc/asound.conf file:
Code:
pcm.!default {
   type plug
   slave {
       pcm "hw:0,7"
   }
}

I have AC3 and DTS capable receiver checked and as my audio output and passthrough settings are for custom with "plughw:0,7" as the output device
Reply
#9
Okay, aplay -l returns this:

Code:
**** List of PLAYBACK Hardware Devices ****
xcb_connection_has_error() returned true
card 0: PCH [HDA Intel PCH], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC889 Digital [ALC889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

First I tried entering the same code as pumkinut as 0,7 seems to be correct here too. I entered this into the audio device/passthrough and that caused the 'failed to init' errors regardless of whether AC3/DTS was enabled, ditto 0,3.

Anything other than 'Default (ALSA)' entered into Audio Output device causes failures, its frustrating Sad
Reply
#10
Did you also create the /etc/alsa.conf file I noted in my post and reboot? Without that, it's probably not going to work. The 0,7 entries will probably be the correct values, as the HDMI interface on the Intel IGP boards tends to be HDMI 1 and not HDMI 0.
Reply
#11
I recommend following the advice of the developer who asked you to post the other debug logs.
ASRock ION 330
Ubuntu 11.10 x86_64 minimal install
xbmc from unstable ppa
Reply
#12
Debug logs are probably not needed, however an asound.conf file is as well as making sure the audio outputs are not muted through alsamixer. All of this has already been pointed out.

Now, if the OP does create his asound.conf, matches his audio output settings to it, determines that none of the outputs are muted with alsamixer, and still has problems, then debug logs and further investigation are warranted.
Reply
#13
Alrighty so here's what I did

http://imgur.com/a/doFIS

Alsamixer was set with the above settings, that file was written to /etc/asound.conf (and rebooted) and those settings were used within XBMC.

Result? No sound output at all from any file, DTS or otherwise, but no 'failed to init' error either.

Here's a debug log from trying to play a DTS movie:

http://pastebin.com/PemTjQ50

Seeing as how I didn't get an error, I'm hopeful that we're getting closer to a solution! I also tried changing everything from 0,7 to 0,3, but that brought the return of init errors, so that's deffo not a solution.
Reply
#14
Motherfuckin' FIXED!

The problem? Auto mute mode enabled in Alsamixer. Once I disabled it a shitload more passthrough/output devices became available inc. HDA Intel PCH - hdmi - 0 (ALSA), which will happily output DTS Smile
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Enabling DTS/AC3 disables sound00
This forum uses Lukasz Tkacz MyBB addons.