•  Previous
  • 1
  • 16
  • 17
  • 18(current)
  • 19
  • 20
  • 22
  • Next 
Thread Rating:
  • 2 Vote(s) - 5 Average
[RELEASE] rtmpGUI plugin
I was just wondering whether there are any channels from Hong Kong like TVB channels, TVB Pearl, etc... ? Because I saw there are some from china but there are none from Hong Kong and also Japan Smile
I would like to see if there are any streaming channels from there. Thanks, get.
(2012-03-18, 23:16)HansMayer Wrote:
(2012-03-18, 22:52)s4ug4 Wrote: Hi,

i can't get around the 60 second stream stops problem (not in rtmpgui or in rtmpgui+). I've updated the librtmp.dll but whenever i enable the "updated librtmp option" the stream doesn't start at all.

Here is a log: http://pastebin.com/Fy3gSsir

I think the problem is: "21:36:20 T:3904 ERROR: Unknown option swfsize" ?

What can i do to get this working? Thanks for any help.

P.S. a lot of the channel selections by language in rtmpgui+ gives me a script error (ie Austria, Swiss, France etc.) as well as the default rtmpgui list.

@ustheboss: the blackoutworms list is working for me
blackoutworm's list works fine.

The problem here is that you haven't successfully updated your librtmp. Are you sure that you copied the file to right directory?

oh i'm sorry of course you're right... i copied the lib to \XBMC\system and not to \XBMC\system\players\dvdplayer Blush

so i have to restore the original file in \XBMC\system or...?

Thanks a lot for all the good work
You can safely replace both, however the one in the dvdplayer core is mandatory.
Ok thanks. Btw... Are there any plans to set up a repository or integrate rtmpgui+ and SuperTV into an existing repository to get auto updates?

For some reason the epg sometimes does not show the actual event:


I'm using the last version of rtmpgui+ (1.1.0) and xbmc 11.0(eden) on my ATV2. Yesterday rtmpGUI list has worked ok. Today when I enter I get "error script failed plugin.video.rtmpguiplus. I have also updated libRTMP. What can be wrong ? Here is the log: http://pastebin.com/htH53B7Z
I'm also using the latest version of rtmpgui+ (Version 12) on my ATV2 and having similar problems with these channels (BBC one, BBC two, Channel4, Channel5, ITV1, ITV4, Dave , PickTV, E4, and Move4. They seemed to work the first day and now I get "error script failed plugin.video.rtmpguiplus". l tried updating the libRTMP file, but having the same error. Please help. Great site and addon. Thank-You.
Hi everyone,
I'm new in this topic. I've installed rtmpgui on my Windows 7 PC, with VLC. I followed every step to setup everything but when I doubleclick on a channel, I can't have anything else than a black screen in VLC.
I'm from France, I don't know if it change something or not, but if someone can help that would be very nice!
salut mbiaud,
I had the same problem and i just changed the VLC version(2.0.1) with an oldest (1.1.11 in this case) and it works.
Find an oldest version here:
OK guys a little confused here. I've updated RTMPDump to the latest version but im completely stuck on how to update libRTMP to get livestreams, livetv and this plugin to work on a xbmc-live distro. Has anyone a step by step as as it is i'm getting some streams working but very few (most of the uk ones fail and i'm from the UK lol).

I've upgraded my xbmc install to Eden Final but i'm completely at a loss on how to find, download, compile and replace libRTMP in ubuntu 10.4 live distro. Any help would be so greatly appreciated.


Ok as far as I know i've upgraded librtmp on my xbmclive doing the following

Quote:git clone git://git.ffmpeg.org/rtmpdump
cd rtmpdump/
make SYS=posix
cd librtmp/
sudo cp -f librtmp.so.0 /usr/lib/librtmp.so.0
sudo cp -f librtmp.a /usr/lib/librtmp.a
cd /usr/lib/
sudo ln -s librtmp.so.0 librtmp.so

Rebooted but still none of the stream work. BBC Iplayer, ITV Catchup, 40d and Demand 5 work perfectly with the updated RTMPDump so what am i doing wrong ?

Ok got it working Smile

Heres what i did.

Make sure you have everything on your XBMCLive distro to make and compile the new library.

Quote:sudo apt-get install build-essential gcc make subversion libssl0.9.8 libssl-dev libssl0.9.8

Then download the latest RTMPdump source from https://github.com/svnpenn/rtmpdump/zipball/KSV
Extract onto your xbmc live distro then enter the commands below.

Quote:cd svnpenn-rtmpdump-c5bab88/
cd librtmp
sudo cp -f librtmp.so.0 /usr/lib

That fixed it.
-= My Media Centre =-
ACER Revo R3610 | x2 1.5TB WD Caviar Green SATA Hard Drives (WD15EADS) | x2 2.0TB WD Caviar Green SATA Hard Drive ( WD15EARS ) | 3.5in Black eSATA USB Trayless SATA External Hard Drive Enclosure | Emprex 3009URF Wireless MCE Remote Control | XBMCLive Dharma Beta1


thank you
Great to know have people working harder to make this tool woking. Unfortunatly I still in problems, Some channels I can not see them at all live , I mean if I watching them in VLC it open fine, but not in xbmc. Now I did every steps you shown, with no results I try to open this channel " RSI LA1 " and it fail! Is it too much if I asking to somebody to send me by email the correct plugin.video.rtmpGUI_All_Lang with all tools I have to install?
Thank you for your understanding!
Hello! the link of update the library is broken wouls you proved me a good working link?

(2012-03-06, 01:44)iraqiboy Wrote:
HansMayer Wrote:First of all: Dude (or Dudette), AWESOME.

I updated the script, it sorts the streams by language, adds <logourl> for channel logos, accepts local xml files with file:// and most importantly
fixes a serious bug where the parameters from <advanced> weren't passed, which lead to some streams not playing.

Installation: Replace the default.py in the plugin.video.rtmpGUI directory with this one.
If you want to watch European streams, you might want to update your libRTMP as well.

if you get the "Script failed" error with the original script, you need to do three things:
1) Install the update from above
2) Install http://code.google.com/p/anarchintosh-pr...p&can=2&q=
3) Add
<import addon="script.module.elementtree" />
between <requires> and </requires> in plugin.video.rtmpGUI/addon.xml.
BTW, if the streams buffer, close some programs and restart XBMC. Or install more RAM.

Have fun Big Grin

i did fellow your steps and im still getting script failed. is it possible if you can update the link with new iupdated plugin? thanks

First of all, this is an awesome plugin and I'd like to thank everyone who made this happen.

Now, I have a question. Is there a way to disable certain item or link from the list? In particular those that are not appropriate for the whole family, especially my XBMC box is sitting in the family room, I'd like to limit what can be access from it. Thanks in advance.
(2012-04-19, 07:46)utahcafe Wrote: Hello! the link of update the library is broken wouls you proved me a good working link?
How to update your libRTMP.
I need a little help figuring out an HD stream buffering issue. I have a pretty solid 10Mbps connection and I have tested the various UK HD streams on two computers. Computer one is in no way memory and processor constrained. The second computer is a little older but should still be fine. The first computer is an 17 2600 with 16Gigs of Ram and Gig E connection on my LAN out to a 10Mbps cable modem connection so that should be enough to stream UK HD streams but every single one of them buffers. None of my other streaming media players buffer at all. Is anybody successfully streaming HD?
  •  Previous
  • 1
  • 16
  • 17
  • 18(current)
  • 19
  • 20
  • 22
  • Next 

Logout Mark Read Team Forum Stats Members Help
[RELEASE] rtmpGUI plugin52