[ATV2] - Streaming Music from SmartPhone to XBMC-UPnP-Renderer takes too long to load
Hello everybody,
I've got a specific problem with my XBMC running on a jailbroken ATV2.

At home I run a MediaServer with an USB-connected HDD on a FRITZ!Box 7270 router, where I've got my music stored on. I've got an ATV2 connected to my TV and my hi-fi system. I run everything over WLAN in 802.11g-mode (54Mbit/s)
My thought is that I want to access my MediaServer over my android-smartphone (Motorola Defy+) as a remote control and stream the music to my ATV2.

It works without jailbreak of the ATV2 when I use the app "Twonky-Media-Server", where I can beam my music over Airplay. It's ok, but the app is slow and the user interface is not exactly what i want to have.

Therefore I tested some over apps (UPnPlay or BubbleUPnp), which for me are much more lightweight, faster and better to control. The fact, that these apps only can stream to UPnP-Renderers and not to Airplay made me jailbreak the ATV2 and install XBMC on it.

Now I turned on the option "UPnP-Renderer" under "System -> Network" and the XBMC-Renderer-Device was found in the network.

Now my actual problem:
When I select a music-title with my phone from my MediaServer and press "play", it begins to play instantly, when I select the local phone renderer. When I select the XBMC-renderer I would estimate, that the song starts to play instantly, too (at least after a short gap), but nothing happens. After a "long" while (15 - 20 seconds are too long for me), it starts to play first.
When I switch to the next song, it's all the same - it takes 15-20 seconds to start, which is far too long for me.

I already plugged my ATV2 to the network over a cable, but it's the same. I also created a file "advancedsettings.xml" and set the parameter
"cachemembuffersize" to values between "0" and "5242880", but nothing changed.

I know that the WLAN or the MediaServer might be the problem and not XBMC itself, but as I already wrote, it works with the Twonky app over Airplay, which begins to play immediately.
For me it seems that XBMC loads the complete MP3-file and then begins to play. I thought that it might be possible to configure XBMC that it begins to play instantly, even if the file isn't loaded completely (just like Youtube Smile).

It would be nice if somebody has got the same problem or can give me a hint what to do.

Might be that I'm totally wrong in this forum. Then sorry for that. ;-)

Thank you very much.
I do not know if it the same as your issue, however I seem to get a 15-20 second delay per song when streaming songs from a WAN FTP where even the UI becomes unresponsive. Currently using Beta 1. Any help would be appreciated.
any log appreciated too...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
I think I have the same issue. Running XBMC on Windows 7, playing from an Android phone using 2player.

I have the same issue too!
Windows 7 running XBMC 11 and foobar2000 with upnp server. When I set the upnp source in my ATV2(xbmc 11), I select the two sources on my pc (XBMC 11 and foobar2000) When I select to play from foobar2000, everything is ok. When I select from the music of XBMC it takes 15-20 second delay per song and the UI becomes unresponsive. I will post a log tomorrow but I am sure anyone can reproduce it, I think it is a problem of the upnp server of XBMC.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
[ATV2] - Streaming Music from SmartPhone to XBMC-UPnP-Renderer takes too long to load00