Thread Rating:
  • 0 Vote(s) - 0 Average
A couple questions about fonts.
#1
hello,

i am really happy to see that the ttf fonts get antialiased now, a lot of my media has japanese info and therefore i am stuck in a ttf font.

i have a couple of questions though.

1) is it possible to make the ttf fonts a bit smaller in the gui? the original font looks really good, but the ttf font (i am using arialuni.ttf) is too big and makes some labels overlap.

2) when i play a song with japanese id3 info, on the visualisation screen, it displays just those little boxes [] instead of characters. everywhere else in the gui the characters display fine.

any help would be much appreciated!
Reply
#2
1. is already been done by chokemaniac in cvs.

2. has likely been fixed as well. if you feel it hasn't, please upload an example file so that we can look into it.

thanks,
jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
Reply
#3
ok thanks. i will upgrade to the latest cvs this weekend. if it's all been fixed, i will place my foot firmly in my mouth :-)
Reply
#4
ok, i updated to the latest build just now and the fonts look great. as you said, they now show up on the visualisation screen too. however, the id3 tags on my japanese music is just showing gibberish text.
it's japanese, it's just not correct.
Reply
#5
maybe you could make a dummy file, paste the id3 tags in and post it here so we can investigate..

are you sure its japanese? maybe check on your pc what characters are missing and see if arialuni.ttf has them...
[Image: pm_banner.jpg]

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
Reply
#6
yeah, i know the tags are all correct, because they worked fine before i updated, with the exception of the visualisation screen (which i mentioned before). of course i can upload a file, but where to?
Reply
#7
http://www.rapidshare.de/
Reply
#8
there is currently a bug in cvs if the file contains id3v1 tags as the ape tag reader currently reads these which takes priority over id3v2 - this may be the issue. furthermore, it had a bug (that is now fixed in cvs) that screwed up utf8 strings.

the id3v1 priority bug is fixed in my local source - just gotta commit it.

and yeah, it'd be handy if you'd upload a snippet with the tags intact.

cheers,
jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
Reply
#9
ok, i uploaded one of the songs...

here is the link.

sayonara wo iwasanaide
also, i am updating from cvs as we speak. i will post back if it is working or not.

edited to include link that works... hopefully!!
Reply
#10
nah, still nopt working...

i guess it wasn't the utf8 bug.
Reply
#11
does this look ok?

http://rapidshare.de/files/1772539/scree...3.jpg.html

cheers,
jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
Reply
#12
yes, that's perfect... did you need to do anything? how did you fix it?
Reply
#13
awesome, i just installed the latest cvs and it's working fine. thanks a lot!!! :bowdown:
Reply
#14
maybe still minor problem here.

id tags on song list screen are ok but have problem on visualisation screen.

please check out these images ;

http://rapidshare.de/files/1884965/scree...e.jpg.html

http://rapidshare.de/files/1884983/scree...e.jpg.html

http://rapidshare.de/files/1884988/scree...e.jpg.html

thanks.
Reply
#15
sorry mate, i'm on virgin.net, so can't access rapidshare for downloads (stupid transparent proxies!Wink

you can upload to http://www.xboxmediaplayer.it/upload if you want me to look at it.

cheers,
jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
A couple questions about fonts.00