•  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 103
  • Next 
  Thread Closed
 
Thread Rating:
  • 17 Vote(s) - 4.76 Average
[WINDOWS][PATCH]Bitstream output of HD audio formats
#16
Am I the only one thinking WTF? This is incredible!

Any way your work could be merged into the Windows sink for AE?
Living Room: ASUS Chromebox / OpeneElec 5 / Kodi 14.2
Bedroom: Amazon FireTV Stick / Kodi 14.2
Home Office: Amazon FireTV Stick / Kodi 14.2
Windows Server: Intel Core i3-2100T / 8GB Ram / 48TB / MySQL / StableBit DrivePool on Server 2012 R2 Standard
#17
Just tested on my system and it works great. Never could get the July version working on my setup, but this works great.

Sandy Bridge 2100, 430gt GPU, Pioneer 1120.

Thanks, you just made my week.
#18
I tried it on my lowest spec (E350M1) HTPC and Onkyo 7.1 surround sound system. If it work on my E350M1, it will definitely work on my more powerful HTP's too. I tried BD ISO movies "Thor (DTS-HD 7.1) and Kung Fu Panda 2 (TrueHD 7.1)". I watched roughly 10 minutes on each movie, and it bitstreamed flawless. Are these Gnif AE codes? If it is, I want to personally thank him for the latest AE and thank you for taking time to compile it and shared it with us. Great job!
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
#19
This is awesome!!! Just tried and only found one file it won't work on (DolbyTrueHD). Has a video sync issue on it. Trying to find the culprit. Otherwise perfect. Thank you so much, I thought this would never happen so soon.
#20
really thx for this release. Need only merge pvr inside your git (down know how can i do ... :/)

Thx Again
#21
you are the man.
#22
.....
#23
@ all: Thanks for all of your testing efforts - I appreciate them heartedly!

I can see those random TrueHD issues on my setup as well, but only if I play them from the original M2TS container. In almost every case output is fine on a retry. If I remux these files into my preferred MKV container I can't see playback issues, and the same is true with exactly the same audio streams in raw audio files. To me this looks like a timing problem deep down in the dvdplayer engine.

@ Memphiz: this is a Windows-only (former OS/2-only) shop - sorry Wink

@ steelman1991: I've never been hiding anywhere, my HTPC project started in december last year and I had to do something about the sad state of affairs when it comes to HD audio bitstreaming. Back then AE was seemingly abandoned and no binary worked on my brand new rig. And this is only a small part of the project...

@ Philmatic: rip the code apart, keep what you like, and dump the rest ...

@ bluray: there is gnif/AE stuff in there - it's too good to be put aside. My idea was to check what's available, take what works, add what's missing, and fix what needs fixing. And then strip all of the surplus code lines such that impact to main xbmc trunk code is kept as low as possible.

@ charlievoviii: try one more time. Hint: Daniela is a female name here in Germany Wink
ciao, Dani

AMD Fusion E-350/Win 8/custom XBMC, Yamaha RX-V1900, Pioneer DV-LX50, custom speakers
#24
DDDamian Wrote:Ah yes - I see the database change. Good you pointed that out in case anyone tries it and needs to revert.
What's the difference for the database?
Fanart.tv

HTPC 1: ChromeBOX (LibreELEC Krypton Build)
HTPC 2: Intel NUC D34010WYK (Windows afedchin's Krypton MVC Build)

_____________________________________________________________
RIP schimi2k
I miss you buddy :(
#25
ArieS Wrote:What's the difference for the database?

The database update comes from commits that have been done in XBMC after Beta2 has been released. No high impact changes though. Some commits that changed something in the SQL views were reverted so the database version had to be updated so that the "new" (old) views were re-created correctly.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
#26
DanielaE Wrote:To me this looks like a timing problem deep down in the dvdplayer engine.

@ Philmatic: rip the code apart, keep what you like, and dump the rest ...

@ charlievoviii: try one more time. Hint: Daniela is a female name here in Germany Wink

Hi Daniela - AE is seeing the same dvdplayer timing or fetch issues as well, resulting in some skips/drop-outs or discontinuities as they are logged, so you are correct in the source of that issue.

@philmatic - the WASAPI sink of AE already handles the bitstreaming in shared and Exclusive modes Cool but there's issues further up the ladder as noted above, plus some recently introduced stream-handling code that needs work.

Gotta say though, this is a working solution, and a great piece of work.

Daniela - you da woman lol. Wink
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
#27
Montellese Wrote:The database update comes from commits that have been done in XBMC after Beta2 has been released. No high impact changes though. Some commits that changed something in the SQL views were reverted so the database version had to be updated so that the "new" (old) views were re-created correctly.

So Montellese - are the nightlies post-Beta 2 using MyMovies60.db? As you say - low-impact but good for peeps to know if they try this, add items and have to revert for whatever reason.
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon AVR-3808CI - Denon DVD-5900 Universal Player - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray - X-Box 360 - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
#28
For some reason I need to change either the audio track (if the movie has more than one) or change the audio output from HDMI to coax, and then back to HDMI (while in a movie) to get audio working. Other than that this works great.
#29
DDDamian Wrote:So Montellese - are the nightlies post-Beta 2 using MyMovies60.db? As you say - low-impact but good for peeps to know if they try this, add items and have to revert for whatever reason.

Yes if the build from Daniela has a MyVideos60.db then it's a post-Beta2 build because Beta2 uses a MyVideos58.db.

But sure if someone wants to revert to Beta2 he must live with the fact that anything added while using the post-Beta2 build will not be in his Beta2 database.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
#30
DanielaE Wrote:@ all: Thanks for all of your testing efforts - I appreciate them heartedly!

I can see those random TrueHD issues on my setup as well, but only if I play them from the original M2TS container. In almost every case output is fine on a retry. If I remux these files into my preferred MKV container I can't see playback issues, and the same is true with exactly the same audio streams in raw audio files. To me this looks like a timing problem deep down in the dvdplayer engine.
I tried 3 BD ISO movies with TrueHD audio on my AsRock E350M1/GT430 HTPC and Onkyo AVR (7.1 speakers). It seems to work fine with Audio settings as shown below.

I like a woman who take matter to their own hand, and don't rely on their hubby on everything. You remind me of one of the lady that used my guide to build her first HTPC, and she got everything to work the way she like it on her first trial. Great job! Smile

Image

Image
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
  •  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 103
  • Next 
  Thread Closed
 
Thread Rating:
  • 17 Vote(s) - 4.76 Average



Logout Mark Read Team Forum Stats Members Help
[WINDOWS][PATCH]Bitstream output of HD audio formats4.7617