Thread Rating:
  • 0 Vote(s) - 0 Average
[LINUX] Audio Problems with Eden Beta 3 and Ubuntu 11.10
#16
Stop all that messing about and use -

Custom: plughw:1,3

in both Audio and Passthru.
I struggled for a bit, but managed to get it working on my cleanly installed R3700 this way.
(Used to be plughw:1,7 on Eden B2).
Image
Maraschino - Web based HTPC Organiser. Keep track of all your web based programs all in one place.
Home Page - Repo - Bug Tracker - Support Forum.
Reply
#17
I "solved" the problem by using the optical out (SPDIF) of my Revo....That works like a charm....
Reply
#18
I gave up on XBMC Live because of the audio troubles. Back to Windows 7 using Splash player.....!
Reply
#19
Hi all,

I am running into the same problems as mentioned here with my Zotac Box.
Interestingly enough, I can now use
plughw:1,3
on both the audio and the passthrough devices.
This makes me hear audio perfectly via HDMI.

But in order to not have to turn my TV on which is the first receiver of HDMI signals, I wanted to make use of SPDIF.

But I cannot find any plugh:xxxxx or other audio setting to make this working

What I tried:

plughw:1,0
plughw:1,1
hw:1,0
iec958:CARD=NVIDIA,DEV=0

No luck.

With Dharma, as far as I remember, no issues. Even not with the live CD I am currently working with.
And: with Win7 no SPDIF problem either.

So what's broken here?
Reply
#20
Hi,

Are you (people who have this sound initialization problem) using A/V sync (in settings => video => Playing) ?

I have this problem too, turning off A/V sync makes everything works (but no A/V sync...).
More weirder, I have this problem with "not-default" skins (Aeon Nox/Alaska), if I use Confluence, then no problem.

In case that could help...

Regards.
Reply
#21
esprit Wrote:I have this problem too, turning off A/V sync makes everything works (but no A/V sync...).

Same problem on OpenElec:

http://www.openelec.tv/forum/68-audio/26...-issue-214
Reply
#22
Yes, that's my thread there Big Grin
Reply
#23
hope someone can help me. I have the same problem.
With the custom settings plughw:1,3 i get white noise from the tv speakers. Tried every possible custom setting that is written in this thread but couldn't get the audio to work. I don't have A/V sync activated and the TV doesn't have a SPDIF input.
Hope someone has another idea how this problem could be solved. With dharma i had no problems activating the audio output through hdmi.
Reply
#24
post output of aplay -l and aplay -L
Reply
#25
aplay -l
Quote:**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

aplay -L
Quote:null
Discard all samples (playback) or generate zero samples (capture)
default
both
multi
hdmi_formatted
hdmi_complete
front:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
Front speakers
surround40:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
HDA Intel, ALC888 Digital
IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
Direct sample mixing device
dmix:CARD=Intel,DEV=1
HDA Intel, ALC888 Digital
Direct sample mixing device
dsnoop:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
Direct sample snooping device
dsnoop:CARD=Intel,DEV=1
HDA Intel, ALC888 Digital
Direct sample snooping device
hw:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
Direct hardware device without any conversions
hw:CARD=Intel,DEV=1
HDA Intel, ALC888 Digital
Direct hardware device without any conversions
plughw:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
Hardware device with all software conversions
plughw:CARD=Intel,DEV=1
HDA Intel, ALC888 Digital
Hardware device with all software conversions
hdmi:CARD=NVidia,DEV=0
HDA NVidia, HDMI 0
HDMI Audio Output
dmix:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Direct sample mixing device
dsnoop:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Direct sample snooping device
hw:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Direct hardware device without any conversions
plughw:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Hardware device with all software conversions

I have a "ZOTAC ZBOX Blu-ray HD-ID34"
Reply
#26
Do you get sound with this command?
aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav

If yes, first try non passthrough in xbmc. plughw:1,3 does not work on my id80 for some reason but plug:hdmi:NVidia does.

For passthrough custom device use:
hdmi:NVidia

Note this is case sensitive.

If this does not work, you might need a probemask for snd_hda_intel

EDIT: rename your asound.conf while trying in order not to have a default device.
Reply
#27
Similar problem for myself on my Zotac ZBox trying to enable HDMI output to my TV. Normal menu sounds work fine, its only when playing any MKV file (All files play successfully on the rest of my XBMC kit):

aplay -L shows:

Quote:null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=Intel
HDA Intel, ALC888 Analog
Default Audio Device
front:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
Front speakers
surround40:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Intel,DEV=0
HDA Intel, ALC888 Digital
IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
Direct sample mixing device
dmix:CARD=Intel,DEV=1
HDA Intel, ALC888 Digital
Direct sample mixing device
dsnoop:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
Direct sample snooping device
dsnoop:CARD=Intel,DEV=1
HDA Intel, ALC888 Digital
Direct sample snooping device
hw:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
Direct hardware device without any conversions
hw:CARD=Intel,DEV=1
HDA Intel, ALC888 Digital
Direct hardware device without any conversions
plughw:CARD=Intel,DEV=0
HDA Intel, ALC888 Analog
Hardware device with all software conversions
plughw:CARD=Intel,DEV=1
HDA Intel, ALC888 Digital
Hardware device with all software conversions

aplay -l shows:
Quote:**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

I've already updated the file /etc/modprobe.d/alsa-base.conf to add the following line to the bottom:

options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

Can anyone help?
QNAP TS670 NAS - 4x4TB Raided with NFS Support & Central MySQL DB
Pi 3 [Xbian] - Samsung 46" ES7000 Smart TV & HT-E5550 3D BD Sound System
Pi 3 [Xbian]  + Hyperion Ambilight- Samsung 48" Curved UE48JS9000 4k
PowerEthernet T1502 Powerline adapters
Reply
#28
FernetMenta Wrote:Do you get sound with this command?
aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav

That worked

Quote:If yes, first try non passthrough in xbmc. plughw:1,3 does not work on my id80 for some reason but plug:hdmi:NVidia does.

How can I get non passthrough?

Quote:For passthrough custom device use:
hdmi:NVidia

Note this is case sensitive.

If this does not work, you might need a probemask for snd_hda_intel

EDIT: rename your asound.conf while trying in order not to have a default device.

Still no sound. Same thing as nsviper. SD Files work but HD .mkv files don't.
Reply
#29
You enable passthrough with AC3 capable receiver in audio settings. If you hear no sound check your xbmc.log for "device busy". This message means that the device can't be muted and used for passthrough. To make it work on Ubuntu 11.10 I unconfigured system sounds by not having an asound.conf with a default device and did not set hdmi device in gstreamer-properties.
On my 10.10 or Fedora system it works with system sounds.

BTW:
Quote:options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2
This is wrong. Bit 8 should not be set. Values < 16 are correct and in most cases only a single bit is needed.
Reply
#30
FernetMenta Wrote:You enable passthrough with AC3 capable receiver in audio settings. If you hear no sound check your xbmc.log for "device busy". This message means that the device can't be muted and used for passthrough. To make it work on Ubuntu 11.10 I unconfigured system sounds by not having an asound.conf with a default device and did not set hdmi device in gstreamer-properties.
On my 10.10 or Fedora system it works with system sounds.

Disabled AC3 and now it works. Thanks for Your help. Now I can finally lean back and enjoy a movie again Cool
Reply



[LINUX] Audio Problems with Eden Beta 3 and Ubuntu 11.1000