Thread Rating:
  • 0 Vote(s) - 0 Average
XBMCbuntu lcdproc causes hang on shutdown
Hey All,

Anyone else seeing this - I did a clean install last night. setup lirc, audio, addons all that is great, suspend/resume works just fine. Install lcdproc and I cannot reboot (hangs at shutdown) and suspend will no longer put the machine to sleep, actually it is like I never even pressed the power button)
sudo apt-get remove --purge lcdproc restores everything to working fine.

I still use lirc as it is easy to setup from the get go. reconfigure lirc choose devinput(Linux input layer) and then by-id if00 for me. stop lirc from loading modules and then copy the Lircmap.xml to .xbmc/userdata and change the device to devinput instead of mceusb and edit missing functions, works like a dream using the kernel modules and ir-keytables is not installed.

I installed lcdproc from apt, I will try and build an older version from source tonight and see if that changes anything.

The shutdown issue I have seen with the several 11.10 build I have done in the last couple weeks but never an issue with suspend after installing it and setting up my suspend/resume script.

just configured and installed two different versions of lcdproc from source and installed them and they both create the exact same problems.

Hang at shutdown and no suspend. Uninstall either version and everything works just fine.

why is xbmc trying to start the lcd server, is that just for the internal lcd device, I would think that should only try and start if it is enabled.

ive had lots of issues with the lcd on my setup, causing hangs on shutdown, or massive delays booting
my lack of knowledge led me to just doign away with the lcd (unplug) for the time being until there was a suitable solution
I have looked a little further into it and it seems there is an issue with the lirc init script on shutdown. error I see is K19lirc blocked then kernel hang message. As far as I remember both S (start) and K(Kill) call or are symlinked to the /etc/init.d/ lirc init script.

The shutdown issue I have seen on ubuntu 11.10, Mythbuntu 11.10 and now XBMCbuntu. The suspend problem I only have with XBMCbuntu. I will find the problem with the init script first it may be as easy as killing lirc earlier in the shutdown process which I will try tonight.

Well I fixed it on my machine and this is what I did.

manually changed all S20LCDd in /etc/rc0-6.d to S10LCDd (not all of those directories have an SxLCDd link)

manually changed all the K20LCDd in /etc/rc0-6.d to K30LCDd (not all of those directories have an KxLCDd link)

changed my /etc/pm/sleep.d/07LCDd to 99LCDd

and I got rid of the the /etc/pm/sleep.d/99lirc-resume script (not sure why this is needed or included in 11.10 by default)

reboots just fine now, suspend and resume works just fine and the Imon LCD (ffdc) works perfectly. It goes to sleep and kills the backlight on suspend and wakes up just fine as well.

I think it was a combination of the above because I cannot see why the 99lirc-resume script would cause an issue with the system rebooting.

ah, you are using hte same display as me (and 11.10)

I shall follow your info and see what i can achieve
do you have any other tips and tricks to getting hte lcd working properly, its been some months since i tried to do this,
i ended up with bootup/shutdown issues (guide above)
the powering down off the back light not working, and or corruption on the display when powered down/standby

many thanks
How are you using lirc. is your device an LCD (ffdc) lsusb will tell you.

It is just a matter of installing lcdproc from the command line with apt-get install then edit your /etc/LCDd.conf changing the server section as below (you can also change the goodbye message in there I usually do not as when it goes to sleep it makes no differenc to me)

setserver screen = no

scoll down to the imonlcd section and make sure the protocol is correct
uncomment OnExit=2 line

save and restart (sudo /etc/init.d/LCDd restart)

make the changed above and turn on the lcd in xbmc you should be good.

If you need the sleep script let me know and I will paste a copy of it.

see, this is where it gets tricky
i haven't got a remote i can use with the lcd/ir receiver
so i am runnign a seperate hauppage dvb-t500? ( i think thats right) tuner card and remote
i had loads of issues getting the remote working, the documentation has got very flaky for the later versions of ubuntu
eventually it just worked (pretty sure without lirc), so putting lirc on throws all sorts of extra issues in
irkeytables throws up the remote keypresses (last time i checked)

i assume lirc is not required just to get the lcd working with lcdproc
i will have a good look tonight and experiment when home

Ah, yes it is the ffdc display as I recall (with the volume knob, not bothered as it is pointless)

I switched over to XBMC Eden recently.
Now I am experiencing the same shutdown issue like rodercot.

K19lirc is blocking the reboot / shutdown.

I wanted to apply the solution from below
rodercot Wrote:Well I fixed it on my machine and this is what I did.

manually changed all S20LCDd in /etc/rc0-6.d to S10LCDd (not all of those directories have an SxLCDd link)

manually changed all the K20LCDd in /etc/rc0-6.d to K30LCDd (not all of those directories have an KxLCDd link)

changed my /etc/pm/sleep.d/07LCDd to 99LCDd
but my files are numbered differently and because I haven't understood the cause now Huh I'm struggling with what to do.

In all of those /etc/rc0-6 folder my files(if they exist in there) are named S60LCDd and K60LCDd respectively.
To be on the safe side below the content of rc0.d as an example.
K19setserial -> ../init.d/setserial
K20inputlirc -> ../init.d/inputlirc
K20sphinxsearch -> ../init.d/sphinxsearch
K20tvheadend -> ../init.d/tvheadend
K20unattended-upgrades -> ../init.d/unattended-upgrades
K30etc-setserial -> ../init.d/etc-setserial
K31atieventsd -> ../init.d/atieventsd
K60LCDd -> ../init.d/LCDd
S20sendsigs -> ../init.d/sendsigs
S30urandom -> ../init.d/urandom -> ../init.d/
S35networking -> ../init.d/networking
S40umountfs -> ../init.d/umountfs
S48cryptdisks -> ../init.d/cryptdisks
S59cryptdisks-early -> ../init.d/cryptdisks-early
S60umountroot -> ../init.d/umountroot
S90halt -> ../init.d/halt

I would really be happy if somebody could either explain me the cause or the soultion or even both Big Grin


bump Confused
I have the same issue on shutdown but also a random xbmc freeze on startup due to lcd proc (if i stop via /etc/init.d/ LCDd xbmc goes on). I'm on precise so i have K60 and S60.
I tried the above suggested, startup issue seem to be ok now, i will let you know if it also fix well both problems.
Can you tell me what exactly you have done to fix that issue?
I am still having freezes on when I shutdown XBMC via remote control, everything runs fine via SSH though.

I'd like to hear something back on this too.

XBMCbuntu lcdproc causes hang on shutdown00