XBMC Library Auto Update - Script Error
(2012-04-10, 19:40)tentimes Wrote: Hi,

I have the same problem, script failing.

Is there any answer to this yet? I am surprised to see 11.0 pushed with this in it. Are we posting in the wrong place for anyone to take notice?

Sorry for this not getting the attention it probably deserves. Please use this thread (http://forum.xbmc.org/showthread.php?tid=119520) to post any problems or requests, I follow it regularly. Side note: please use a log site like xbmclogs.com if posting debug logs - thank you!

(2012-04-13, 00:25)tentimes Wrote: I have now recreated this bug on two windows 7 x64 machines. In both cases I then uninstalled Eden Beta 3, cleared out all old data, then installed Eden 11 (release). In both cases the script is failing and I have a fucked up library with no way to fix it. The only solution seems to be to go back to Beta 3.

Is there a bug tracker? I'm off to look, as this seems pretty bad in terms of bugs to have.

I'm curious how this "fucked up" your library. It only scans content, and if it didn't scan anything then it should be 100% the same. If you're test machines had paths like "Donné" then it is likely you created the same error in your setups. Please post a debug log as Harlock did if you would like a further look.

(2012-04-17, 18:18)Harlock Wrote: I worked around this by using standard ASCII names only, I created a new user Donne instead of Donné
Not perfect but hey it now works.

Oh, and it is easy to copy the C:\Users\Donné\AppData\Roaming\XBMC folder to the new user e.g. C:\Users\Donne\AppData\Roaming\XBMC

Everything then works fine.

Thank you for doing some testing on this. I looked at your log and if we follow it you'll see the error was actually thrown in the Python OS package. I think the path returned via xbmc.translatePath must have been something it could not parse. As you concluded this is most likely due to the characters in your username. I'm going to have a go at recreating this and see if there is a way to encode the string in a way that this function will complete.
Hi Rob,

I assumed as much, the problem is/was not in the add-on but in a certain combination with the Python handler because it worked fine in release 0.5.4 of the add-on and release candidate versions of Eden.
The add-on did not change, I tested 0.5.3, 0.5.4 and 0.5.6.

Thanks for the response.
In the little testing I was able to get done so far I've found out by using the unicode() function of python I can get windows to accurately interpret these types of filenames. I've pushed a version of this to my github account and plan on making a pull request for the xbmc repo soon. Can't guarantee that this will solve your particular problem but in my testing it seemed to.

I'll post back once I can confirm that the changes have hit the xbmc repo and maybe you can test it out for me on your system?

how would i fix this same problem on atv1 getting script error on apple tv eden11.0
(2012-07-11, 19:05)jenniferdiane Wrote: how would i fix this same problem on atv1 getting script error on apple tv eden11.0

What is "the same problem"? There were quite a few discussed in this thread. If possible could you post a debug log? If getting files off the atv is a pain there is an addon for posting logs to the XBMC pastbin site in the addon repo. That seems work well for people with iOS or XBMCbuntu devices that don't want to muck with the file system.
I'm using XBMC alpha 9 and I'm getting a script error on startup. Is this addon not compatible with Gotham? Any suggestions?

Edit: Oddly I'm only getting the error if I have a custom cron set. It works fine if I just have the default update every hour.

I want it to update every 5 minutes so I set */5**** which should be correct. Why would that give me a script error?
Your cron syntax looks incorrect. You need spaces between the different parts:

*/5 * * * *
Rofl Thanks!
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
XBMC Library Auto Update - Script Error00