Remove source missing from context menu
#1
Hi!
I just installed XBMC Eden beta3 Live on an Acer Aspire R3700. Works fine but I have an entry I can't remove from Videos/Files. I was playing with this new install and tried adding some entries to the Videos library. After that I guess the usual way is to right-click (or press "c" on the keyboard) on the entry to get the context menu. I was getting the full menu on all entries (and was able to remove them if I wanted to) except for one. The context menu for it is incomplete. It only shows: Play, Add to favourites, Add source, Change content, and Scan for new content. The "Remove source" options is nowhere to be seen, though it's not the only one that's missing. One thing I noticed is that it's name in the Videos/Files list appears differently than it's in the filesystem. The name of the file would be: "[name] date.wmv" (without the quotation marks). In the Videos/Files list it is: "[name (date)" (again, without the quotation marks). Would a square bracket in the name cause that? And more importantly how do I remove that name from the list? Thanks for any suggestions.
Reply
#2
You want to remove a source (i.e. a path to your files) or a movie file (a single file)?

Is the source an auto-added source (eg usb stick that auto-popped up) or something that you added via "Add Source"?
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#3
Hi!
I want to remove a source. I've done some more testing and even though it seems it's related to how the source folder is named it doesn't look like square brackets have anything to do with it. Here's how I consistently reproduce it:

from the main screen
-> Files
-> Add Videos...
-> Browse
-> Windows network (SMB)
-> WORKGROUP
-> FREENAS
-> Storage
-> Folder 2009-06-05
-> OK
-> OK

Then the source is listed as "Folder (2009)" and not as "Folder 2009-06-05". If the source folder is named "Folder2009-06-05" (note the lack of space) then I get the full context menu after adding it to the list.

The source folder is on a CIFS share on FreeNAS-8.0.3-RELEASE-p1-x64 (9591) server.
Reply
#4
There's a bug in b3 that *might* be causing this - not completely sure. Try turning off Settings->Video->File Lists->"use library names for file listings". If that fixes it, then grab RC1, as this is fixed (RC2 is out in a couple days if you want to wait for that).

Cheers,
Jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#5
OK, thanks! Will try that.
Reply
#6
That was it! After changing the setting I had access to the full context menu. Thanks!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Remove source missing from context menu00
This forum uses Lukasz Tkacz MyBB addons.