wasapi 2ch to 5.1ch issue
#1
i have the problem that 2ch come to my receiver as 2ch. when i use direct sound then i get 5.1ch with only front sound. i use windows 7 x64 pro and set hdmi out to 5.1. wehen i use aimp3 for mp3 with wasapi it shows the setup from windows (5.1), when i edit windows settings i see it in aimp too. with direct sound i only get 2ch in aimp. atm i must use dts neo 6 from the receiver. but sounds not like aimp when i hear mp3. is there any code for advancedsettings ore some other?
A/V: Sony KDL52W5500|Yamaha RX-V471|Elac Cinema XL Center|4x Elac Cinema 2 Sat|REL Strata II|Elac Sub 101 ESP
HTPC: Realan E-Q8|ASRock Z77E-ITX||i3-3225+HD4k|8GB 2133 RAM|60GB Vertex3|120W Pico PSU|p8 USB-CEC|Win7 x64
Server: Raid 5 - 8x 2TB WD AV-GP|Win7 x64|HighPoint 2680
Reply
#2
Sorry, could you break that down a little more clearly?
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon  AVR-3808CI  - Denon DVD-5900 Universal Player  - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray  - X-Box 360  - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
Reply
#3
i mean that upmix from 2ch to 5.1ch doesnt work in xbmc but in other programs it works. but why? have i something configured wrong? with direct sound i get an upmix but only sound from front speakers.
A/V: Sony KDL52W5500|Yamaha RX-V471|Elac Cinema XL Center|4x Elac Cinema 2 Sat|REL Strata II|Elac Sub 101 ESP
HTPC: Realan E-Q8|ASRock Z77E-ITX||i3-3225+HD4k|8GB 2133 RAM|60GB Vertex3|120W Pico PSU|p8 USB-CEC|Win7 x64
Server: Raid 5 - 8x 2TB WD AV-GP|Win7 x64|HighPoint 2680
Reply
#4
Ah, understood. XBMC does not have an upmixer, you can expect one after the Eden rollout is complete. Some drivers do have that option - you can check in your windows audio panel. It is more likely to be an option using DirectSound, not WASAPI, but again, not all drivers have this option.

When you see 5.1 on your receiver playing a stereo source, it is simply matching the WASAPI settings as required, but filling in blank channels.

It is a feature you can expect in the near future.
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon  AVR-3808CI  - Denon DVD-5900 Universal Player  - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray  - X-Box 360  - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
Reply
#5
ok, thanks for answer. so i can stop searching for success. i will try it again later.
A/V: Sony KDL52W5500|Yamaha RX-V471|Elac Cinema XL Center|4x Elac Cinema 2 Sat|REL Strata II|Elac Sub 101 ESP
HTPC: Realan E-Q8|ASRock Z77E-ITX||i3-3225+HD4k|8GB 2133 RAM|60GB Vertex3|120W Pico PSU|p8 USB-CEC|Win7 x64
Server: Raid 5 - 8x 2TB WD AV-GP|Win7 x64|HighPoint 2680
Reply
#6
Hello!

Although I have a different setup than Nimo's, I experience opposite concerning the upmix in XBMC.
I run Win 7 x64 and have Asus Xonar DX Analog connected to 4.0 speakers. XBMC Eden Beta 3 of course is also set to analog and 4.0. The output is through WASAPI.
I am happy about it, that my stereo sound source is upmixed to 4.0. It does not happen, however, on Winamp be it DS or WASAPI output, but I again have Upmix in Foobar through WASAPI.
Can somebody explain, where the upmixing occurs? If it is in XBMC, can I control it, are there any settings? My sound card drivers should not do upmixing, as I have the source selected as 6 channels and output as 4 channels.

Any comments?

Cheers
Reply
#7
I assume this is in DVDPlayer (the video side of XBMC)? There is the radio button in the popup audio window when playing a movie to enable this, but it is not actually backed by any code since the XBox days.

So I'm not actually sure where your upmix is occuring? Not in XBMC with WASAPI.
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon  AVR-3808CI  - Denon DVD-5900 Universal Player  - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray  - X-Box 360  - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
Reply
#8
I found some hint later, and posted in another thread http://forum.xbmc.org/showthread.php?tid...pid1045637

I am almost sure that upmix is done on driver level. Unfortunately, there is no control over that, c-media and asus bad.

However, still the question, what does XBMC do with eg. 5.1 source and 2.0 analog output? Are there any settings for down/upmix available?
Reply
#9
I figured it was the driver doing it for you - some do have that capability. XBMC can downmix from 5.1 to 2.0 - the only setting available is "Boost volume level on downmix" available in the audio popup of the OSD available while playing a movie.
System: XBMC HTPC with HDMI WASAPI & AudioEngine - Denon  AVR-3808CI  - Denon DVD-5900 Universal Player  - Denon DCM-27 CD-Changer
- Sony BDP-S580 Blu-Ray  - X-Box 360  - Android tablet wireless remote - 7.1 Streem/Axiom/Velodyne Surround System
If I have been able to help feel free to add to my reputation +/- below - thanks!
Reply
#10
I am sure XBMC can. This is the quote from 11.0 Beta " Improved audio channel matrix mapping, audio channels downmixing, and upmixing support".

It is just the lack of description (wiki) about when and how it works - at least regarding the source and output settings.
Reply



Logout Mark Read Team Forum Stats Members Help
wasapi 2ch to 5.1ch issue0
This forum uses Lukasz Tkacz MyBB addons.