Thread Rating:
  • 0 Vote(s) - 0 Average
Eden RC2 crashes when trying to play some files
Hey everyone. Like the thread title says, I'm seeing the RC2 of Eden consistently crash when I try to play certain videos from my library. I set up the debug log and looked for any error lines, but all I see is:

21:11:24 T:2964115456 ERROR: CCoreAudioRenderer::InitializePCM: The selected device (Built-in Output) does not have a speaker layout configured. Using the default layout.
21:11:24 T:2964115456 ERROR: CCoreAudioRenderer::InitializePCM: Please go to Applications -> Utilities -> Audio MIDI Setup, and select 'Configure Speakers...'

Is there anything I can do to test this further? Other logs to check? A way to back up my current settings and test with a default set?

Any help would be much appreciated
There may be other things in the debug log (turn on debug logging in Settings->System->Debugging) that might help.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.

I hope this helps:
Something else I tried was to remove all of XBMC's settings and trying to reload the entire library. Took awhile but didn't fix any problem. So far I can only replicate this on my Mac Mini.
Can I please get some assistance on this issue? I've tried to completely uninstall and reinstall XBMC, I've removed SoundFlower (which was popping up in the debug logs), I've wiped all the client settings and verified the videos work through VLC. What can I do? I'm really desperate here because the list of files I can replicate this with grows every week!
I'm assuming that XBMC v11 (Eden) final didn't fix the issue for you? I'm not sure what the issue might be, but I'm guessing we'll need some more details.

Run MediaInfo (wiki) on one of the files that causes a crash and post that info as well, as it will give more details about the codecs and settings than we can see in XBMC's log.

Maybe a fresh debug log using v11 final.

Crashreporter log as well from /Users/<username>/Library/Logs/CrashReporter/

If you can make a small clip of a file that causes an issue (IIRC, Mpeg Stream Clip is good to use to make such clips because they don't re-encode the file) and put it up on Dropbox or something, so we can have a test file, that would help as well. A minute or two of video would be fine.

What year/model is your MacMini? How is it connected to the TV and/or receiver? (HDMI directly, or HDMI via DVI adapter, is audio using HDMI or is it via optical or analog, etc)

If we can recreate the situation behind the crash then we will be in a lot better position to fix it, so all these things will help.
You're correct in that 11.0 Final did not fix this issue. From what I can tell, only MPEG4 videos will always work. AVI's and MKV's are the only types that make the application crash, but it's not every single file of this type. I'll work on getting a shorter video up, but here's the nitty-gritty details:

MacMini3,1 with 4GB of RAM and an internal SSD, running 10.7.3 with all the latest updates. The media files are on a Drobo Gen2 attached via Firewire 800. The Mac is connected to a TV but in a slightly odd way; I use a mini-DVI to DVI adaptor, and then a DVI to HDMI cable for the video. The audio goes out through the headphone jack to analog audio on the TV (a 42" Sharp Aquos from a few years back). SoundFlower USED to be installed, but I removed it because I thought it was causing problems.

This is the log snippet of what happens when I try to watch an episode of "Clerks". What you're seeing is all debug-level output from the moment I hit "Play" while viewing the episode in the library list.


I hope this information is more helpful than what I've posted before.
I've managed to fix this bug. It turns out that I had the Video -> Playback -> Render Method setting on "Software", but once I changed it to "Auto detect", the crashes stopped!

Eden RC2 crashes when trying to play some files00