•  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 14
  • Next 
 
Thread Rating:
  • 2 Vote(s) - 3.5 Average
[RELEASE] Sickbeard XBMC - Control Sickbeard from XBMC
#16
ursli Wrote:First of all thanks for this great plugin, now the not so nice part, I ran into a script error. When I want to manage my shows it errors out with some unicode failure. (I can browse History/Upcoming though)

Log: http://pastebin.com/NnCWPGuj

Another thing, I guess you're not using the sickbeard API for calls, at least it didn't ask for my API key, wouldn't it be easier and more future proof to use that?

That is an interesting error you are seeing (thanks for the log btw). Do you have any shows that are named... differently? Not sure how to ask that, but my guess is the error is coming from the URL parser on one of your show names. Can I trouble you to send me a list of the shows you have added to Sickbeard?

And yes I am using the API, I just "detect" it so users don't have to manually enter it. It's not so bad to enter it manually if you have a keyboard hooked up to XBMC but the people with just remotes (like on my ATV2) it is painful enough to enter an IP :p.
Reply
#17
acegutta22 Wrote:it says that i need to check user name and password and i dont have one

Can you make sure you have your IP/Port set up correctly and that you have the API enabled? It's under the General section of Sickbeard's settings. Just enable the API and generate an API key. I forgot to add that note to the installation instructions.

That error message is too generic right now, I just implemented password protection and that error will pop up if the connection to Sickbeard fails for any reason. This weekend when I have more time I will add better error handling so failures are clearer about what is actually wrong.
Reply
#18
chemlab Wrote:omg i love you .. you already made a webapp that i can't live w/o and now this Big Grin cant wait to give this a try this weekend.

Thanks for the praise but I didn't develop Sickbeard, just a fan of it as well and wanted to contribute to it's awesomeness! Laugh
Reply
#19
Maniaczm Wrote:That is an interesting error you are seeing (thanks for the log btw). Do you have any shows that are named... differently? Not sure how to ask that, but my guess is the error is coming from the URL parser on one of your show names. Can I trouble you to send me a list of the shows you have added to Sickbeard?

And yes I am using the API, I just "detect" it so users don't have to manually enter it. It's not so bad to enter it manually if you have a keyboard hooked up to XBMC but the people with just remotes (like on my ATV2) it is painful enough to enter an IP :p.

Ah, that makes sense at the API, thanks for the clarification.

Regarding the show names, it's probably my girlfriends German series using umlauts. (Ä Ö Ü) Can't think of anything else that would be named different then any of the usual shows.

Example:

Code:
2012-03-07     CSI: Den Tätern auf der Spur     CBS     HD 241 / 268    N     Continuing

Is that enough or you want some more?
Reply
#20
No I think that should be enough but thanks ursli, that's probably the culprit. I will try adding that to my Sickbeard and see if it causes the same error. I think I have a solution in mind but I'll have to mess around with that show name to see if I can resolve it. If nothing else I can work around that error as a quick fix so the rest of your shows will be displayed Wink.
Reply
#21
Maniaczm Wrote:No I think that should be enough but thanks ursli, that's probably the culprit. I will try adding that to my Sickbeard and see if it causes the same error. I think I have a solution in mind but I'll have to mess around with that show name to see if I can resolve it. If nothing else I can work around that error as a quick fix so the rest of your shows will be displayed Wink.

Code:
url="+urllib.quote_plus(str(tvdbid))+"&mode="+str(menu_number)+"&name="+urllib.quote_plus(show_name)

The urllib.quote_plus is picky/buggy so you could encode show_name to utf-8
Pneumatic | SABnzbd | XBMC that just works - openelec
Reply
#22
Popeye Wrote:
Code:
url="+urllib.quote_plus(str(tvdbid))+"&mode="+str(menu_number)+"&name="+urllib.quote_plus(show_name)

The urllib.quote_plus is picky/buggy so you could encode show_name to utf-8

Yeah, that's the path I was thinking. I think that will work fine in regards to the plugin directories, I'm wondering if it will translate over when making the calls to the Sickbeard API. As I'm typing this I am thinking it will since Sickbeard has to already process these. Thanks for your input again Popeye, you are making these issues too easy to solve! Big Grin
Reply
#23
No worries! I'm in a utf-8/unicode hell myself right now and have run into this issues several times before in my nzbs addons....
Pneumatic | SABnzbd | XBMC that just works - openelec
Reply
#24
Hah, i know what you mean. Just seeing the work unicode pop up made me shudder a bit. Have had some major headaches associated with character encoding in some previous projects.
Reply
#25
Also getting the Check username/password error.

Where do you find/setup the IP?


Maniaczm Wrote:Can you make sure you have your IP/Port set up correctly and that you have the API enabled? It's under the General section of Sickbeard's settings. Just enable the API and generate an API key. I forgot to add that note to the installation instructions.

That error message is too generic right now, I just implemented password protection and that error will pop up if the connection to Sickbeard fails for any reason. This weekend when I have more time I will add better error handling so failures are clearer about what is actually wrong.
Reply
#26
AdeXB Wrote:Also getting the Check username/password error.

Where do you find/setup the IP?

In the programs menu bring up the context menu while highlighting Sickbeard XBMC ("C" key on the keyboard or hold the menu button on ATV2) and select Add-On Settings.

You can also go to the Settings->Add-Ons menu and find Sickbeard XBMC under Enabled Add Ons and select it. It should have a Configure option when you view it this way.
Reply
#27
I've got that far, sorry I meant what IP do I enter for Sickbeard?

Maniaczm Wrote:In the programs menu bring up the context menu while highlighting Sickbeard XBMC ("C" key on the keyboard or hold the menu button on ATV2) and select Add-On Settings.

You can also go to the Settings->Add-Ons menu and find Sickbeard XBMC under Enabled Add Ons and select it. It should have a Configure option when you view it this way.
Reply
#28
AdeXB Wrote:I've got that far, sorry I meant what IP do I enter for Sickbeard?

Oh I see, you need to enter the IP and Port that Sickbeard is running on. So whatever address you use to access Sickbeard through the web browser is what you would enter into the settings. For example for http://192.168.1.5:8081/home you would enter 192.168.1.5 for the IP and 8081 as the Port.
Reply
#29
Thanks, got it working. Nice!
Reply
#30
ursli Wrote:Ah, that makes sense at the API, thanks for the clarification.

Regarding the show names, it's probably my girlfriends German series using umlauts. (Ä Ö Ü) Can't think of anything else that would be named different then any of the usual shows.

Example:

2012-03-07 CSI: Den Tätern auf der Spur CBS HD 241 / 268 N Continuing

Is that enough or you want some more?

I have updated Sickbeard XBMC to version 1.0.2 and now supports special characters in show names. I tested with your specific show and this build worked with it. Let me know if you have any further troubles with it. Thanks!
Reply
  •  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 14
  • Next 



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Sickbeard XBMC - Control Sickbeard from XBMC3.52