• 1
  • 56
  • 57
  • 58(current)
  • 59
  • 60
  • 192
Release Artist Slideshow addon (with skin and addon integration)
(2014-02-08, 20:58)peppe_sr Wrote: Is someone experiencing random errors on the script while playing music? after a restart of xbmc it works again. last version from github
is difficult for me make a debug log.
Peppe

I don't have this problem. The latest beta version of Artist SlideShow is V.1.5.9.6 and can be downloaded from here:

https://github.com/pkscout/script.artist...master.zip

What version are you currently running? This one?
Reply
Yes 1.5.9.6, i think it arrives when my system wake up from suspended mode.....
Peppe
Reply
I am trying to get Artist Slideshow to show the CD cover of songs being played in the radio.
I have tried with both the TuneIn and Radio addons but I can't get this to work.

https://www.dropbox.com/s/s19hbadg47a29j....46.13.jpg

What it does work is to set the Background Customizer to artistslideshow.

https://www.dropbox.com/s/w7gimrumib4x5p....47.23.jpg

Am I missing something?
Reply
peppe_sr and reg4nt, I'm limited on what I can do to help without a debug log. There's a link in my signature on how to submit those.
Reply
pkscout I am sorry about that. Here you can find my log file: http://xbmclogs.com/show.php?id=128079
Reply
The problem seems to be that ArtistSlideshow fails to read the metadata of the song:
13:46:30 T:1816939648 DEBUG: [Artist Slideshow] No artist names returned from JSON call, assuming this is an internet stream
13:46:30 T:1816939648 DEBUG: [Artist Slideshow] Looking for a musicbrainz ID for artist Radio Paradise
13:46:30 T:1816939648 DEBUG: [Artist Slideshow] Looking for musicbrainz ID in the musicbrainz.nfo file
13:46:30 T:1816939648 DEBUG: [Artist Slideshow] no musicbrainz ID found in musicbrainz.nfo file
13:46:30 T:1816939648 DEBUG: [Artist Slideshow] current artist is Radio Paradise with a mbid of
13:46:30 T:1816939648 DEBUG: [Artist Slideshow] start download

Is there a way to make A.S. to hook up in the TuneIn/Radio playing song info?
Reply
(2014-02-09, 22:16)regr4nt Wrote: The problem seems to be that ArtistSlideshow fails to read the metadata of the song:
13:46:30 T:1816939648 DEBUG: [Artist Slideshow] No artist names returned from JSON call, assuming this is an internet stream
13:46:30 T:1816939648 DEBUG: [Artist Slideshow] Looking for a musicbrainz ID for artist Radio Paradise
13:46:30 T:1816939648 DEBUG: [Artist Slideshow] Looking for musicbrainz ID in the musicbrainz.nfo file
13:46:30 T:1816939648 DEBUG: [Artist Slideshow] no musicbrainz ID found in musicbrainz.nfo file
13:46:30 T:1816939648 DEBUG: [Artist Slideshow] current artist is Radio Paradise with a mbid of
13:46:30 T:1816939648 DEBUG: [Artist Slideshow] start download

Is there a way to make A.S. to hook up in the TuneIn/Radio playing song info?

The log you submitted doesn't seem to have those lines it. The one artist that was played from Radio Paradise was Neko Case, as AS did what it is suppose to do for that artist. If you see lines like above, that most likely means that Radio Paradise has sent the song title and included their name in it. Since they seem to sometimes do that and sometimes send the song title as ARTIST - SONG TITLE, there isn't much I can do to fix that. The internet stream support on AS has always been a little dicey, as there is no standard for how to send information in the stream. Since most stations seem to use ARTIST - SONG TITLE, that's the one AS supports. If a stream provider does something different, or isn't consistent, then AS will work sometimes and sometimes it won't.
Reply
But if you take a look at the screenshots I provided before you can see that the player does show the ARTIST - TITLE pair. And it does this for all songs, afaik. Where is that pair read from?
Reply
Maybe using:
- MusicPlayer.Artist
- MusicPlayer.Title
- MusicPlayer.Album

(http://forum.xbmc.org/showthread.php?tid...pid1623493)
Reply
I need a debug log that shows the actual problem. The one you posted didn't show any issues at all. You played an artist, AS found an artist. Looking at screenshots and snippets of log out of content don't help at all.
Reply
(2014-02-09, 19:13)pkscuot Wrote: peppe_sr and reg4nt, I'm limited on what I can do to help without a debug log. There's a link in my signature on how to submit those.

Thank you,
my problem is random so is really difficult to replicate.
i'm using xbmc with Debug Log on so if it arrives i will be able to post what you need.
Peppe
Reply
(2014-02-09, 23:16)pkscuot Wrote: I need a debug log that shows the actual problem. The one you posted didn't show any issues at all. You played an artist, AS found an artist. Looking at screenshots and snippets of log out of content don't help at all.

Does this help? I set XBMC in Debug mode as indicated in the Wiki.
This is the result:

http://xbmclogs.com/show.php?id=128676
Reply
The wiki (section 3.1) states you should create a custom skin so that when you update xbmc you'll retain the changes necessary for Artist Slideshow to function. However it states to put the custom skin in the userdata folder. I'm pretty sure this is wrong and it should be the xbmc/addons folder! Thought it might be confusing for newbies.
Reply
i cant get it to work in visualiziation, so that when there is no images it shows the visualization. nor can i get to work when i am not in the fullscreen playing mode (so when i start playing music i have to press the fullscreen button on my remote to get it up) and there in fullscreen playing mode i have set artist slideshow as background.
i'm using frodo with aeon nox skin
Reply
(2014-02-10, 18:58)regr4nt Wrote:
(2014-02-09, 23:16)pkscuot Wrote: I need a debug log that shows the actual problem. The one you posted didn't show any issues at all. You played an artist, AS found an artist. Looking at screenshots and snippets of log out of content don't help at all.

Does this help? I set XBMC in Debug mode as indicated in the Wiki.
This is the result:

http://xbmclogs.com/show.php?id=128676

According to that log, the streaming addon is sending information that doesn't include an artist, even in the title field. It looks like it's just sending a generic file name. Streaming support in AS is just barely above experimental, and the solution I have seems to work for most streaming add ons. I'm not in a position to start adding specific support for different streaming add ons. So at this point either AS will be able to interpret the artist name from the stream or it won't.

(2014-02-15, 12:31)VanZan Wrote: The wiki (section 3.1) states you should create a custom skin so that when you update xbmc you'll retain the changes necessary for Artist Slideshow to function. However it states to put the custom skin in the userdata folder. I'm pretty sure this is wrong and it should be the xbmc/addons folder! Thought it might be confusing for newbies.

Mahalo for the feedback. I've updated the wiki pages to try and make things clearer.
Reply
  • 1
  • 56
  • 57
  • 58(current)
  • 59
  • 60
  • 192

Logout Mark Read Team Forum Stats Members Help
Artist Slideshow addon (with skin and addon integration)5
This forum uses Lukasz Tkacz MyBB addons.