• 1
  • 59
  • 60
  • 61(current)
  • 62
  • 63
  • 192
Release Artist Slideshow addon (with skin and addon integration)
(2014-02-20, 08:31)warlion Wrote:
(2014-02-20, 04:51)LEDFan Wrote: I'd like to know is this is hard coded somewhere or if it's possible to change the pictures for the following: Ended, Returning, IMDB ratings etc. I'd like to use my own pictures (in french) but I don't know how to do that or where to start from. Could somebody guide me a little bit?

Image

That's actually meant for TV show next aired script but you fomd that on media/tvguide on your Aeon nox skin

Oups yes sorry I posted this in the wrong topic.
Reply
1.6.2 Pushed to Main Repo

I have put in a request to the XBMC team to update Artist Slideshow to 1.6.2. This should resolve the crash issue folks saw with 1.6.0 and 1.6.1. Hopefully this will start being available later today. If you aren't seeing the update by tomorrow, I'd try forcing a refresh of the main XMBC repo.

My apologies that I so thoroughly messed up these last couple updates. My test systems ended up with a strange version of a python module, so things that looked like their were working really weren't. I think I have everything resolved now, so next time I can have a different problem. '-)
Reply
I get some results with 1.6.2 but look at the picture. Why do I get this on many many artists? My tags are OK so I don't understand.
Image
Reply
Hi guys, really sorry to ask some help but i'm going mad...
I try for 2 days to make this addon work but I can't
I promise I did a lot of search but I really don't understand.

Config:
Windows 7 SP1
XBMC 13.0 Alpha11
Aeon NOX 4.1.9 Gotham

My mp3 tags are ok, I did clean/update library many times, and still get "script failed" and empty boxes:

Image

Image

(Yes I can view a background in Biography box !!!!)

here's my last log: http://xbmclogs.com/show.php?id=135020

please help :'(

Ben
Reply
Please try all settungs like here...

and if it doesen't work, try Artist Slideshow 1.5.9 works as best for me...
Board: B85M-ITX
CPU: i3 4330
GPU: Geforce GTX 750ti
Reply
1.6.0 and 1.6.1 are broken. That's totally my fault. 1.6.2 will fix everything, and I'm hoping it will make it into the repo soon. The XBMC devs ask developers not to do updates more than once a month, and because I did a bad job testing I've had to do three updates this week. So I won't be surprised if it takes a little longer for them to get to the last update.

If you're really desperate, you can download the beta listed a few posts up. Otherwise this should all resolve itself in the next day or so. Again,my apologies.
Reply
(2014-02-21, 08:41)pkscuot Wrote: 1.6.0 and 1.6.1 are broken. That's totally my fault. 1.6.2 will fix everything, and I'm hoping it will make it into the repo soon. The XBMC devs ask developers not to do updates more than once a month, and because I did a bad job testing I've had to do three updates this week. So I won't be surprised if it takes a little longer for them to get to the last update.

If you're really desperate, you can download the beta listed a few posts up. Otherwise this should all resolve itself in the next day or so. Again,my apologies.

Hi,
Just want to say thank you for the add-on and quick fix to the issue :-)
Reply
I just got home, turned on XBMC and got the "Artist Slideshow Updated" message on my screen. Checked the info, and it's pulled in 1.6.2 already! Slideshow appears to be working just fine (XBMC Gotham Alpha 11, Aeon Nox 4)
Reply
Before updating to 1.6.2 the vizualiazation fanart was truly stuck on an artist from a few days ago, even after a reboot. Deleting the add-on folder (not the data folder) and replacing with 1.6.2 fixed it (at least for now). I recall this happeneing some weeks ago, where a manual update reset things back to normal. Obviously I'll post any future issues. Thanks for the update.
Win10x64 Pro. Intel Core2Duo E8500 3.26GHz on Gigabyte GA-EP43-UD3L. 4GB DDR2 1066MHz RAM. Nvidia GT240 512MB PCIx16. Multiple displays, including Sony VPL-XW5000ES 4k projector + 100" Da-Lite Cinema screen.
Reply
Luv u guys !!
Image

Still have to adjust some litlle things but it works fine !!

I love this Smile
One more time thank you for all this amazing good job !
Reply
Hi,
I was working on a fresh install of my htpc when you pushed the "broken" versions, so i reinstall my system quite a few times these last days, and found this thread.
Here is my feedback if it can help :

Everything works fine with 1.6.2 on an XBMCbuntu fresh install.
But still getting the 'error script failed' on a fresh install of OpenELEC (Frodo 12.2).

Is there still something to be fixed on a future 1.6.3 to work with OpenELEC ? If not i'll try to get a previous working version of artist slideshow.

Thanks.
Reply
I love this add on, but having some small problems. From version 1.6.0 onwards, they work but are for me, slow and it's hit or miss if it finds the artist. So I've reverted back back to version 1.5.9 and it works absolutely great. One question, everytime you check the information of an artist, does it go back to Last.FM or does it recover the information locally, because it has downloaded that information before. If it's the latter, where is this stored. The reason I ask is, I have an artist it didn't fine originally and now it seems stuck that it won't look for that artist. I know that the artist is there, because my other PC found them.

Any help would be appreciated.
Reply
(2014-02-22, 21:57)nayxorg Wrote: Everything works fine with 1.6.2 on an XBMCbuntu fresh install.
But still getting the 'error script failed' on a fresh install of OpenELEC (Frodo 12.2).

Is there still something to be fixed on a future 1.6.3 to work with OpenELEC ? If not i'll try to get a previous working version of artist slideshow.

In theory everything should be working on all platforms, but I don't have an OpenELEC machine with which I an test. Could you post a debug log?

(2014-02-23, 02:16)bolter Wrote: I love this add on, but having some small problems. From version 1.6.0 onwards, they work but are for me, slow and it's hit or miss if it finds the artist. So I've reverted back back to version 1.5.9 and it works absolutely great. One question, everytime you check the information of an artist, does it go back to Last.FM or does it recover the information locally, because it has downloaded that information before. If it's the latter, where is this stored. The reason I ask is, I have an artist it didn't fine originally and now it seems stuck that it won't look for that artist. I know that the artist is there, because my other PC found them.

There was no change in the logic for finding an artist from 1.5.9 to the current 1.6.2. If you are only using Last.FM you should enable another source, as Last.FM has continued to close down Thierry public API to the point that they are basically completely useless. The only thing Last.FM is used for now is the similar artists and as a fallback for the artist bio in case one can't be found on the audiodb.com.

All the artists' data is stored in the XBMC userdata folder in script.artistslideshow/ArtistInformation. AS will recheck artists' info once every two weeks. If you delete the directory for a particular artist, that will force a refresh. The folders are all hashes of the artists' names, so you might want to download Artist Slideshow Helper, as that will generate a text file for you that maps an hash name to an artist name.
Reply
(2014-02-23, 03:05)pkscuot Wrote:
(2014-02-22, 21:57)nayxorg Wrote: Everything works fine with 1.6.2 on an XBMCbuntu fresh install.
But still getting the 'error script failed' on a fresh install of OpenELEC (Frodo 12.2).

Is there still something to be fixed on a future 1.6.3 to work with OpenELEC ? If not i'll try to get a previous working version of artist slideshow.

In theory everything should be working on all platforms, but I don't have an OpenELEC machine with which I an test. Could you post a debug log?

(2014-02-23, 02:16)bolter Wrote: I love this add on, but having some small problems. From version 1.6.0 onwards, they work but are for me, slow and it's hit or miss if it finds the artist. So I've reverted back back to version 1.5.9 and it works absolutely great. One question, everytime you check the information of an artist, does it go back to Last.FM or does it recover the information locally, because it has downloaded that information before. If it's the latter, where is this stored. The reason I ask is, I have an artist it didn't fine originally and now it seems stuck that it won't look for that artist. I know that the artist is there, because my other PC found them.

There was no change in the logic for finding an artist from 1.5.9 to the current 1.6.2. If you are only using Last.FM you should enable another source, as Last.FM has continued to close down Thierry public API to the point that they are basically completely useless. The only thing Last.FM is used for now is the similar artists and as a fallback for the artist bio in case one can't be found on the audiodb.com.

All the artists' data is stored in the XBMC userdata folder in script.artistslideshow/ArtistInformation. AS will recheck artists' info once every two weeks. If you delete the directory for a particular artist, that will force a refresh. The folders are all hashes of the artists' names, so you might want to download Artist Slideshow Helper, as that will generate a text file for you that maps an hash name to an artist name.

Thanks for the advice pkscuot, I tried your Artist Slideshow helper but all it created was an empty txt file. All should have done was set a destination path for the txt file in the settings right?
I was able to go through the directories manually (lucky for me it was near the top) and now it's sorted.

Edit: I've got version 1.6.2 now going thanks, but would like to use you slideshow helper add on as I have to fix up a couple of artist that I stuffed up before I had the settings correct. As I stated above, I used the add on and it just gave me a empty txt file. I am using windows 7 and the latest Gotham nightly.
Reply
Apparently I spoke too soon as well... The script will display artwork for a few artists, then randomly stop updating and just keep looping artwork for the last artist it found. Last night it hung on Paul Simon, tonight I don't know exactly when it stopped working, but it's been showing a black screen for the last two artists (on Party Mode - Garth Brooks, and Matchbox 20.) Both of whom I not only have seen artwork for, but definitely have artwork in the local cache (both Artist Slideshow cache and XBMC cache - don't get me started on that!) Guess I should enable debug logging so I can help with the solution instead of just being obnoxious.
Reply
  • 1
  • 59
  • 60
  • 61(current)
  • 62
  • 63
  • 192

Logout Mark Read Team Forum Stats Members Help
Artist Slideshow addon (with skin and addon integration)5
This forum uses Lukasz Tkacz MyBB addons.