Thread Rating:
  • 0 Vote(s) - 0 Average
XBMCbuntu install keeps failing to install GRUB bootloader
#1
Well I've tried two times now with same results. Ever time I hit the end of the install it says "Failed to install bootloader.. Fatal Error has occured" (something like that) First i tried with partitioning the whole drive as /. Second time I partitioning a /boot too. both as EXT4 and No Swap space. I dont want to go crazy if is a broken release causing it as it is the eden beta3 release, but i dont see any posts of people with same issues.

Specs:

Newest Mac Mini
4gb Kingston USB Stick
XBMCbuntu Eden Beta 3

I found other people with same problem online (for other versions of linux), but none with a solution! installing linux is not as smooth as one would hope compared to OSX.

anyone else having this issue?
Reply
#2
I had similar problem but in my case install procedure just stopped.
After reboot I tried to install once more but this time I used just created existing partitions but I reinstalled boot/system partition as ext2 and manually assign it as root "/" - then I was able to go to the end.
My pen Patriot Rage
Reply
#3
when you say you used existing partitions, do you mean the ones from the previous install or did you format your drive prior to install?

I am setting root manually, however on my other linux install i did have to format the drives to fat (mac doesn't have ext2-4) on OSX which seemed to make it work for ubuntu 11.10 (that was a nightmare to get it working on OSX as a noob).
Reply
#4
yes - as existing partition I mean this ones created from previous install (EDEN RC3 boot CD)
Reply
#5
Are you sure the installer is trying to install grub to the right drive? I've noticed the Ubuntu installer gets it wrong a lot, especially if you have multiple drives. Take note of the installation drive name when partitioning (it'll be something like /dev/sdX) and when installing grub choose to select the location manually and enter the drive name from the partitioning menu.
Reply
#6
That was my first issue when i was trying to install linux the first time last week. was installing it on my mac hd vs external. I actually got it working finally by adding swap space.

was trying to avoid it because the usb is small, takes like 1/4 of the drive, and i read that it wasn't needed. but the warning kept saying it might not install. so I tried it and it worked..

Works good now, just initial boot is pretty long.
Reply
#7
I have some problem, but in my case, i can't install bootloader if connected to internet, while go smoothly if no internet connected. OMG, why?
Reply
#8
(If you use usb flash disk for install)

i have had similar problem with installing ubuntu desktop, ubuntu server and xbmc live. My problem was that the usb flash stick i did use was not proper formated before i used unetbootin to write the image to the flash disk. every time the grub installer failed. and it did give the wronge install dir some times. did not help change it to right dir /dev/sda.

it can be youre usb flash disk. not all flash disk do work for installing linux. if you got other flash disk try one
i am not sure what ubuntu version xbmclive use but on Natty there is problem.
ref: https://help.ubuntu.com/community/Instal...omUSBStick
Natty Narwhal 11.04 is having issues with USB flash drives from SanDisk that have U3 Launchpad. You can either use another brand or use either u3-tool from Ubuntu Repositories or SanDisk's U3 Launchpad Removal Tool to remove U3."
Reply
#9
There seem to be more problems with GRUB.

With me the installer always installs GRUB on the usb-stick.
So maybe its trying to do the same but failing in your case.
For some reason the installers mount the usb as /dev/sda1 or /dev/sda.

If you can try using a CD or another usb-stick.
And if you run into the same problem as i do reinstall GRUB on the right disk after first boot.



-Unetbootin
-Ubuntu minimal
-Emtec 4GB usb-stick
Reply



Logout Mark Read Team Forum Stats Members Help
XBMCbuntu install keeps failing to install GRUB bootloader00