Thread Rating:
  • 0 Vote(s) - 0 Average
FPS/HZ Smoothness
#16
Ok cool. At least that's not really a problem then.

I'm using HDMI and SPDIF. My "AV" (not really) receiver is a logitech z5500 and they don't have HDMI. So HDMI for video and Optical toslink for audio. I originally had only the HDMI coming out of the HTPC but when the TV passed through the audio to the receiver, it wouldn't work for DTS. I think this is some kind of DRM copy protection thing. So now I have vid (HDMI) from PC to TV and audio (optical) straight from PC to Z5500.

Thanks for all the responses by the way.
Reply
#17
I Spoke to soon. The sync problem is still there. The delay feature on my speakers is only for the rear speakers. It's Not really for sync issues. I might need to look at the advanced settings but I'm not sure how many ms I'd want to adjust by. It's a very small delay.

I also noticed some visual issues with scenes experiencing sort of jumps. This Is still better than it was overall so I'll just have to keep trying small tweaks.
Reply
#18
LOL! So just to let you know I'm going round in circles. I'm now back to Windows being at 60HZ but now I'm going to use the "adjust refresh rate" setting as it does generally seem to make stuff smoother. I had a vid that wasn't smooth whether or not "adjust refresh rate" was enable or not at 50HZ-Windows. Changed to 60HZ-Windows and it's smooth now!

So I guess instead of wasting all this time I should have just enabled the "adjust refresh rate" setting orginally.
Reply
#19
LOL. I know the round and round in circles drill.
Read this before using these builds.
Changelog
Reply
#20
So now... 24p stuff is sucking. The TV switches to the correct mode, but the video isn't great, it's ok most of the time but I think it drops frames every now and then (like 5mins) and the audio sync changes. Like if I adjust say -100ms, it's ok for 5mins but then changes for a few mins then goes ok again.

I guess I just need to keep testing stuff.

What's funny is the "adjust refresh rate" setting seems to have sorted a lot of the smoothness out on 25/30fps videos but 24p vids aren't great now. The TV definitely supports them and changes and comes up with a 24p logo. It's liek the hardware struggles.

I'm gonna go back to 50 HZ on windows and compare the same videos.
Reply
#21
Have you gone thru the Nvidia drivers with a fine tooth comb to make sure there isn't some setting in there that could be causing the issue?
Read this before using these builds.
Changelog
Reply
#22
I only see the Nvidia control panel which gives very basic options. I'v never changed anything. Any ideas if i should be looking for something in particular?

ATM. 50HZ Windows, everything but 24p seems fine. 24p is out of sync, dropping frames etc. And the audio sync seems to be different for different files, so setting a delay for all wouldn't work I don't think.
Reply
#23
You can set delays separately for each refresh rate. I think you need to look into the advanced settings file and try to set the refresh rate for 24p as well as it's sync properties. Look back thru the links I posted earlier for how to do this.
Read this before using these builds.
Changelog
Reply
#24
What I meant was different 24p videos need different delays. Not all 24p videos are delayed by the same amount and throughout the video it seems to change. Also I'm getting clear frame drops on the OSD.

Other refresh rates don't have any sync issues that iv noticed so far.
Reply
#25
Then maybe you just need to get the refresh rate corrected. Look at those advanced settings for that.

Also look at the <fpsdetect>1</fpsdetect> setting. Look at this thread for some info on that.
Read this before using these builds.
Changelog
Reply
#26
Thanks. I'm a total noob with the advanced setting stuff. Scared to touch it. lol... But I guess I'll need to familiarise myself with them as I'v pretty much exhausted all the basic settings.

I did read somewhere about there being a bug with Nvidia displaying 24HZ.
Reply
#27
It isn't hard to do, just hard to understand Wink

If it doesn't work you can just pitch the advancedsetting.xml file and you are back to where you were.
Read this before using these builds.
Changelog
Reply
#28
What do u know about reclock?

Could it be a solution?
http://www.homecinema-hd.com/reclock_en.html

And if im going to say put a delay of 300ms (to the left in the XBMC offset option) on 24p content only.

How should it look? From this sample one.

Code:
<advancedsettings>
  <video>

    <!-- Compensate display latency (video lag). Latency is given in msecs. -->
    <latency>

      <!-- Global default display latency -->
      <delay>0</delay>

      <!--
        Override latency for given display (not video) refresh rates.
        When XBMC is in windowed mode, override is ignored. Multiple
        overrides are allowed.

        Syntax of an override entry:
          <refresh>
            <min>, <max> refresh rate range, OR
            <rate> exact refresh rate
            <delay> display latency for the given refresh rate
          </refresh>
       -->

      <!-- Example: display has 125 msec latency at 23-24 Hz -->
      <refresh>
        <min>23</min>
        <max>24</max>
        <delay>125</delay>
      </refresh>

      <!-- Example: display has 50 msec latency at 50 (+/-0.01) Hz -->
      <refresh>
        <rate>50</rate>
        <delay>50</delay>
      </refresh>

    </latency>

  </video>
</advancedsettings>

_________________________________________

I already have this in my advanced settings


Code:
<?xml version="1.0"?>
<advancedsettings>
    <videoscanner>
        <ignoreerrors>true</ignoreerrors>
    </videoscanner>
</advancedsettings>
Reply
#29
I've never used reclock personally, so I can not comment on that. I'll try to look at the other stuff later today when i get time.
Read this before using these builds.
Changelog
Reply
#30
Thanks for fixing my layout of those. And no problem. Take your time, you've been very helpful.
Reply



FPS/HZ Smoothness00