•   
  • 1
  • 22
  • 23
  • 24(current)
  • 25
  • 26
  • 68
  •   
[WIP] HTPC-Manager Beta, Manage XBMC, Sabnzbd, SickBeard with one app
Hi HTPC-Manager is not working for me.

I cant see any pictures (movies, series and music) can is be it is not working because i make use of a separate mysql datebase? I have 2 raspbarry pi's (with raspbmc) and one shared mysql database on a seperated Ubuntu server (here i also installed HTPC-Manager)

Or is it something else?

Hope you can help me

Riddertommie
Reply
(2013-06-20, 22:27)sumnerboy Wrote:
(2013-06-20, 12:35)mbw2001 Wrote: Try deleting the log in userdata/htpcmanager.log

Then run the program as "python Htpc.py --debug --loglevel DEBUG" and paste the logfile from above.

Here is the debug log as requested. I can't see anything obviously going wrong in there.

http://pastebin.com/7KjZFp52

No appearent errors. Weird...

Try accessing the /xbmc/GetMovies page. Can you see your movies there?

And what about the XBMC webinterface? Can you see your movies there?

(2013-06-21, 15:59)riddertommie Wrote: Hi HTPC-Manager is not working for me.

I cant see any pictures (movies, series and music) can is be it is not working because i make use of a separate mysql datebase? I have 2 raspbarry pi's (with raspbmc) and one shared mysql database on a seperated Ubuntu server (here i also installed HTPC-Manager)

Or is it something else?

Hope you can help me

Riddertommie

I use MySQL aswell, so that isn't the problem. Try reading my post above and link the log.
Reply
(2013-06-20, 05:35)sumnerboy Wrote:
(2013-06-14, 20:12)HenryFord Wrote:
(2013-06-14, 02:26)sumnerboy Wrote: Am I missing something? Raspbmc is currently using XBMC 12.2 I believe. Is this too 'new' for HTPC Manager?
Works fine over here... Undecided
I'm currently in the process to add some logging to the program, troubleshooting would surely get a lot easier then Wink


As I said, TV is showing up perfectly, but I have yet to see a list of movies. I am updating to the latest HTPC Manager version every day in the hope it will be fixed one day soon!

Same problem for me...
TV shows are showing up perfectly but unfortunately no movies. However, in the dashboard at "latest movies" they are showing up - at least 5 of them.

@mbw2011
At /xbmc/GetMovies there are all movies listed.
Reply
(2013-06-21, 17:10)mbw2001 Wrote: No appearent errors. Weird...

Try accessing the /xbmc/GetMovies page. Can you see your movies there?

And what about the XBMC webinterface? Can you see your movies there?

Hey - thanks for the help here mate. I just tried /xbmc/GetMovies on my HTPC Manager URL and it returned a full list of movies. I also checked the XBMC web interface and it successfully returned all my movies.

I can only presume there is a lack of debug logging in this early version of the software as the interface is reporting an 'Error connecting to XBMC' red popup in the lower right corner of the screen when I try and view movies. The popup shows after a couple of seconds when navigating to the movie screen. So it is almost like it is timing out or something?

Will keep trying latest versions and report back here if I have any success.
Reply
Edit: Fixed my own foolish issue.
Reply
(2013-06-21, 23:51)sumnerboy Wrote:
(2013-06-21, 17:10)mbw2001 Wrote: No appearent errors. Weird...

Try accessing the /xbmc/GetMovies page. Can you see your movies there?

And what about the XBMC webinterface? Can you see your movies there?

Hey - thanks for the help here mate. I just tried /xbmc/GetMovies on my HTPC Manager URL and it returned a full list of movies. I also checked the XBMC web interface and it successfully returned all my movies.

I can only presume there is a lack of debug logging in this early version of the software as the interface is reporting an 'Error connecting to XBMC' red popup in the lower right corner of the screen when I try and view movies. The popup shows after a couple of seconds when navigating to the movie screen. So it is almost like it is timing out or something?

Will keep trying latest versions and report back here if I have any success.

I had this same issue ... I fixed it, at least on my box, by adding a 10 second ajax call timeout to the loadMovies function in /interfaces/defaults/js/functions/functions.xbmc.js :

movieRequest = $.ajax({
url: WEBDIR + 'xbmc/GetMovies',
type: 'get',
data: sendData,
dataType: 'json',
timeout: 10000,
success: function (data) { ...


Hope this helps.
Reply
Nice one odb2013 - that has done the trick! So it was just timing out waiting for all the movie information to come back? Good work for figuring that one out!!
Reply
(2013-06-22, 05:46)odb2013 Wrote:
(2013-06-21, 23:51)sumnerboy Wrote:
(2013-06-21, 17:10)mbw2001 Wrote: No appearent errors. Weird...

Try accessing the /xbmc/GetMovies page. Can you see your movies there?

And what about the XBMC webinterface? Can you see your movies there?

Hey - thanks for the help here mate. I just tried /xbmc/GetMovies on my HTPC Manager URL and it returned a full list of movies. I also checked the XBMC web interface and it successfully returned all my movies.

I can only presume there is a lack of debug logging in this early version of the software as the interface is reporting an 'Error connecting to XBMC' red popup in the lower right corner of the screen when I try and view movies. The popup shows after a couple of seconds when navigating to the movie screen. So it is almost like it is timing out or something?

Will keep trying latest versions and report back here if I have any success.

I had this same issue ... I fixed it, at least on my box, by adding a 10 second ajax call timeout to the loadMovies function in /interfaces/defaults/js/functions/functions.xbmc.js :

movieRequest = $.ajax({
url: WEBDIR + 'xbmc/GetMovies',
type: 'get',
data: sendData,
dataType: 'json',
timeout: 10000,
success: function (data) { ...


Hope this helps.

GJ fixing the problem. I'm a bit hessitant with just increasing the timeout in the repo though. I would rather look into increasing the speed somehow.
Reply
Not sure if increasing the speed of this function is in the scope of the application though. The delay appears to be coming from the XBMC server processing the api request. For a user who has a large smb library and say, a 1st gen Pi as their XBMC server, api calls could take upwards of 15 seconds for the hardware to process depending upon the request. The only thing coming to mind at the moment is to lower the pagination limits for the GetMovies call and/or offer the user a progress report on the query, whether it be a bar, number of titles loaded, etc.
Reply
(2013-06-22, 16:38)odb2013 Wrote: Not sure if increasing the speed of this function is in the scope of the application though. The delay appears to be coming from the XBMC server processing the api request. For a user who has a large smb library and say, a 1st gen Pi as their XBMC server, api calls could take upwards of 15 seconds for the hardware to process depending upon the request. The only thing coming to mind at the moment is to lower the pagination limits for the GetMovies call and/or offer the user a progress report on the query, whether it be a bar, number of titles loaded, etc.

As of now, the movie limit has been set to 50 movies instead of 100.
Reply
(2012-03-27, 22:46)Aenima99x Wrote: Love it so far, great work! Have it running on Ubuntu 12.04 no problems.

Also, if anyone needs it, I took the Init script I had been using for Maraschino and modified it for HTPC-Manager.
Get it here and save it as HTPC-Manager in /etc/init.d

Then just run the following -
sudo chmod a+x /etc/init.d/HTPC-Manager
sudo update-rc.d HTPC-Manager defaults

I get after doing this
"missing LSB information"

And portnumber is 8084/8085? because its not working for me
Reply
(2013-06-23, 14:26)RiChaDo Wrote:
(2012-03-27, 22:46)Aenima99x Wrote: Love it so far, great work! Have it running on Ubuntu 12.04 no problems.

Also, if anyone needs it, I took the Init script I had been using for Maraschino and modified it for HTPC-Manager.
Get it here and save it as HTPC-Manager in /etc/init.d

Then just run the following -
sudo chmod a+x /etc/init.d/HTPC-Manager
sudo update-rc.d HTPC-Manager defaults

I get after doing this
"missing LSB information"

And portnumber is 8084/8085? because its not working for me

There is a bundles initd script named initd when you download the program. Remember to edit the path in the script.
Reply
I got it working

I did:

python /home/xbmc/.htpc-manager/htpc.py
Reply
Currently trying to mash up some sort of headphones support, it'll probably take a while but I've already learned so much from doing this Smile
Reply
(2013-06-24, 02:27)Username2045 Wrote: Currently trying to mash up some sort of headphones support, it'll probably take a while but I've already learned so much from doing this Smile

Good to hear! Any code-samples we can check?

Find us on irc and maybe we can help you. #htpc-manager on freenode.net
Reply
  •   
  • 1
  • 22
  • 23
  • 24(current)
  • 25
  • 26
  • 68
  •   
 
Thread Rating:
  • 7 Vote(s) - 4.71 Average



Logout Mark Read Team Forum Stats Members Help
[WIP] HTPC-Manager Beta, Manage XBMC, Sabnzbd, SickBeard with one app4.717