Win -  Xbox 360 Controller won't work after it was idle
Windows 7 64 bit

No Shell / Auto Loads
I use xpadder too ( for some stuff in advanced launcher) and "emerge" as a shell...but I still can not explain why rc 2 works and eden don't...for now I'm under rc2 so I have no more log to post...but I already posts 2 with no conclusion...I know I got some problem with ati drivers but now everything work fine in rc 2..maybe they have something to do with this problem but it seems odd...
well,no clues...
I upload rc 2...

(2012-04-14, 20:24)bakito Wrote: I upload rc 2...


Thanks,. still crashing when i back from a game, using wii emulator sometimes when i load bluesoleil to connect wiimote, back to xbmc crash,...
Same happens whean i load a game. Always using advanced laucher and xbmc as shell

for the WII emulation I use a script that close xbmc then restart it when emulation done...maybe try that, you can find these script in advanced launcher thread.
I am using Xpadder too. Crashes appear at on/off switching of XBOX360 Controller. XBMC crashes too if i disconnect my Logitech G700 from USB cable (then using in wireless mode).
All Betas and RCs worked flawlessly but final is quite unusable for me, because of this bug.
I notice that in my log...

19:37:47 T:3356 ERROR: CRemoteControl::Connect - failed to connect
19:37:47 T:3356 INFO: CRemoteControl:Tonguerocess - failed to connect to irss, will keep retrying every 5 seconds

maybe it has something to do with this usb/controller problem??
nah. it just tells that we can't connect to the irss daemon which is okay (probably need to set another log level there)
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
i dont now if this have anything to do with this problem but after the creation of advancedsettings.xml the crashes stop for me...
You should give this a try...
I'm having the exact same problem. Mine will only crash if a video is not playing. If I boot up xbmc and use the 360 controller to navigate, it works great and then I leave the controller to idle (takes about 10 mins or so), when it idles at that point XBMC crashes. If I'm playing a video, when the controller idles it does not crash. but upon waking the controller it does not respond. weird
I've noticed a couple more things about the crash issue.

1) XBMC only crashes after it is activated. If, for example, you have another window open and XMBC in the background (in windowed mode) when the controller disconnects, you can actually still see XBMC react to your mouse in the background after the disconnect. It's only when you then reactivate XBMC that XBMC crashes.

2) The crash also occurs when connecting the controller, but only for the first time connecting the controller after startup. If you disconnect and then reconnect without restarting the computer, the reconnect will be handled without crash.

I'll go ahead and update my original post with these findings as well.
XBMC doesn't crash for me just the controller will not respond after going to sleep. I have to alt tab out of media center close xapper and xbmc center then restart xpadder and then the keys work again. Looks like the keys get unbound some how with xapadder
I'm having exact the same problem using the keymap.xml for the wireless Xbox 360 controller.
While watching a movie the controller goes to sleep and XBMC crashes in the same moment or while trying to alt+tab it.
The problem appears only with the final version of Eden. Betas and RCs worked fine.

I'll try to post some logfile from the crash, later this week.
Since this thread is getting long and it was originally about the XBMC controller not working after it goes idle, I'm going to move my discussion of the crash on controller disconnect issue to this thread:
So I'm not alone! This was driving me nuts to the point where I went and bought a new remote. I love using the wireless 360 controller with XBMC, but ever since I installed the Eden final there's no way to get the controller to communicate with XBMC after it goes idle. I really hope someone addresses this because I really don't want to go back to Dharma Sad

Windows 7 Ultimate x64 on a Zotac Mag with an official 360 wireless controller and receiver. XBMC w/ Eden final.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Xbox 360 Controller won't work after it was idle00