Thread Rating:
  • 0 Vote(s) - 0 Average
Windows - Block screensaver
#1
Hello!

Since Eden and Aeon Nox 2.0 when i'm playing music the screensaver is not blocked.
I have set XBMC to dim after 5 minutes and turn of the screen after 20.
This did not happen before.
When the screen turns of the music also stops playing.

This might be a duplicate of http://forum.xbmc.org/showthread.php?tid=125527 but he/she was not getting any response. I hope somebody can tell me if this is broken for just me or for everybody.

Thanks!

ps. i updated to the git version, 3.0 branch. the problem still exists.
Reply
#2
This doesn't sound like a skin issue. Can you reproduce the problem with Confluence? If so it's a XBMC bug.
Reply
#3
The exact same occured to me 30 minutes ago and i indeed have the same problem with confluence...
searched the internet but i cant find anything.

sorry that i posted this here. know what i should do next to fix this?

thanks for the quick response.
Reply
#4
Are you using the screens speakers to listen to music?
Reply
#5
(2012-03-26, 23:12)Hitcher Wrote: Are you using the screens speakers to listen to music?
no, i got speakers hooked up to my receiver. xbmc is setup to use those.
Reply
#6
(2012-03-26, 23:19)Guuz Wrote:
(2012-03-26, 23:12)Hitcher Wrote: Are you using the screens speakers to listen to music?
no, i got speakers hooked up to my receiver. xbmc is setup to use those.

so only the monitor switches off? a better explanation would help.
perhaps your computer goes into standby Big Grin
Donate: https://kodi.tv/contribute/donate (foundation), 146Gr48FqHM7TPB9q33HHv6uWpgQqdz1yk (BTC personal)
Estuary: Kodis new default skin - ExtendedInfo Script - KodiDevKit
Reply
#7
First of; thanks for helping me!

ill try to explain better.

I set the screensaver to "dim" after 5 min.
I set the power saving to "display to sleep" after 20 minutes.

This all works as expected say in the case i forget my XBMC so it doesnt burn in the screen or cost to much energy.

But when i play music (and am in the music playing screen, tab, where you see the song information and fanart) it should prevent this.

Also when it puts the display to sleep the audio stops...
Reply
#8
(2012-03-26, 23:39)Guuz Wrote: First of; thanks for helping me!

ill try to explain better.

I set the screensaver to "dim" after 5 min.
I set the power saving to "display to sleep" after 20 minutes.

This all works as expected say in the case i forget my XBMC so it doesnt burn in the screen or cost to much energy.

But when i play music (and am in the music playing screen, tab, where you see the song information and fanart) it should prevent this.

Also when it puts the display to sleep the audio stops...

what about the option to switch to visualisation when activating screensaver? debug log could also help.
Donate: https://kodi.tv/contribute/donate (foundation), 146Gr48FqHM7TPB9q33HHv6uWpgQqdz1yk (BTC personal)
Estuary: Kodis new default skin - ExtendedInfo Script - KodiDevKit
Reply
#9
that option seems to have no effect...

I got this from the debug log:

(removed unrelated stuff before and after. i started xbmc, played an album, waited 1 minute, saw the screen dim, then pressed S and shutdown xbmc)

Code:
20:15:17 T:1564   DEBUG: ### search url: http://services.tvrage.com/tools/quickinfo.php?show=Falling+Skies
20:15:20 T:2368   DEBUG: CAnnouncementManager - Announcement: OnScreensaverActivated from xbmc
20:15:20 T:2368   DEBUG: GOT ANNOUNCEMENT, type: 2, from xbmc, message OnScreensaverActivated
20:15:20 T:2368   DEBUG: ------ Window Init () ------
20:15:25 T:2368   DEBUG: SDLKeyboard: scancode: 1f, sym: 0073, unicode: 0073, modifier: 0
20:15:25 T:2368   DEBUG: CAnnouncementManager - Announcement: OnScreensaverDeactivated from xbmc
20:15:25 T:2368   DEBUG: GOT ANNOUNCEMENT, type: 2, from xbmc, message OnScreensaverDeactivated
20:15:25 T:2368   DEBUG: CApplication::OnKey: s (f053) pressed, screen saver/dpms woken up
20:15:26 T:2368   DEBUG: SDLKeyboard: scancode: 1f, sym: 0073, unicode: 0073, modifier: 0
20:15:26 T:2368   DEBUG: CApplication::OnKey: s (f053) pressed, action is ActivateWindow(shutdownmenu)
20:15:26 T:2368   DEBUG: Activating window ID: 10111
20:15:26 T:2368   DEBUG: ------ Window Init (DialogButtonMenu.xml) ------
Reply
#10
Why did you shutdown XBMC?
Reply
#11
(2012-03-28, 11:52)Hitcher Wrote: Why did you shutdown XBMC?

To get to my log file and the forum to post this. Also i wanted the logfile to be as short as posible so i did not have to look through thousands of lines of logging ;-)
Reply
#12
But you really need to post a full debug log up to the point the screen gets switched off.

Use http://pastebin.com/
Reply
#13
(2012-03-28, 13:40)Hitcher Wrote: But you really need to post a full debug log up to the point the screen gets switched off.

Use http://pastebin.com/

Will do! But i can't untill i get home. Thanks!
Reply
#14
(2012-03-28, 13:40)Hitcher Wrote: But you really need to post a full debug log up to the point the screen gets switched off.

Use http://pastebin.com/

here it is! :-)

http://pastebin.com/2hiBaqGr
Reply
#15
I've got the same problem, running the latest XBMC from Debian unstable repositories. Any updates on this?
Reply



Block screensaver00