Thread Rating:
  • 0 Vote(s) - 0 Average
Linux - Suspend Resume TBS 6922 issues
#1
Hey all,

I am on xbmcbuntu with the latest p-8 update. I am having issues getting the tbs 6922 to resume. I have tried a few script for unloading loading modules with no luck yet. I can unload vdr and then the modules but when it resumes and reloads the modules and starts vdr - XVDR goes into a loop saying connection restored and I have to manually start and stop pvr then the error goes away but still no live tv. a reboot fixes all.

If I check lsmod before and after resume all the modules remain the same. I tried this script and it causes suspend to stop working at all. named it 75_dvb in sleep.d this is from the tbs forums.

#!/bin/sh
echo "Hibernate/Suspend DVB Modules script : $1"

case $1 in
hibernate|suspend)
modprobe -v -r saa716x_tbs_dvb saa716x_core dvb_core tbsfe tbs6928fe
;;
resume|thaw)
modprobe -v saa716x_tbs_dvb
;;
*)
echo "Hibernate/Suspend DVB Modules script : wrong argument!"
;;
esac


Thanks,

D.
Reply
#2
Without checking the script properly that does say 6928 rather than 6922. Could be one of the issues.
Reply
#3
Rather than do what you're doing there - remove that file and instead add a simple (doesn't need to be executable) file in /etc/pm/config.d/ called for example; modules. To that file add the following line:

SUSPEND_MODULES="saa716x_tbs_dvb"

and see if that works. This is what I do with my qbox3 - although when using tvheadend I still need a similar shell script as you have to first stop tvheadend else the modules cannot be suspended.
Reply
#4
THX for the suggestions. The issues still persist. I can unload ALL the related tbs modules and list tbs6922fe last on the list and I still get a FATAL tbs6922fe is in use and this is after vdr is stopped. The other issue that seems to be pressing is xvdr, when the system wakes up, xvdr says it re-connects but then just loops on the bottom right of the desktop with connected, lost connection, connected, lost connection etc, and does that until I turn the pvr off and on again in xbmc settings, but still no channels after a resume if I look at dmesg the frontend has completely reloaded with no issues. It also take nearly 30 seconds to fully suspend for some reason.

rgds,

D.
Reply
#5
(2012-03-29, 13:12)rodercot Wrote: xvdr says it re-connects but then just loops on the bottom right of the desktop with connected, lost connection, connected, lost connection etc

This seems to be an issue with xvdr rather than your system. If I restart my VDR backend this happens to me. I have to restart XBMC to fix it. I should raise a ticket about it with the xvdr dev.
Reply
#6
@ant_thomas,

Please post back if you filed the ticket on this, no need to have it submitted twice.

Thanks,

D.
Reply
#7
I have been testing a little more and I am confused. If I stop VDR first then unload the saa716x_tbs_dvb module manually and then suspend and resume the system reload the module and restart vdr everything works but as soon as I try and do it as part of a script during suspend and resume it will not play live tv after resume. I have tested both xvdr and vnsi now. If I resume and then restart vdr manually live tv will work with vnsi but not with xvdr.
I was thinking of loading up a vdr backend that would run all the time but I would still run into this issue I think as the frontend and client would still need to resume and connect to the backend across the network.

I may try a new mythsetup I have been testing both tvheadend and vdr going on 6 months and cannot come up with a solid working solution. my 10.04 mythbackend still is solid as a rock going on over 1.5 years since it has been shutdown or rebooted.

D.
Reply



Logout Mark Read Team Forum Stats Members Help
Suspend Resume TBS 6922 issues00