Thread Rating:
  • 0 Vote(s) - 0 Average
iPad - No recursive scanning for TV shows content
#1
Bug 
My TV Shows content is set up on my hard drive in directories in the following nature:
.../TV Shows/Some Show Name/Season X/Some Episode.mkv
In the windows version I could tick 'scan recursively' after choosing the TVDB scrapper but on my iPad this is not available and thus these shows are missing from my iPad xbmc library. (the scan recusrively options is available only for movies for some reason)
Was it forgotten or am I missing something?
Ideas? Thoughts?

Thanks
Reply
#2
What network protocol are you using (NFS, SMB, AFP, FTP, UPnP, etc) to the iPad?
Reply
#3
(2012-03-28, 00:08)Ned Scott Wrote: What network protocol are you using (NFS, SMB, AFP, FTP, UPnP, etc) to the iPad?

SMB
Reply
#4
TV Show scrapers always work recursively, thus there is no option (nor has there ever been one).
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#5
I have just jailbroken my new Apple TV 2 (not easy, considering I first had to 'downgrade' it), have installed XBMC and am having the same problem.

There is no recursive option for TV shows, and when the library updates it downloads the general information for the TV show, but does not seem to look any deeper. There are no episodes listed for any of the TV shows.

Does anyone have a solution to this?
Reply
#6
Well, I've played around a bit and it seems that it doesnt like the 'Season X' folder. Have tested with one show so far and it works if all the episodes are just in the 'Show Name' directory. If there are episodes from more than one season it will automatically sort them in XBMC

Now to go and pull everything out of season folders and reconfigure 'The Renamer'.... *sigh*

Just thinking, perhaps this is something to do with the latest version of XBMC? My laptop stopped updating new TV shows a couple of days ago too..

A quick test shows that it now sees the new episodes for the same folder I tested above, but no other new episodes added today.
Well, now that I've gone and moved everything it seems this wasnt the solution.

I'm stumped.
Reply
#7
This is completely false.

XBMC doesn't care one iota if you have Season X folders or not.

Moving your episodes will simply change the hash, which means the scanner will re-scan them.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#8
Hi

For some reason when I moved the first show to try it out, it found the episodes, but as stated later this did not work for any of the other shows so obviously not the problem.

Still stumped and looking for a solution...
Reply
#9
The Debug Log as always is your first point of call. Enable debuglogging, refresh a show, if it doesn't work, grab the Debug Log and post.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#10
Thanks for your help

I've only used unix very basically and a long time ago. I can find the xbmc.log file in my ATV, but I have no idea how to either view it and copy/paste the details into a text editor, or somehow copy the file from the ATV on to my computer. Yes, I have tried googling but no luck (maybe im using the wrong search terms?) - any assistance appreciated
Reply
#11
Give this a go:

http://forum.xbmc.org/showthread.php?tid=127108
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#12
I've just tried this. Installed, entered my email address but I haven't received an email 20 min later, and I cant get the program to run again - nothing happens when I click on the icon to launch...
Reply
#13
The read the Debug Log link - it shows exactly where the file is located on all types of OS.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#14
I can find the file using ssh, I just dont know the Unix commands download it so I can post it here

I think Im getting closer, using the scp command, but not sure exactly how to configure

The following seemed to work, but not sure where the 'root' directory is on my laptop - cant find the file in c:/

scp [email protected]:/var/mobile/Library/Preferences/xbmc.log [email protected]
Reply
#15
If you can connect using ssh, then use sftp.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply



No recursive scanning for TV shows content00