Allwinner A10 : Is XBMC ported to MALI-400MP ?
(2012-11-18, 11:56)Vaevictus2 Wrote: You could try
apt-get install wicd wicd-curses and let wicd manage the wifi?

Thank you, I had previously read some of the RaspBMC users going to wicd to deal with their wireless, so I took your advice and tried it.

Until I update the release, here is how to enable WPA support and have a more sturdy network management system.

Put your network on WEP to install the packages you will need

run "iwlist wlan1 scanning|grep ESSID" and make sure your network is visible

run the following -

"ifdown wlan1"

"iwconfig wlan1 essid "YOURNETWORKNAME" key "YOURKEY"

for "YOURKEY", if you used a passphrase to generate your keys, you cannot use that passphrase here, you MUST enter the key.

"ifup wlan1"

"apt-get install wicd wicd-curses"

If you get a screen asking you to add a user to the network group, tab to the only user available, select it, and tab to the okay button and select enter.

"apt-get remove --purge network-manager"

"service wicd start"

"wicd-curses"

Now use the right arrow key on the network you want to configure, scroll to the bottom, set your key, enable auto-connect, and sharing the settings for all SSIDs with the same name. Press F10 to save, and press enter on the network to connect.

Congrats, now use the watchdog script to manually start up xbmc and try it. If all seems well, re-enable the daemon/autoboot and confirm that it all works. I personally started seeing CPU spikes using wicd, but perhaps with some configuring it'll settle down.

(2012-11-18, 16:17)FreddyAV Wrote: I have this stick: http://dx.com/p/rikomagic-mk802-android-...ram-149384
in which I have inserted a class 10 16Gb microSD with the above image (from page 127) and added an additional ext4 partition with 6 movies. I did not make any other changes to the image.

I don't particularly think that your SD card is the problem here. Check the profiles that were confirmed working, and try to encode using those to see if they play correctly.

Lucky for you, I have one of those sticks coming to me, and plan on using it as my next build platform, so I'll try to resolve any issues that it has once I get it. Thanks for letting me know.

Also, the cursor blinking is mentioned in the release post. I'll correct it once the release is more functional and doesn't require dropping to command line to configure it.
Reply
 
Thread Rating:
  • 15 Vote(s) - 4.13 Average


Messages In This Thread
RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - by servili007 - 2012-11-18, 18:35


Logout Mark Read Team Forum Stats Members Help
Allwinner A10 : Is XBMC ported to MALI-400MP ?4.1315