• 1
  • 85
  • 86
  • 87(current)
  • 88
  • 89
  • 104
Allwinner A10 : Is XBMC ported to MALI-400MP ?
You could try
apt-get install wicd wicd-curses and let wicd manage the wifi?
First let me say, thanks for all your efforts!

I have this stick: http://dx.com/p/rikomagic-mk802-android-...ram-149384
in which I have inserted a class 10 16Gb microSD with the above image (from page 127) and added an additional ext4 partition with 6 movies. I did not make any other changes to the image.

It boots nicely into XBMC but I am having severe issues with the graphics while playing movies. One AVI makes XBMC crash (and automatically restart, nice feature btw). Two of them are 720p files which were not encoded by me (they are the ones that do best, image-artifact-wise, almost OK besides being somewhat slow and slightly worse image quality than I am used to for these files). The rest of them are slow and with loads of missing blocks / purple screens / uneven play (Image is alright for one second, then missing blocks for the next second and the purple/pink with missing blocks for a couple of seconds and the back to alright again). These three movies I did encode by myself from DVD using Handbrake and the iPad setting (adjusted to 25fps), and hence SD. Only one of the movies are live action movies, the rest are animated ones.

One other minor thing is that I can see the cursor from the tty login blinking through the graphics/video of XBMC a few times a second.

Please let me know what I can do to help! (I'm in Adelaide, which usually means logged on at times most of you won't be)


Could parts of the problem come from my microSD being too slow I wonder? I wouldn't expect it but you never know. I will try with an external USB stick or drive tomorrow.
(2012-11-18, 11:56)Vaevictus2 Wrote: You could try
apt-get install wicd wicd-curses and let wicd manage the wifi?

Thank you, I had previously read some of the RaspBMC users going to wicd to deal with their wireless, so I took your advice and tried it.

Until I update the release, here is how to enable WPA support and have a more sturdy network management system.

Put your network on WEP to install the packages you will need

run "iwlist wlan1 scanning|grep ESSID" and make sure your network is visible

run the following -

"ifdown wlan1"

"iwconfig wlan1 essid "YOURNETWORKNAME" key "YOURKEY"

for "YOURKEY", if you used a passphrase to generate your keys, you cannot use that passphrase here, you MUST enter the key.

"ifup wlan1"

"apt-get install wicd wicd-curses"

If you get a screen asking you to add a user to the network group, tab to the only user available, select it, and tab to the okay button and select enter.

"apt-get remove --purge network-manager"

"service wicd start"


Now use the right arrow key on the network you want to configure, scroll to the bottom, set your key, enable auto-connect, and sharing the settings for all SSIDs with the same name. Press F10 to save, and press enter on the network to connect.

Congrats, now use the watchdog script to manually start up xbmc and try it. If all seems well, re-enable the daemon/autoboot and confirm that it all works. I personally started seeing CPU spikes using wicd, but perhaps with some configuring it'll settle down.

(2012-11-18, 16:17)FreddyAV Wrote: I have this stick: http://dx.com/p/rikomagic-mk802-android-...ram-149384
in which I have inserted a class 10 16Gb microSD with the above image (from page 127) and added an additional ext4 partition with 6 movies. I did not make any other changes to the image.

I don't particularly think that your SD card is the problem here. Check the profiles that were confirmed working, and try to encode using those to see if they play correctly.

Lucky for you, I have one of those sticks coming to me, and plan on using it as my next build platform, so I'll try to resolve any issues that it has once I get it. Thanks for letting me know.

Also, the cursor blinking is mentioned in the release post. I'll correct it once the release is more functional and doesn't require dropping to command line to configure it.
I've been watching this thread for awhile and am excited that my mk802 might be able to run xbmc. I've been waiting on my microsd card for awhile but it should be here Monday. I was able to purchase a cheap usb to rj45 on ebay and it works great under android. Hopefully it will work within xmbc.

Keep up the good work.
Oh, sorry about missing that in the release post.

Anyways, I downloaded the eight samples from the CedarX samples page found in the release post on page 127. I currently only at 720p (how do I change that? Change evb.bin? Done that before with an other linaro release) so I only tried files 2, 4, 6, 7 and 8 this time around. What I get is:

Sample 2: Plays well.
Sample 4: Jerky play all the way through. Wouldn't consider stating that it works. Image is alright though.
Sample 6: Plays alright the last 2 seconds, before that jerky and stuttering. Image alright (i.e. no block artifacts etc)
Sample 7: Plays like a slide-show. My guess is that it is only showing me I-frames. Audio is running.
Sample 8: Seems to be running at the correct speed, but half of the movie is all white/90% white blocks.

Looking at the CedarX samples page, this seems to contradict the results posted on that page. Am I using the wrong evb.bin or is this probably due to other minor differences between the Hackberry and the MK802 II?

As a side note, there is no support for wlan on the MK802 II. The module rtl8192cu is loaded but it is apparently not sufficient for even detecting the card and its MAC etc (i.e. it is missing from dmesg), but I'm guessing this will be fixed soon Smile ?

I will capture some TV commersials and encode through different profiles in HandBrake and test those too. Will try today or tomorrow.
EDIT: Hmmm... I will probably try more samples from http://samplemedia.linaro.org/ first.

It would be *really* interesting to have a write up of what you did to compile this SD-card image!

Is there anything else I can do at the moment to help out?

I'm working from an Oval Elephant (Uhost U1A), so perhaps there are some differences. As I said, I have the same device as you on its way to me, so I'll be looking into fixing whatever inconsistencies there are in compatibility.

What I would suggest for you is, if you have a linux system and time handy, compiling your own bootloader, script.bin, and kernel from the latest source (MK802 II is what you have and is already in their model tree, so it should be easy) and using a1x-media-create.sh to overwrite the bootloader, script, and kernel of the release on your SD card with your own (using the norootfs argument). More information is available at http://linux-sunxi.org/FirstSteps
mele a2000 owner here.

How do the recent findings transfer to this device?
Yeah, I am on Linux and I just got a new HDD yesterday for the end of having room to cross compile for the MK802. I read somewhere that the hardware packs produced for the MK802 by the scripts you refer to is OK for other models than the MK802. For the MK802 it apparently crashes the kernel (http://www.cnx-software.com/2012/07/20/n...are-packs/ mentions issue 46 which does not seem to be resolved just yet). Don't know if that is still relevant information. Do you know anything about this? Anyone else know?

I guess I will discover soon enough though Smile

Will report back on any success with my own compiles.

(2012-11-19, 05:23)hansarsch Wrote: mele a2000 owner here.

How do the recent findings transfer to this device?

you have to write the image to sd card using win32 imager writer, then replace the script.bin with the one from guillaume's image in the first partition. then edit /etc/network/interfaces and your first line should be "auto lo eth0" without quotes. this will enable wired network.

xbmc interface works like charm.. for playback i have only tested .avi files which crashes xbmc.. i will do extended testing when i go back home.

A great program is out there called mediainfo, you run it on a file and it outs a text file telling you everything there is to know about the file, like what encoding settings were used and what profile. I'm no developer and have no chance in hell of adding real code to the port, however posting the mediainfo files of the files that do work and don't work should be a great help (I remember it helped me find out that movies encoded on a special setting of x264 all didn't work on the raspberry pi, luckily I only had two of those movies, don't remember if they fixed it, however at least I knew why it wasn't working).

Also, I own an MK802 too! Got it for $40, couldn't resist on the hope that one day someone will get XBMC working on it. Good luck!
A few points te give it a review, its works thats great, however, wifi is not the best, buffering buffering... also when i add an usb stick, external drive, it doesnt see it. Also i've tryied to use "PimpMyMele" to copy the SD image to NAND flash, either that doesn't work, it woule be nice, perhaps it should work a bit faster Smile When i used PimyPyMele, select copy to NAND and he asked to reboot the OvalElephant but... nothing is changed, he needs to boot from SD. Somebody any sugestions?
Just got my WPA2 network up using wicd.

It didn't go as straight forward as the instructions and at first wicd-curses was giving me dbus errors.

I eventually had to remove dbus wicd and wicd-curses and re-install them. If anyone else has a similar issue do this;

apt-get remove --purge dbus
apt-get update
apt-get install dbus wicd wicd-curses

all should be well after that.

I think it would be good to start thinking about where this is heading. It would be worthwhile stripping out all the unnecessary stuff now (x etc) and lightening down the base.

Initial releases should default to the command line for network setup until we have configurable network from inside XBMC - without ssh its a pain trying to work on SoC based systems.

then the hard work begins of getting HWA as robust as we can.

All in all a pretty nice initial release. I'm going to go test some media.


If you want to get rid of the blinky cursor during your testing do this;

cd /etc/init/
cp tty1.conf tty1.conf.bac
rm tty*.conf

then if you ever want tty1 back just rename tty1.conf.bac back to tty1.conf
Initial findings are the same as most other people - some videos are laggy some cause the xbmc deamon to die and restart - I'll add to the cedarx docs.

1Channel Addon is working but lags and frame drops

smb shares come across nicely

gui feels snappy but does have slight vertical tearing - didn't try enabling vsync yet

oh this is all running a 1080p evb.bin
Wifi settings changed at home (just another channel) and its now playing without buffering.. Skyfall 15min from 1channel without lags so thats good. Polish Weeb.tv works also better, there where some lags but i guess its the wireless connection it self. Perhaps i should build an external antenna to the OvalElephant. First of all i am wondering how to flash that SD card to the NAND flash? It would be work quicker. Also before i do that i have to install openssh-server on it to connect it remotely. I'm tired to modify the sd card on ubuntu every time Smile
If anyone wants to lighten out the build -

apt-get remove --purge x11-common
apt-get autoremove --purge

this should strip out all the x11 stuff and some other redundant packages

Further testing;

quite a lot of 1channel content is actually running well - you need to press pause as soon as it starts and go do something for a couple of minutes. After that it runs most stuff in sync and with out problems

Now to try and get Lirc working.
  • 1
  • 85
  • 86
  • 87(current)
  • 88
  • 89
  • 104

Logout Mark Read Team Forum Stats Members Help
Allwinner A10 : Is XBMC ported to MALI-400MP ?15
This forum uses Lukasz Tkacz MyBB addons.