Allwinner A10 : Is XBMC ported to MALI-400MP ?
Very strange.

I reboot Cubieboard and then run xbmc.bin : it works. In my TV I watch XBMC main screen
I stop xbmc.bin
I start xbmc.bin again but nothing in my TV: black screen.
xbmc is running but nothing is showed in my TV

It's like xbmc run correct only the first time.
I need to reboot to have again xbmc main screen, but only the first time I run it.

I've tried to rmmod mali && modprobe mali without success.
Nothing strange in dmesg
Code:
first run ok
[  291.340000] Warning: this sunxi disp driver will see significant redesign.
[  291.340000] Applications using /dev/disp directly will break.
[  291.350000] For more information visit: http://linux-sunxi.org/Sunxi_disp_driver
[  291.370000] disp: process 2491 (xbmc.bin) has skipped the version handshake.
[  291.370000] [DISP] layer released: 0,101
[  291.390000] [DISP] released layer not allocated in this session: 0,101
[  291.390000] [DISP] layer released: 0,102
[  291.390000] [DISP] released layer not allocated in this session: 0,102
[  291.410000] [DISP] layer released: 0,103
[  291.410000] [DISP] released layer not allocated in this session: 0,103
[  291.410000] [DISP] layer allocated: 0,101
[  291.420000] [DISP] layer released: 0,101
[  291.420000] [DISP] layer allocated: 0,101
[  291.450000] UMP<2>: New session opened
[  324.010000] UMP<2>: Session closed
[  324.010000] [DISP] layer allocated at close: 0,101

second run: TV black screen
[ 3266.000000] disp: process 6025 (xbmc.bin) has skipped the version handshake.
[ 3266.020000] [DISP] layer released: 0,101
[ 3266.020000] [DISP] released layer not allocated in this session: 0,101
[ 3266.020000] [DISP] layer released: 0,102
[ 3266.050000] [DISP] released layer not allocated in this session: 0,102
[ 3266.050000] [DISP] layer released: 0,103
[ 3266.050000] [DISP] released layer not allocated in this session: 0,103
[ 3266.070000] [DISP] layer allocated: 0,101
[ 3266.070000] [DISP] layer released: 0,101
[ 3266.070000] [DISP] layer allocated: 0,101
[ 3266.080000] UMP<2>: New session opened
[ 3298.060000] [DISP] layer allocated at close: 0,101
[ 3298.060000] UMP<2>: Session closed
Reply
 
Thread Rating:
  • 15 Vote(s) - 4.13 Average


Messages In This Thread
RE: Allwinner A10 : Is XBMC ported to MALI-400MP ? - by ambrosa - 2013-08-25, 09:13


Logout Mark Read Team Forum Stats Members Help
Allwinner A10 : Is XBMC ported to MALI-400MP ?4.1315