Thread Rating:
  • 0 Vote(s) - 0 Average
Linux - Eden - child process doesn't exit after xbmc exit
#1
Hi !

I've a problem, that if i leave xbmc with exit (on ubuntu precise), a child process remains and is only killable with kill -9 . I tried to find out what is spawning that process, but have not been successful so far.

vdr 7999 1 20 08:11 ? 00:00:24 /usr/lib/xbmc/xbmc.bin --standalone --lircdev /var/run/lirc/lircd
vdr 8086 7999 0 08:13 ? 00:00:00 /usr/lib/xbmc/xbmc.bin --standalone --lircdev /var/run/lirc/lircd

in the log xbmc shows a normal exit if that happens, so this child doesn't log anything.

As this child process doesn't occur always its not reproducable on demand.

Does someone have an idea what could cause this or how to find further details about the child process (gdb ?) ?

Killing this process while xbmc is running doesnt seem to have any adverse effect on xbmc (at least not obvious).

Can someone confirm he is seeing the same ? (most likely did not pop up yet as most running xbmc until they shutdown)


Reply
#2
Just as a followup - assumption was that latest nvidia driver has broken something. Indeed this is not the case,
this problem also exist with Intel display driver and on windows according to our feedback. Looks like a race condition/deadlock
Reply
#3
I'm having the same annoying issue.
kill -9 xbmc.bin is needed after a regular xbmc shutdown.
This behaviour is quite new.
Eden beta 3 was alright, only rc2 and release show this behaviour.
Have you filed a bug report?
Reply
#4
With what information i should fill the bug report Smile

Guess a stack trace from the hanging process would be useful. Need to find some time to do it.
I'm occupied by RL at the moment - so feel free to do it - if not happened in a few days i will try to open a bug.
Reply
#5
hi steffen_b,

I was about to file a bug report and tried out a few things to make it more thorough.

I had noticed recently that something's wrong with libvdpau on my (and other people's) system: Youtube via flash hardware acceleration showed everything slightly blue.

That and you mentioning the nvidia driver triggered me to also try deactivating vdpau acceleration in xbmc and, lo and behold, there was no remainder process xbmc.bin after shutdown anymore.

When I switched vdpau acceleration on again, xbmc still shut down properly.

So, I don't know what happened, but switching vdpau off and on must have fixed it.
I don't have an issue with that anymore.

Maybe you might want to try out the same to resolve your issue.
Reply
#6
The only case I know of that this happens with is if you have sync playback to display turned on and you're using Nvidia's 295.20 or higher driver, the child process hangs on locking a mutex, which is done from Nvidia's libGL.
Reply
#7
295.20 is my current version.
Would the mutex hang indefinitely?

Seems my issue hasn't been resolved after all.

I suppose, the workarounds are:
- not to use sync to display (which I don't want for viewing experience)
- go back to previous nvidia drivers (which I can't using the 3.3 kernel)
- wait until nvidia fixes the issue
Reply
#8
It hangs because it's locked and there's no thread in the child process to unlock it.
Reply
#9
Is this causing anyone else problems? I am certainly seeing this, and usually have to switch to tty1 and use "kill -9". I have 64 bit arch linux installed and nvidia drivers (using GT430 silent card), and have kept my system up to date.
Reply
#10
I have the same problem here with a GT520 on xbmcbuntu, with the 295.40 nvidia drivers and "sync playback to display" activated.

Is nvidia aware of the problem?
Reply
#11
I've found that the problem still exists only if you close xbmc in windowed mode from the "x" button in the upper right. If i close via pressing "s" and selecting "EXIT XBMC" then both xbmc and xbmc.bin processes shut down properly - or at least I can't see them listed in System Monitor - Processes (n00bsk1llz)
Windows 10 - 64bit
Intel HD Graphics 5500
Intel i5-5200 CPU
4GB RAM
Boxee Remote
Reply
#12
I'll give that a try, thanks.
If it doesn't work I had an idea to run a cronjob that issues a "killall xbmc" command (or similar) at midnight. My HTPC has MythTV configured to run a script to check if it's idle (which involves checking for xbmc processes) and if idle, shutdown. This pesky xbmc.bin stops that script from working and my HTPC often stays on overnight as a result because I forget to "kill -9" it manually.
Reply



Eden - child process doesn't exit after xbmc exit00