Flatten TV shows Bug?
#1
Hallo,

I am nur sure if this is a bug or intended:

I set "Flatten TV shows" to "Never" in settings.

When I enter TV-Shows-menu (with "hide watched" disabled) and I click on an TV-Show with only one season the next screen I see is the season selection screen. So far exactly as i would expect it. Now when I set "hide watched" to enabled and I enter the same TV show again i come directly to the episode selection screen. I would expect that i come again to the season selection screen. Is this a bug or a feature Wink?

Thanks,
Daniel
Reply
#2
Are they all from the same season though?
Reply
#3
Yes, all episodes belong to the same season.

Example:
“TV-Show XYZ”
- Season3
--Episode_1
--Episode_2
--…
--Episode_20

With "hide watched" disabled i have to select first Season3 and then i can select the episodes belong to season 3 (because I set "Flatten TV shows" to "Never"). This is exactly how i want it to be, i always want to select the season! But if I enable "hide watched" (which I prefer) I jump directly in season3 without having to select it.

Hope this is now a little bit clearer my English is not the best Wink
Reply
#4
Do you have a Debug Log - it might at least confirm which steps it's taking.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#5
Is the problem still not clear? Ohh man, my english seems to be really worse ^^.

Ok, i try it first with images, but if you want i can also upload the log:

This are my (relevant) settings:
Image

No i go to my TV shows as select "Fringe" (I only have season 3):
Image

Now I press the enter key on my keyboard:
Image

PERFEKT! I have to select the season 3 first. Now i press backspace and then activate "hide watched":
Image

Now i select again "Fringe":

No i go to my TV shows as select "Fringe" (I only have season 3):
Image

Press the enter key on my keyboard
Image
and I am here. Why??

If you still need the log where i can upload it. I only knew where i can upload images?

thanks
Reply
#6
I asked for the log for a reason, yes. Use pastebin or similar.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#7
ok, here it is:
http://pastebin.com/iWT5UZD8
Reply
#8
Thanks - I've pinpointed the problem, and fixed in 21fc662.

Cheers,
Jonathan
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#9
Thank you! This was really fast!

This might now be a stupid question but how do i get the fix "21fc662". Do I need to reinstall XBMC or is this fix auto updating?
Reply
#10
Compile it yourself or wait for the Nightles to restart.
Reply
#11
Is this problem solved or is it still there?

For me it's the same. I can't get TV shows with only one season left to NOT flatten. I still want to be able to see what Season it is. I also use the option to only show not watched episodes.

If I change settings, and watch guisettings.xml, it's only changed from "0" or "1".
<flattentvshows>0</flattentvshows> is for "never"
<flattentvshows>1</flattentvshows> is for "if only one season" and "always".

http://piclair.com/4bdlz
http://piclair.com/qkcoo
http://piclair.com/z2au2

/Söder
Vero 4K with unRAID server and mysql (mariadb)
Reply



Logout Mark Read Team Forum Stats Members Help
Flatten TV shows Bug?0
This forum uses Lukasz Tkacz MyBB addons.