Linux Possible x-server crash on startup
#1
XBMCBuntu had been working absolutely fine for a couple of days but when logging out of XBMCBuntu and back into XBMC the GUI informed me that to launch XBMC I needed a graphics card capable of OpenGL. After this it just crashed back to a screen that said:

*Stopping save kernel messages [ok]
Checking for running unattended-upgrades:
*checking battery state... [ok]

When I ctrl alt f2 into another command line window the system works fine in command line but won't start any window manager. As well as this XBMC hasn't generated any crashlog in the /home/xbmc folder where it usually generates them. Now every time I reboot the system it fails to start either lxde or XBMC and just boots into the above screen.

I haven't changed anything on the system except to install samba and set up some shares. The graphics card according to lspci is: nVidia Corporation G98 [GeForce 8400 GS]

Any help with this? Do I need to reinstall the graphics card drivers? If so how do I do this?

Thanks in advance
Reply
#2
Hey there,

i have nearly the same issue, but to me only xbmc is not starting anymore since today. Yesterday everything worked fine.

The crashlogfile give me this error:

Code:
SQL: The database disk image is malformed

and the xbmc.log File give me this error:

Code:
20:32:50 T:3043702528   ERROR: SQL: The database disk image is malformed
                                            Query: SELECT idVersion FROM version

I tried to repair the db, but nothing changed, and my two other clients are still workin great!

sry for overtakin ur thread! Smile

EDIT:

My Problem is solved -> just deleted the local addons.db
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Possible x-server crash on startup00
This forum uses Lukasz Tkacz MyBB addons.