Thread Rating:
  • 0 Vote(s) - 0 Average
Windows - Update Library is adding movies that do not exist in the source
#1
I recently switch from Linux to Windows and in the process upgraded to Eden. I set my movie sources, I have 2 sources, and during the scan a HUGE number of random "films" were added to my library. Films that I'm not even sure exist anywhere let alone on my hard drive. Some had seemingly random names like "tn a45" or "50 000". When I try to play them I get the "This file does not exist. Remove from library?" prompt. Of the random films that were added that actually are real films, I do not actually have them on my hard drive nor have I ever.

In this process the films that I actually DO have on in these sources were also added so I ran a "Clean library" and all the random films were removed.

Adding my TV source was fine. No issues there.

This started last week and I'm still having the same problem when I update my library. If I want to successfully add new films to my library I have to go into Videos, then on each source "Scan for new content". This works, but it would be nice to be able to just do an Update Library rather than scan each source individually.

Log is here: XBMC Log

Happy to answer any questions to help find the problem.
Not sure if this is Windows specific so I put this thread in General.
[Image: sigpic_58772_5db87b45e3eb258c98f0fd01c27194ce.png]
Reply
#2
I had this problem when I had my movies categorised in folders ie Drama, Horror etc
I dumped all my movies into one folder & added that as the source & all was ok.

Don't know if that helps.
Reply
#3
If you bring up info for one of the false movies (press i on the keyboard) and look under "Path", what does it say?
Reply
#4
Sorry for the delay in replying.

Nothing happens when I push 'i' while one of these movies is highlighted. If I bring up the content menu I see:
Queue Item
Play From Here
Add To Favourites
Mark as Watched
Edit Title
Link to TV Show
Remove From Library
Update Library
Now Playing...

It doesn't seem like I mentioned this in my original post but these films only show up under Library, not if I go into my Movies directory through the Videos menu.

I don't have my movies sorted by genre.
[Image: sigpic_58772_5db87b45e3eb258c98f0fd01c27194ce.png]
Reply
#5
I faced the same issue.

I remember one of the files were with the .bin extension located in my previous Windows 7 (Windows.Old) installation.

I tried to remove it from XBMC but it didn't work.

Ended up removing XBMC's folder in APPDATA and started from anew. No such issue after that.
Reply
#6
(2012-04-14, 16:40)avngl Wrote: Ended up removing XBMC's folder in APPDATA and started from anew. No such issue after that.

Ok I'll give this a go. Thanks.
[Image: sigpic_58772_5db87b45e3eb258c98f0fd01c27194ce.png]
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Update Library is adding movies that do not exist in the source00